Aplicações em 32 bits para seu Ubuntu 64 bits (Feisty Fawn)

Aproveitando as férias de meio de ano resolvi instalar o Ubuntu Feisty Fawn 64 bits no computador e posso dizer claramente que foi uma ótima escolha. Li vários artigos e passei por vários fóruns pesquisando como rodar aplicativos 32 bits em sistemas 64 bits e isso é algo realmente simples.

[ Hits: 51.169 ]

Por: Perfil removido em 24/07/2007


De onde parti e bibliotecas necessárias



Como muitos, possuo um computador com processador 64 bits e sempre tive uma certa insegurança em relação a usar um sistema com 64 bits.

Aproveitando as férias de meio de ano resolvi instalar o Ubuntu Feisty Fawn 64 bits no computador e posso dizer claramente que foi uma ótima escolha.

Bom, li vários artigos (muitos aqui do próprio VOL) e passei por vários fóruns pesquisando como rodar aplicativos 32 bits em sistemas 64 bits. E isso é algo realmente simples. =)

Resolvi fazer uma mescla de artigos, wikis e fóruns e escrever um artigo simplificando a vida de que está com o Feisty Fawn e não quer correr atrás de pedaços de informações, como eu fiz.

Bibliotecas necessárias

As bibliotecas necessárias são, à priori, 3. E você pode pode instalá-las com um simples:

$ sudo apt-get install ia32-libs
$ sudo apt-get install ia32-libs-gtk
$ sudo apt-get install ia32-libs-sdl


Feito isso estamos prontos para instalar alguns programas que geralmente dão problema, como o Firefox (devido ao flash), alguns programas multimídia e seus plugins para o navegador já citado.

    Próxima página

Páginas do artigo
   1. De onde parti e bibliotecas necessárias
   2. Firefox + Java + Flash
   3. Mplayer + MplayerPlugin
   4. Considerações finais e agradecimentos
Outros artigos deste autor

LVM completo e sem mistérios

Avaliando as dicas de segurança do Banco do Brasil

Como instalar Postgres 8 no Linux em 10 passos rápidos

Armazenamento de arquivos em Linux: um estudo de caso

Lançamento do GFP 0.1.4.5 - Gerenciador Financeiro Pessoal

Leitura recomendada

Linux - Quota de disco

Osiris - Integridade do sistema de arquivos

Raid 1 com mdadm

Replicando e distribuindo armazenamento de arquivos através de quatro servidores usando Cluster (GlusterFs) no Debian Lenny

Visão geral sobre o Raid

  
Comentários
[1] Comentário enviado por removido em 24/07/2007 - 22:24h

Seu matralha:

não tenho pc de 64 bits - quem me dera - mas ao ver seu artigo achei que leria palavras cabalísticas dum mais profundo mistério a que nenhum iniciado teria acesso.

Rapaz, que moleza!!!!!

Um excelente trabalho e, acima de tudo, econômico e completo ao mesmo tempo (nem eu consigo ser simples assim)...

Parabéns!
;-)

[2] Comentário enviado por m4rc310 em 27/07/2007 - 23:25h

Também funcionou no meu debian sid!
Faz tempo que eu usava o videodownloader. Agora não preciso mais.
Valeu!

[3] Comentário enviado por mslackv em 09/08/2007 - 14:25h

Muito bom artigo, parabéns!!!! Só uma dica, antes de instalar os pacotes acima do firefox, é necessário instalar antes os seguintes:

Pacote ia32-libs
Pacote ia32-libs-gtk
Pacote linux32
Pacote gsfonts-x11

[4] Comentário enviado por removido em 09/08/2007 - 16:01h

Então, mslackv, se você estiver usando ubuntu, não.
Se você utilizar o ubuntu precisará apenas instalar as 3 libs citadas na primeira página do artigo, as outras já vem no sistema ou são baixadas como dependências.

[]'s

[5] Comentário enviado por mvzereks em 19/08/2007 - 15:46h

Muito bom seu artigo matralha. Mas tenho uma dúvida com relação ao uso do Firefox-32 no Kubuntu-64: Ele acessa sites de bancos? Principalmente o Banco do Brasil e CEF? Agradeço por sua atenção.

[6] Comentário enviado por removido em 19/08/2007 - 16:43h

Mvzereks,

Tem um java genérico de 64bits. Esse capota em sites de bancos.
Mas se o java for instalado no firefox32 bits, conforme o artigo, funciona sim.

[]'s.

[7] Comentário enviado por removido em 27/08/2007 - 00:36h

Galera. Queria dizer que estava errado!

Como disse o MSLACKV, é necessário instalar também o linux32 e o gsfonts-x11.
Quando fiz esse artigo, já possuia taias paoctes instalados no PC, então nem notei a falta dele.

MSLACKV, desculpa por ter discordado de você em primeira instância e obrigado pela dica.

[]'s

Fabiano.

[8] Comentário enviado por shirglei em 31/10/2007 - 15:39h

E quanto ao restante dos aplicativos, Xmms, K3B, Kopete, etc... como proceder a instalçaõ deles? no ubuntu 64 bits o firefox ja vem instalado!!!!

[9] Comentário enviado por removido em 31/10/2007 - 16:20h

shirglei, não sei o quão por dentro dos sistemas 64bits você está mas acontece o seguinte:

- Firefox64 bits já vem instalado. Só que Flash só tem para 32bits... resumindo, você tem seu firefox, mas sem youtube, sites de banco e algumas coisinhas mais.
- K3B, Kopete, você instsala com sudo apt-get install. Esses pacotes vem por padrão no KDE, que está portado já para 64bits
- Xmms, realmente não sei te responder.

Bom. Abraço rapaz.
E boa sorte.,

[10] Comentário enviado por mestrekame em 14/05/2008 - 10:25h

?comentario=Faleu Fabiano
Estava puto da vida por usar um player generico de flash que dava pau em metade dos sites feitos em flash, fora o youtube.
muito obrigado!

[11] Comentário enviado por mestrekame em 14/05/2008 - 10:26h

ops :) .... é valeu e nao Faleu! :D
abraço

[12] Comentário enviado por removido em 14/05/2008 - 11:23h

=).

Fico feliz em ajudar a comunidade.


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts