Ícones das ferramentas no Inkscape não aparece, mostra um retângulo preto no lugar. [RESOLVIDO]

1. Ícones das ferramentas no Inkscape não aparece, mostra um retângulo preto no lugar. [RESOLVIDO]

Bruno Costa
allbrunofc

(usa Fedora)

Enviado em 02/03/2017 - 02:26h

Sou iniciante no linux e usava o coreldraw no windows, estou tentando usar o inkscape mas não sei resolver esse problema. Tentei instalar pelo gerenciador de programas e pelo rpmfusion mas nada mudou.
Aqui tem uma imagem do meu desktop para vocês entenderem: http://imgur.com/a/Znzgs
Obrigado e desculpe minha ignorância, pode não ser nada para usuários experientes mas para mim é quase o fim do linux na minha maquina kkk.


  


2. Re: Ícones das ferramentas no Inkscape não aparece, mostra um retângulo preto no lugar. [RESOLVIDO]

Guilherme Machado
Ma-chan

(usa Arch Linux)

Enviado em 02/03/2017 - 03:25h

Que estranho. Nunca passei por isso antes. Abra o Nautilus (o Gerenciador de Arquivos) e clique as teclas CTRL+H do teclado. Vai aparecer umas pastas ocultas, veja se tem uma com o nome .inkscape. Se tiver apague-a. Depois vá em .config e procure por uma pasta com o nome inkscape. Se achar, também apague. E tente reabrir o aplicativo.

Ou você pode tentar reinstalar;

sudo dnf reinstall inkscape 


Via Terminal.




O Arch Linux define simplicidade como sem acréscimos desnecessários,
modificações ou complicações, e provê uma estrutura leve e UNIX-like
que permite a um usuário moldar o sistema de acordo com as suas ne-
cessidades. Em suma, uma abordagem elegante e minimalista.



3. Re: Ícones das ferramentas no Inkscape não aparece, mostra um retângulo preto no lugar.

Bruno Costa
allbrunofc

(usa Fedora)

Enviado em 03/03/2017 - 13:41h

Olá, obrigado por responder minha pergunta, fiz o que você pediu mas não resolveu.
Eu reparei, que isso acontece em outros programas também, como por exemplo quando abre uma janéla para eu selecionar alguma coisa.
Ex: http://imgur.com/a/J0qb0
Talvez isso não seja exclusivo do Inkscape.


4. Re: Ícones das ferramentas no Inkscape não aparece, mostra um retângulo preto no lugar.

Bruno Costa
allbrunofc

(usa Fedora)

Enviado em 03/03/2017 - 14:19h

Consegui resolver o problema, acontece que, pelo que entendi, o Fedora 25 usa por padrão o servidor gráfico Wayland, ele é relativamente novo e deve ter seus bugs e esse provavelmente é um, então eu encerrei a cessão com o Wayland e fiz login no Xorg, aparentemente resolveu aquele problema que citei anteriormente. Percebi que no Xorg a interface gráfica não flui como no Wayland, mas não atrapalha.