Webcam não funciona no Ubuntu 14.04 LTS [RESOLVIDO]

13. Re: Webcam não funciona no Ubuntu 14.04 LTS [RESOLVIDO]

Gustavo
gustavo_cunhas

(usa Ubuntu)

Enviado em 23/12/2014 - 13:57h

Bom dia, pessoal.

Tenho o mesmo problema que iniciou este tópico, mas quando cheguei ao penúltimo post do Morvan, aquele no qual ele sugere que se encontre os botoes aceleradores (os que se usa com a tecla Fn), me deparei com o problema de que o meu note nao possui nenhum botao Fn+Câmera! Entao parei por aí. Será que há alguma dica sobre como continuar?

Vou postar as saídas dos comandos de terminal que eu recebi ao tentar descobrir se ela figura nas enumeraçoes de hw:

[email protected]:~$ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 009: ID 1bcf:2082 Sunplus Innovation Technology Inc.
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


[email protected]:~$ lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1c.7 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 8 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
04:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
09:00.0 Network controller: Qualcomm Atheros AR9462 Wireless Network Adapter (rev 01)


[email protected]:~$ lsmod
Module Size Used by
ctr 12905 1
ccm 17496 1
cuse 13213 3
rfcomm 53664 0
bnep 18895 2
ath3k 13110 0
btusb 27580 0
bluetooth 342208 12 bnep,ath3k,btusb,rfcomm
snd_hda_codec_hdmi 45440 1
snd_hda_codec_realtek 59259 1
uvcvideo 71309 0
videobuf2_vmalloc 13048 1 uvcvideo
videobuf2_memops 13170 1 videobuf2_vmalloc
videobuf2_core 39258 1 uvcvideo
videodev 108503 2 uvcvideo,videobuf2_core
ip6t_REJECT 12809 1
xt_hl 12465 6
ip6t_rt 13259 3
nf_conntrack_ipv6 14318 8
nf_defrag_ipv6 26163 1 nf_conntrack_ipv6
ipt_REJECT 12485 1
xt_LOG 17445 10
xt_limit 12541 13
xt_tcpudp 12756 18
xt_addrtype 12563 4
nf_conntrack_ipv4 14492 8
nf_defrag_ipv4 12649 1 nf_conntrack_ipv4
xt_conntrack 12664 16
acer_wmi 31735 0
sparse_keymap 13708 1 acer_wmi
ip6table_filter 12711 1
ip6_tables 17819 1 ip6table_filter
nf_conntrack_netbios_ns 12585 0
nf_conntrack_broadcast 12541 1 nf_conntrack_netbios_ns
nf_nat_ftp 12645 0
nf_nat 20861 1 nf_nat_ftp
nf_conntrack_ftp 14056 1 nf_nat_ftp
nf_conntrack 83685 8 nf_nat_ftp,nf_conntrack_netbios_ns,nf_nat,xt_conntrack,nf_conntrack_broadcast,nf_conntrack_ftp,nf_conntrack_ipv4,nf_conntrack_ipv6
iptable_filter 12706 1
ip_tables 17987 1 iptable_filter
x_tables 22067 13 ip6table_filter,xt_hl,ip_tables,xt_tcpudp,xt_limit,xt_conntrack,xt_LOG,iptable_filter,ip6t_rt,ipt_REJECT,ip6_tables,xt_addrtype,ip6t_REJECT
snd_hda_intel 42730 6
snd_hda_codec 164067 3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep 13272 1 snd_hda_codec
arc4 12536 2
snd_pcm 85501 3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
intel_rapl 18301 0
x86_pkg_temp_thermal 13845 0
intel_powerclamp 14239 0
coretemp 13195 0
kvm_intel 132651 0
snd_page_alloc 14230 2 snd_pcm,snd_hda_intel
ath9k 144602 0
snd_seq_midi 13132 0
kvm 388310 1 kvm_intel
ath9k_common 13359 1 ath9k
ath9k_hw 438205 2 ath9k_common,ath9k
snd_seq_midi_event 14475 1 snd_seq_midi
snd_rawmidi 25135 1 snd_seq_midi
snd_seq 55383 2 snd_seq_midi_event,snd_seq_midi
ath 23922 3 ath9k_common,ath9k,ath9k_hw
crc32_pclmul 12967 0
mac80211 546051 1 ath9k
joydev 17101 0
i915 710093 6
snd_seq_device 14137 3 snd_seq,snd_rawmidi,snd_seq_midi
serio_raw 13230 0
snd_timer 28584 2 snd_pcm,snd_seq
cfg80211 409394 3 ath,ath9k,mac80211
snd 60939 23 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_seq_midi
lpc_ich 16864 0
drm_kms_helper 48868 1 i915
drm 244037 7 i915,drm_kms_helper
soundcore 12600 1 snd
mei_me 18195 0
i2c_algo_bit 13197 1 i915
mei 66737 1 mei_me
parport_pc 31981 0
wmi 18673 1 acer_wmi
ppdev 17391 0
video 18903 2 i915,acer_wmi
intel_rst 12770 0
mac_hid 13037 0
lp 13299 0
parport 40836 3 lp,ppdev,parport_pc
tg3 152160 0
ahci 25579 2
libahci 27214 1 ahci
psmouse 91357 0
ptp 18445 1 tg3
pps_core 18799 1 ptp



Desde já, obrigado pela ajuda!
PS: Como vcs devem ter notado, atmbém tenho problemas com os acentos no teclado, rsrsrs




  


14. Webcam não funciona no Ubuntu 14.04 LTS [RESOLVIDO]

morvan bliasby
Morvan

(usa Fedora)

Enviado em 23/12/2014 - 14:57h

gustavo_cunhas escreveu:
Bom dia, pessoal.
...
[email protected]:~$ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 009: ID 1bcf:2082 Sunplus Innovation Technology Inc.
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
...
uvcvideo 71309 0
videobuf2_vmalloc 13048 1 uvcvideo
videobuf2_memops 13170 1 videobuf2_vmalloc
videobuf2_core 39258 1 uvcvideo
videodev 108503 2 uvcvideo,videobuf2_core
...
Desde já, obrigado pela ajuda!
PS: Como vcs devem ter notado, atmbém tenho problemas com os acentos no teclado, rsrsrs

Boa tarde.
Sua saída (a mais provável, USB) não lista nenhum dispositivo de Vídeo, mas o driver UVCVideo está enumerado nos drivers carregados, o que é estranho. Vou pedir que você nos poste a saída dos seguintes comandos, para desambiguar a questão:
lspci -nn | grep -i vga 
e
lsmod | grep -i video 
.

Se você tiver o ekiga instalado, tente rodá-lo e veja se ele descobre algum dispositivo de vídeo (o vlc também serviria);
Diga-nos o resultado e ficamos no aguardo. Quanto ao teclado, se for acentuação, crie um arquivo texto e escreva nele o seguinte:
setxkbmap -model abnt2 -layout br -variant abnt2 

Torne-o executável:
chmod +x MeuArquivoTexto. 
Coloque um atalho para ele no Dash, se estiver utilizando-o, claro (em "Aplicativos de Sessão"). Pronto. Sempre que inicializar o seu Home, a acentuação estará correta. O Dash tem um bug com reversão do teclado. Para quem usa o KDE, basta colocar um linque para o mesmo arquivo no /home/MeuUser/.Autostart .

Morvan, Usuário GNU-Linux #433640 (Fedora 21_x64). Seja Legal; seja Livre. Use GNU-Linux.




15. Rebrir tópico

Gustavo
gustavo_cunhas

(usa Ubuntu)

Enviado em 23/12/2014 - 16:19h

Por favor, será possível reabrir este tópico?


16. Webcam não funciona no Ubuntu 14.04 LTS [RESOLVIDO]

morvan bliasby
Morvan

(usa Fedora)

Enviado em 23/12/2014 - 16:27h

gustavo_cunhas escreveu:

Por favor, será possível reabrir este tópico?


Boa tarde.

Gustavo, você pode iniciar o tópico, criando-o na seção de perguntas. Ou pode continuar a discussão, como ora o fazemos; não sei o que é mais prático, dos pontos de vista seu e da Moderação. Alguém da Moderação poderia nos informar algo, por favor?

Morvan, Usuário GNU-Linux #433640 (Fedora 21_x64). Seja Legal; seja Livre. Use GNU-Linux.


17. Re: Webcam não funciona no Ubuntu 14.04 LTS [RESOLVIDO]

Gustavo
gustavo_cunhas

(usa Ubuntu)

Enviado em 23/12/2014 - 16:58h

Ops, desculpe Morvan! Eu nao havia recebido sua resposta.

vou tentar seguir as instruçoes e em breve posto o resultado.

E desde já, muito obrigado pela atençao!


18. Re: Webcam não funciona no Ubuntu 14.04 LTS [RESOLVIDO]

Gustavo
gustavo_cunhas

(usa Ubuntu)

Enviado em 23/12/2014 - 17:02h

Olá Morvan. Aqui vao os outputs:

[email protected]:~$ lspci -nn | grep -i vga
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)

*VGA escrito em vermelho

[email protected]:~$ lsmod | grep -i video
uvcvideo 71309 0
videobuf2_vmalloc 13048 1 uvcvideo
videobuf2_memops 13170 1 videobuf2_vmalloc
videobuf2_core 39258 1 uvcvideo
videodev 108503 2 uvcvideo,videobuf2_core
video 18903 2 i915,acer_wmi

*video sempre escrito em vermelho


19. Webcam não funciona no Ubuntu 14.04 LTS [RESOLVIDO]

morvan bliasby
Morvan

(usa Fedora)

Enviado em 23/12/2014 - 17:22h

gustavo_cunhas escreveu:

Olá Morvan. Aqui vao os outputs:

[email protected]:~$ lspci -nn | grep -i vga
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)

*VGA escrito em vermelho

[email protected]:~$ lsmod | grep -i video
uvcvideo 71309 0
videobuf2_vmalloc 13048 1 uvcvideo
videobuf2_memops 13170 1 videobuf2_vmalloc
videobuf2_core 39258 1 uvcvideo
videodev 108503 2 uvcvideo,videobuf2_core
video 18903 2 i915,acer_wmi

*video sempre escrito em vermelho


Boa tarde.
O seu note não tem aquelas teclas de função que eu falei, no início do tópico, ou uma chave tipo liga-desliga? Porque a câmera parece não ser detectada, ainda. Outra coisa. Procure instalar algum software para teste; pode ser o ekiga ou o vlc.
Com uma excelente ferramenta de detecção de hardware, como o lshw, teremos nosso trabalho facilitado. Se você ainda não dispõe do lshw, instale-o:
sudo apt-get install lshw

depois, execute este comando e publique o arquivo invent.gustav.note.html, pelo menos a parte da detecção de dispositivos USB:
sudo lshw -html > invent.gustav.note.html .


Com o lshw e os parâmetros passados, você terá uma fotografia de tudo o que a sua máquina possui, em termos de HW, em formato html. Este comando eu executo em cada máquina que chega e que sai do meu laboratório e forneço uma cópia do arquivo ao proprietário. É seguro para mim e para ele, pois ele, o proprietário, não pode alegar possuir dispositivo não listado no arquivo html.
Aguardamos.

Morvan, Usuário GNU-Linux #433640 (Fedora 21_x64). Seja Legal; seja Livre. Use GNU-Linux.



20. Re: Webcam não funciona no Ubuntu 14.04 LTS [RESOLVIDO]

Gustavo
gustavo_cunhas

(usa Ubuntu)

Enviado em 23/12/2014 - 18:11h

Boa tarde, Morvan.

Eu já tenho vlc instalado e tentei o Ekiga. O que acontece quando faço o teste de câmera é que apenas o símbolo do programa aparece na janela, ou seja, nada de imagem.

Eu também já possuía o lshw, que após o comando que vc sugeriu me resultou nisso aqui:

[email protected]:~$ sudo lshw -html > invent.gustav.note.html .
Hardware Lister (lshw) - B.02.16
uso: lshw [-format] [-options ...]
lshw -version

-version imprime a versão do programa (B.02.16)

formato pode ser
-html gera saída de árvore de hardware como HTML
-xml gera saída de árvore de hardware como XML
-short gera saída dos caminhos de hardware
-businfo gera saída de informações de barramento

opções podem ser
-class CLASS mostra somente uma classe de hardware
-C CLASS o mesmo que '-class CLASS'
-c CLASS o mesmo que '-class CLASS'
-disable TESTE desativa um teste (como pci, isapnp, cpuid, etc. )
-enable TESTE ativa um teste (como pci, isapnp, cpuid, etc. )
-quiet não exibe o status
-sanitize sanear saída (remove informações confidenciais como números de série, etc.)
-numeric gera saída de IDs numéricas (para PCI, USB, etc.)


Era isso que você queria?

Muito obrigado!




21. Re: Webcam não funciona no Ubuntu 14.04 LTS [RESOLVIDO]

Gustavo
gustavo_cunhas

(usa Ubuntu)

Enviado em 23/12/2014 - 18:20h

ah, sim!

Meu PC (ACER Aspire m5) nao tem chave liga e desliga e entre as teclas Fn nenhum é relativa à câmera.

A propósito do problema, achei um cara que tem o problema exatamente igual ao meu:

http://ubuntuforums.org/showthread.php?t=1937857&highlight=video+skype

Meu problema vai idêntico até o post 14, mas o output dele é diferente do meu.


Output dele:

"Ok, now post the output of
Code:

ls /usr/lib/i386-linux-gnu/libv4l

Code:

ov511-decomp ov518-decomp v4l1compat.so v4l2convert.so

ov511-decomp and ov518-decomp are both in bold green text"


Meu output:

[email protected]:~$ ls /usr/lib/i386-linux-gnu/libv4l
plugins v4l1compat.so v4l2convert.so

(com 'plugins' escrito em azul.

Obrigado


22. Re: Webcam não funciona no Ubuntu 14.04 LTS [RESOLVIDO]

morvan bliasby
Morvan

(usa Fedora)

Enviado em 23/12/2014 - 20:24h

gustavo_cunhas escreveu:

Boa tarde, Morvan.
...
sudo lshw -html > invent.gustav.note.html . ...


Boa noite.
O comando é:
sudo lshw -html > invent.gustav.note.html
(sem os sinais de pontuação. Por isso que espacei. Aqui funciona e gera o html com o meu inventário da máquina.
Peço desculpa por ter, eventualmente, induzido o erro. Teste e veja na Classe USB se ele lista alguma câmera (ela pode estar atada ao PCI, mas é muito improvável).

Morvan, Usuário GNU-Linux #433640 (Fedora 21_x64). Seja Legal; seja Livre. Use GNU-Linux.




23. Webcam não funciona no Ubuntu 14.04 LTS [RESOLVIDO]

morvan bliasby
Morvan

(usa Fedora)

Enviado em 23/12/2014 - 20:35h

gustavo_cunhas escreveu:

ah, sim!

Meu PC (ACER Aspire m5) nao tem chave liga e desliga e entre as teclas Fn nenhum é relativa à câmera.

A propósito do problema, achei um cara que tem o problema exatamente igual ao meu:

http://ubuntuforums.org/showthread.php?t=1937857&highlight=video+skype

Meu problema vai idêntico até o post 14, mas o output dele é diferente do meu.
...

Boa noite.
Gustavo, enquanto não pudermos determinar se a sua câmera está ou não listada, não podemos partir para o passo 2 (software). Neste aspecto, são problemas diferentes, ainda. Temos que identificar se o hardware está sendo detectado e enumerado. Por isso pedi que utilizasse o lshw.
Após sabermos sobre a máquina, podemos partir para o software. No caso dele, a máquina estava detectando o dispositivo. Era pacote quebrado, certamente, uma vez que o V4L[2] é instalado por default.

Morvan, Usuário GNU-Linux #433640 (Fedora 21_x64). Seja Legal; seja Livre. Use GNU-Linux.



24. Re: Webcam não funciona no Ubuntu 14.04 LTS [RESOLVIDO]

Gustavo
gustavo_cunhas

(usa Ubuntu)

Enviado em 23/12/2014 - 21:28h

Boa noite Morvan.

Obrigado por toda a ajuda por enquanto. É muito legal ver como os usuários de software livres podem nos ajudar

Meu problema é que nao sei acontece nada depois do comando 'lshw'.

Será qeu nao estou entendo exatamente o que é pedido?








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts