Erro em dependências do APT

1. Erro em dependências do APT

Lucas Barbosa Leite Silva
NerdLucas

(usa Linux Mint)

Enviado em 18/03/2020 - 16:13h

Fala glr, sou novo na comunidade, perdão se não criei nas configurações corretas o tópico

A um bom tempo instalei o Linux Mint 19.2 Tina, e ao tentar instalar o mysql ocorreram uns erros que acabaram "travando o meu apt"
Toda vez que tento instalar alguma coisa dá o seguinte erro.
Tentando instalar o gedit por exemplo:
~$ sudo apt-get install gedit
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
gedit : Depende: gedit-common (>= 3.28) mas não será instalado
Depende: gedit-common (< 3.29) mas não será instalado
mysql-server-5.7 : Depende: mysql-client-5.7 (>= 5.7.29-0ubuntu0.18.04.1) mas 5.7.28-0ubuntu0.18.04.4 está para ser instalado
Depende: mysql-server-core-5.7 (= 5.7.29-0ubuntu0.18.04.1) mas 5.7.28-0ubuntu0.18.04.4 está para ser instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).


Quando executo o apt --fix-broken install ele me retorna isso:
:~$ sudo apt --fix-broken install
apt
Usage: apt command [options]
apt help command [options]

Commands:
add-repository - Add entries to apt sources.list
autoclean - Erase old downloaded archive files
autoremove - Remove automatically all unused packages
build - Build binary or source packages from sources
build-dep - Configure build-dependencies for source packages
changelog - View a package's changelog
check - Verify that there are no broken dependencies
clean - Erase downloaded archive files
contains - List packages containing a file
content - List files contained in a package
deb - Install a .deb package
depends - Show raw dependency information for a package
dist-upgrade - Upgrade the system by removing/installing/upgrading packages
download - Download the .deb file for a package
edit-sources - Edit /etc/apt/sources.list with your preferred text editor
dselect-upgrade - Follow dselect selections
full-upgrade - Same as 'dist-upgrade'
held - List all held packages
help - Show help for a command
hold - Hold a package
install - Install/upgrade packages
list - List packages based on package names
policy - Show policy settings
purge - Remove packages and their configuration files
recommends - List missing recommended packages for a particular package
rdepends - Show reverse dependency information for a package
reinstall - Download and (possibly) reinstall a currently installed package
remove - Remove packages
search - Search for a package by name and/or expression
show - Display detailed information about a package
showhold - Same as 'held'
showsrc - Display all the source package records that match the given package name
source - Download source archives
sources - Same as 'edit-sources'
unhold - Unhold a package
update - Download lists of new/upgradable packages
upgrade - Perform a safe upgrade
version - Show the installed version of a package


Tenho reparado em algo estranho, quando abro a minha source.list ele me retorna isso:
:~$ cat /etc/apt/sources.list
#deb cdrom:[Linux Mint 19.2 _Tina_ - Release amd64 20190729]/ bionic contrib main non-freen


E agora estou num fria ainda maior, estou tendo que usar o PostgreSQL, e para intalar tem de ser feitos os seguintes passos:

Passo 1:
Importe a chave do repositório de https://www.postgresql.org/media/keys/ACCC4CF8.asc :

sudo apt-get install curl ca-certificados gnupg
curl https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -

Passo 2
Crie /etc/apt/sources.list.d/pgdg.list . As distribuições são chamadas de codinome -pgdg . No exemplo, substitua o buster pela distribuição real que você está usando:

deb http://apt.postgresql.org/pub/repos/apt buster -pgdg main
(Você pode determinar o nome de código da sua distribuição executando lsb_release -c ). Para uma versão abreviada do acima, presumindo que você esteja usando uma versão suportada:

sudo sh -c 'echo "deb http://apt.postgresql.org/pub/repos/apt $ (lsb_release -cs) -pgdg main"> /etc/apt/sources.list.d/pgdg.list'

Passo 3
Por fim, atualize as listas de pacotes e comece a instalar os pacotes:

sudo apt-get update
sudo apt-get install postgresql-11 pgadmin4


Quando realizo o primeiro comando ele retorna o seguinte:

$ sudo apt-get install curl ca-certificates gnupg
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
ca-certificates is already the newest version (20180409).
curl is already the newest version (7.58.0-2ubuntu3.8).
gnupg is already the newest version (2.2.4-1ubuntu1.2).
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
mysql-server-5.7 : Depende: mysql-client-5.7 (>= 5.7.29-0ubuntu0.18.04.1) mas não será instalado
Depende: mysql-server-core-5.7 (= 5.7.29-0ubuntu0.18.04.1) mas não será instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).

$ curl https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 4812 100 4812 0 0 3275 0 0:00:01 0:00:01 --:--:-- 3275
OK


O passo 2 eu consegui fazer de boas
Porém o passo 3, deu erro no apt-get update

$ sudo apt-get update
Ign:1 http://repositorio.nti.ufal.br/mint tina InRelease
Atingido:2 http://repositorio.nti.ufal.br/mint tina Release
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease
Atingido:4 http://mirror.globo.com/ubuntu/archive bionic InRelease
Atingido:6 http://dl.google.com/linux/chrome/deb stable Release
Atingido:7 http://security.ubuntu.com/ubuntu bionic-security InRelease
Atingido:8 http://archive.canonical.com/ubuntu bionic InRelease
Atingido:10 http://packages.microsoft.com/repos/vscode stable InRelease
Ign:11 http://apt.postgresql.org/pub/repos/apt tina-pgdg InRelease
Err:12 http://apt.postgresql.org/pub/repos/apt tina-pgdg Release
404 Not Found [IP: 72.32.157.246 80]
Atingido:13 http://mirror.globo.com/ubuntu/archive bionic-updates InRelease
Atingido:14 http://mirror.globo.com/ubuntu/archive bionic-backports InRelease
Lendo listas de pacotes... Pronto
E: The repository 'http://apt.postgresql.org/pub/repos/apt tina-pgdg Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.


Ficou meio grande, mas espero que conseguam me auxiliar