Ajuda! Google e sites relacionados Parou de Funcionar [RESOLVIDO]

1. Ajuda! Google e sites relacionados Parou de Funcionar [RESOLVIDO]

Ronimarcos Gonçalves Silva
TioRoni

(usa Debian)

Enviado em 10/04/2013 - 14:01h

Boa tarde pessoal.

Pessoal, estranhamente antes de ontem, todos sites do Google, como Gmail e outros, pararam de funcionar, todos os outros sites entram normalmente, mas os do Google não, como se estivessem bloqueados.

Já mudei DNS, coloquei o da Embratel, mas nada, já tentei tudo que sabia, mas mesmo assim não está funcionando.

uso o Squid 3 + Iptables no Ubuntu 12 autenticado, peço ajuda dos mais experientes, pois possuo pouca experiência em Linux/Iptables/Squid.

Já revi todas regras, limpei o cache e nada.

Aguardo ajuda de vc´s.

Abraços.


  


2. MELHOR RESPOSTA

Buckminster
Buckminster

(usa Debian)

Enviado em 26/04/2013 - 23:08h

madrugada escreveu:

TioRoni escreveu:

madrugada escreveu:

TioRoni escreveu:

Poxa, de todas perguntas que fiz aqui, Ninguém Responde, já estou desanimado.


Não desanime. Configuração de Squid e Iptables é especialidade de um nicho específico. Mas temos profissionais que realmente entendem do assunto.
Dê um "up" no tópico em horários diferentes do dia, que em algum momento um deles vai ler o seu tópico.


Madruga, obrigado por responder, é que nos meus posts, ninguém nem responde para dizer que não sabe. Mas creio que agora animei novamente e vamos ver se os amigos me ajudam.

Abraços.


Disponha.
Viu como valeu apena não desanimar. Se possível escolha a melhor resposta(depois deste tópico o Buckminster merecia um churrasco, rsrs)


Se sair o churrasco você está convidado.

3. Ninguém Responde!

Ronimarcos Gonçalves Silva
TioRoni

(usa Debian)

Enviado em 11/04/2013 - 21:19h

Poxa, de todas perguntas que fiz aqui, Ninguém Responde, já estou desanimado.


4. Re: Ajuda! Google e sites relacionados Parou de Funcionar [RESOLVIDO]

Ricardo Fabiano Silva
madrugada

(usa Gentoo)

Enviado em 11/04/2013 - 23:06h

TioRoni escreveu:

Poxa, de todas perguntas que fiz aqui, Ninguém Responde, já estou desanimado.


Não desanime. Configuração de Squid e Iptables é especialidade de um nicho específico. Mas temos profissionais que realmente entendem do assunto.
Dê um "up" no tópico em horários diferentes do dia, que em algum momento um deles vai ler o seu tópico.


5. Re: Ajuda! Google e sites relacionados Parou de Funcionar [RESOLVIDO]

Buckminster
Buckminster

(usa Debian)

Enviado em 12/04/2013 - 04:06h

TioRoni escreveu:

Poxa, de todas perguntas que fiz aqui, Ninguém Responde, já estou desanimado.


Você olhou os logs?
O servidor acessa os sites do google ou só pararam de funcionar na rede interna?
Tem o sarg instalado ou outro programa gerador de relatórios do Squid?
Testa com os DNSs do google: 8.8.8.8, 8.8.4.4.

Abre o terminal, dá um nslookup www.google.com, vê o IP e testa com o IP direto no navegador.

Depois posta aqui dizendo o que aconteceu.


6. Re: Ajuda! Google e sites relacionados Parou de Funcionar [RESOLVIDO]

Ronimarcos Gonçalves Silva
TioRoni

(usa Debian)

Enviado em 12/04/2013 - 13:30h

Você olhou os logs?
O servidor acessa os sites do google ou só pararam de funcionar na rede interna?
Tem o sarg instalado ou outro programa gerador de relatórios do Squid?
Testa com os DNSs do google: 8.8.8.8, 8.8.4.4.

Abre o terminal, dá um nslookup www.google.com, vê o IP e testa com o IP direto no navegador.

Depois posta aqui dizendo o que aconteceu.[/quote]


Boa tarde.

Em primeiro lugar, obrigado por ter respondido, mas vamos em frente, me animei novamente.

Está muito estranho, como não conseguia resolver o problema, tirei o servidor, um dia depois voltei ele novamente e já estava tudo funcionando normalmente, funcionou normalmente por 1 dia, depois começou tudo novamente, nada que era produto do Google entrava e outros sites também, como Terra, Uol, mas os outros, de bancos e outros, funcionava perfeitamente.

Novamente tirei o servidor, como vc me passou o comando para verificar no linux, voltei o servidor agora novamente e advinha, funcionando normalmente, mas sei que isso vai ficar por um dia, depois vai dar problemas novamente. Mesmo assim, rodei o comando que vc tinha me passado, eis o resultado do comando nslookup www.google.com:

;; connection timed out; no servers could be reached

Quando começou os problemas, eu estava usando os dois dns do Google: 8.8.8.8, 8.8.4.4
depois disso coloquei o Embratel como primário e da Google como secundário.

Esse problema acontece tanto no servidor, como nas estações, estou usando o SARG para gerar os relatórios.

Por favor, me ajude a solucionar esse problema, está muito complicado, tirar o servidor e colocar novamente, a net fica toda liberada quando tiro ele.

Grande abraço e obrigado novamente.


7. Re: Ajuda! Google e sites relacionados Parou de Funcionar [RESOLVIDO]

Ronimarcos Gonçalves Silva
TioRoni

(usa Debian)

Enviado em 12/04/2013 - 13:46h

madrugada escreveu:

TioRoni escreveu:

Poxa, de todas perguntas que fiz aqui, Ninguém Responde, já estou desanimado.


Não desanime. Configuração de Squid e Iptables é especialidade de um nicho específico. Mas temos profissionais que realmente entendem do assunto.
Dê um "up" no tópico em horários diferentes do dia, que em algum momento um deles vai ler o seu tópico.


Madruga, obrigado por responder, é que nos meus posts, ninguém nem responde para dizer que não sabe. Mas creio que agora animei novamente e vamos ver se os amigos me ajudam.

Abraços.


8. Re: Ajuda! Google e sites relacionados Parou de Funcionar [RESOLVIDO]

Ronimarcos Gonçalves Silva
TioRoni

(usa Debian)

Enviado em 12/04/2013 - 15:47h

TioRoni escreveu:

Você olhou os logs?
O servidor acessa os sites do google ou só pararam de funcionar na rede interna?
Tem o sarg instalado ou outro programa gerador de relatórios do Squid?
Testa com os DNSs do google: 8.8.8.8, 8.8.4.4.

Abre o terminal, dá um nslookup www.google.com, vê o IP e testa com o IP direto no navegador.

Depois posta aqui dizendo o que aconteceu.



Boa tarde.

Em primeiro lugar, obrigado por ter respondido, mas vamos em frente, me animei novamente.

Está muito estranho, como não conseguia resolver o problema, tirei o servidor, um dia depois voltei ele novamente e já estava tudo funcionando normalmente, funcionou normalmente por 1 dia, depois começou tudo novamente, nada que era produto do Google entrava e outros sites também, como Terra, Uol, mas os outros, de bancos e outros, funcionava perfeitamente.

Novamente tirei o servidor, como vc me passou o comando para verificar no linux, voltei o servidor agora novamente e advinha, funcionando normalmente, mas sei que isso vai ficar por um dia, depois vai dar problemas novamente. Mesmo assim, rodei o comando que vc tinha me passado, eis o resultado do comando nslookup www.google.com:

;; connection timed out; no servers could be reached

Quando começou os problemas, eu estava usando os dois dns do Google: 8.8.8.8, 8.8.4.4
depois disso coloquei o Embratel como primário e da Google como secundário.

Esse problema acontece tanto no servidor, como nas estações, estou usando o SARG para gerar os relatórios.

Por favor, me ajude a solucionar esse problema, está muito complicado, tirar o servidor e colocar novamente, a net fica toda liberada quando tiro ele.

Grande abraço e obrigado novamente.[/quote]

Para você ter uma idéia, da hora que te enviei a resposta, agora parou de funcionar novamente, tive que tirar o servidor denovo.

Complicado.

Aguardo ajuda.
Abraços.


9. Parou Novamente

Ronimarcos Gonçalves Silva
TioRoni

(usa Debian)

Enviado em 12/04/2013 - 15:53h

Parou Novamente, em menos de 3 horas. Tive que tirar o servidor novamente, minha rede agora está toda aberta, a galera vai fazer a festa.

Aguardo ajuda.


10. Re: Ajuda! Google e sites relacionados Parou de Funcionar [RESOLVIDO]

Buckminster
Buckminster

(usa Debian)

Enviado em 12/04/2013 - 17:58h

TioRoni escreveu:

Parou Novamente, em menos de 3 horas. Tive que tirar o servidor novamente, minha rede agora está toda aberta, a galera vai fazer a festa.

Aguardo ajuda.


Bom, se você rodou o comando nslookup do teu servidor e deu essa mansagem "connection timed out; no servers could be reached" ele não está conseguindo encontrar o DNS.
Testou o nslookup para um outro site qualquer?
Dá um traceroute www.google.com ( no Linux) ou tracert www.google.com (no prompt do Windows) no servidor e em duas estações da rede..
Dá um ping www,google.com.

Você tem squid3 + iptables + DHCP no servidor?
Fala quais os serviços que você tem no servidor.
Como você disse que colocou os DNSs da embratel, julgo que você não tem DNS interno na sua rede, é isso?
A tua conexão é ADSL ou é um link de dados?

Verifique o arquivo HOSTS. No Linux está em /etc/hosts, no Windows em c:\Windows\System32\etc\hosts.
Esse arquivo, se você não mexeu nele, deve conter somente o IP e o domínio da loopback (127.0.0.1 e 127.0.1.1, ou parecido) e mais algum IP no formato ipv6. Se tiver muitos IPs e sites ali dentro (nas estações) provavelmente pode ser algum malware que está redirecionando os sites do google para outo IP.
E se ali dentro estiver algo assim:
0.0.0.0 google.com
0.0.0.0 www.google.com
0.0.0.0 google.com.br
0.0.0.0 www.google.com.br
...
isto siginifica que o google e seus domínios estão bloqueados.
Mas é só uma sugestão.


11. Re: Ajuda! Google e sites relacionados Parou de Funcionar [RESOLVIDO]

Ronimarcos Gonçalves Silva
TioRoni

(usa Debian)

Enviado em 12/04/2013 - 21:29h

Grande Buckminster, obrigado por retornar.

vamos lá:

O Comando nslookup para outros sites dá o mesmo resultado, ou seja, ;; connection timed out; no servers could be reached.
O traceroute no linux, resultado:
www.google.com.br:">www.google.com.br: Nome ou serviço desconhecido
Cannot handle "host" cmdline arg `www.google.com' on position 1 (argc 1)

No Windows:
C:\Users\Roni>tracert www.google.com
Não é possível resolver o nome do sistema de destino www.google.com.

O Ping no linux:
[email protected]:/etc# ping www.google.com
ping: unknown host www.google.com

No Windows:
C:\Users\Roni>ping www.google.com
A solicitação ping não pôde encontrar o host www.google.com. Verifique o nome e tente novamente.

No servidor linux, tenho Squid 3 + Iptables DHCP

Não tenho dns local, eu seto o dns no squid.conf.

Minha conexão é um link de 4 MB Full da Embratel.

O Arquivo de Host do linux está assim:

127.0.0.1 localhost
127.0.1.1 ubuntu

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters


E nas máquinas, o arquivo Hosts não tem nada, estão todos comentados.

Agora mesmo que voltei o servidor, está tudo funcionando, mas daquí umas 2 horas para tudo.
É complicado porque contratamos os serviços do Google, então os emails das empresas rodam tudo no Google, aí se não entra no Google ninguém recebe e-mails, ou seja, para as empresas.

O mais engraçado de tudo, que essa estrutura rodou por mais de mês perfeitamente e de uma hora para outra parou de funcionar.

Por favor, continue me ajudando.
Abraços.


12. Re: Ajuda! Google e sites relacionados Parou de Funcionar [RESOLVIDO]

André Canhadas
andrecanhadas

(usa Debian)

Enviado em 12/04/2013 - 22:05h

O Ubuntu tem muitos bugs com o DNS que para de responder pode procurar que vai achar varios aqui mesmo no VOL eu mesmo ja respondi em uns 4.

A problema é que não se pode mais setar um DSN fixo em /etc/resolv.conf pois ele é alterado pelo network-manager para corrigir isso edite o arquivo /etc/resolv.conf :


sudo nano /etc/resolv.conf


Apague tudo que tiver la e deixe somente as linhas:

nameserver 8.8.4.4
nameserver 8.8.8.8

Feito isso a edição do arquivo precisa ser bloqueada:


#Bloqueia
chattr +i /etc/resolv.conf


Feito isso se precisar editar novamente o arquivo terá que rodar o comando para permitir a edição do arquivo:

chattr -i /etc/resolv.conf


Outra coisa interessante e que pode setar o DNS no squid.conf deixa o acesso inicial um pouco mais rapido

dns_nameservers 8.8.8.8 8.8.4.4


A desvantagem de usar somente este metodo é que a resolução de nomes fica valida somente para o http e https








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts