Configurar o modem Huawei e156c [RESOLVIDO]

1. Configurar o modem Huawei e156c [RESOLVIDO]

Fábio Ribeiro
fabis

(usa Outra)

Enviado em 30/11/2009 - 09:52h

Bom dia etsou iniciando em linux, não quero mais saber de windows.

Amigos seguinte a caus.

Por favor, me ajudem a configurar o modem Huawei e156c da Oi no ubuntu 9.10 ou Mandriva 2010 64 bits, como já disse ante sou totalmente leigo.

No Mandriva quando vou configurar no centro de controle aparece uma mensagem "insira uma midia", Já no ubuntu configuro a rede mas não aparece na lista para conectar.

Muito obrigado!


  


2. tenta este script

Lael Lacerda
Lael

(usa Fedora)

Enviado em 30/11/2009 - 12:46h

#!/bin/bash
#
# Copyright (C) 2009 Valter Ferraz Sanches <[email protected]>
#
# huawei- script shell para configuração rápida em modo texto do modem Huawei E156B no Linux
# com opção de uso do wvdial para discagem
#
# baseado no pacote smartconnect-nogui
#
#
VER="0.1"

cat <<EOF
Bem vindo ao huawei-claro. Este script pretende configurar seu modem Huawei no Linux
da maneira mais rápida e simples possível. Por isso, não fará qualquer teste em seu sistema,
razão pela qual ele deverá ser executado com permissões de 'root'. Qualquer tentativa de
execução sem permissão de escrita em arquivos de sistema resultará em erros.

Isto avisado, pressione ENTER para continuar.
EOF

read crap

echo -n "Escrevendo o /etc/wvdial.conf... "

# cria um backup do wvdial.conf existente se houver um
if [ -f /etc/wvdial.conf ]; then
cp /etc/wvdial.conf /etc/wvdial.conf.old
fi

# cria o novo /etc/wvdial.conf
cat <<EOF > /etc/wvdial.conf
#
# arquivo criado pelo huawei-claro by [email protected]
# baseado nas Configurações Claro 3G / Modem Huawei
# Testado e aprovado por Guilherme Oliveira - [email protected]
# Qualquer erro nessa configuração, comunique os desenvolvedores
# os e-mails estão acima.

[Dialer Defaults]
Modem = /dev/ttyUSB0
ISDN = off
Modem Type = USB Modem
Baud = 460800
Init = ATZ
Init2 = AT+CFUN=1
Init3 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init4 = AT+CGDCONT=1,"IP","bandalarga.claro.com.br"
Init5 =
Init6 =
Init7 =
Init8 =
Init9 =
Phone = *99***1#
Phone1 =
Phone2 =
Phone3 =
Phone4 =
Dial Prefix =
Dial Attempts = 1
Dial Command = ATM1L3DT
Ask Password = off
Password = claro
Username = claro
Auto Reconnect = off
Abort on Busy = off
Carrier Check = on
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = off
Idle Seconds = 0
Auto DNS = on

EOF

# dorme para o usuário ver se deu algum erro...
sleep 3

echo
echo -n "Criando regras para o modem Huawei... "

# cria arquivo de regras atropelando o que tiver la!
cat <<EOF > /etc/udev/rules.d/99-huawei.rules
#
# criado pelo huawei-claro
# código original por
# SmartConnect Huawei - www.linux3g.kit.net
SUBSYSTEM=="block", ACTION=="add", \
SYSFS{idVendor}=="12d1", SYSFS{idProduct}=="1003", \
OPTIONS="ignore_device"

SUBSYSTEM=="usb", SYSFS{idVendor}=="12d1", \
SYSFS{idProduct}=="1003", \
RUN+="/sbin/modprobe usbserial vendor=0x12d1 product=0x1003"
EOF

# dorme pra ver se deu erro...
sleep 3

# ufa, deve estar tudo em cima agora...
echo

echo "Seu sistema já deve estar configurado. Reiniciando o udev.d... "
# Slackware e amigos
if [ -x /etc/rc.d/rc.udev ]; then
/etc/rc.d/rc.udev restart
# Debian/Ubuntu e amigos
elif [ -x /etc/init.d/udev ]; then
/etc/init.d/udev restart
else
echo "IXI!!! Não encontrei o script do udev em seu sistema. Verifique sua instalação."
fi

exit 0


3. Sou muito leigo

Fábio Ribeiro
fabis

(usa Outra)

Enviado em 30/11/2009 - 12:50h

Muito obrigado laelleo!

Qual procedimento devo tomar com esse script.. Sou muito leigo mesmo, se não for pedir demais um passo a passo me ajudaria muito.

Mais uma vez muito obrigado!


4. Re: Configurar o modem Huawei e156c [RESOLVIDO]

Lael Lacerda
Lael

(usa Fedora)

Enviado em 30/11/2009 - 13:02h

aqui ensina o que fazer:

http://aurelio.net/shell/apostila-introducao-shell.pdf


5. ainda não consegui

Fábio Ribeiro
fabis

(usa Outra)

Enviado em 30/11/2009 - 21:20h

Obrigado amigos!

Eu consegui configurar no mandriva, porém minha preferência é o ubuntu 9.10, mais alguém poderia me ajudar, pois realmente estou iniciando e sem net fica muito díficil, minha preferência é pelo ubuntu porque já estou familiarizado com o ambiente.

Obrigado a todos que fazem parte do mundo OS livre. LINUX!


6. No Ubuntu 9.10.

Ednilton Santos de Oliveira
ednilton_so

(usa KUbuntu)

Enviado em 30/11/2009 - 22:11h

Olá,

Se você já configurou pelo network manager, você tem que carregar o módulo do modem. Como fazer isso?
Aqui eu uso modem Huawei e156b com a net da TIM (muito ruim onde eu moro). Se eu digito lsusb no terminal, eu obtenho:
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 005: ID 0951:1607 Kingston Technology Data Traveler 2.0
Bus 002 Device 003: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem
Bus 002 Device 002: ID 05c8:0100 Cheng Uei Precision Industry Co., Ltd (Foxlink)
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0bda:8189 Realtek Semiconductor Corp. RTL8187B Wireless 802.11g 54Mbps Network Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 15d9:0a4c Unknown
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

O meu modem aparece na terceira linha. Os números "12d1" e "1003" que aparecem nesta linha são muito importantes, pois vou usá-los para carregar o módulo. Bem, para carregar o módulo, eu tenho que fazer:
"sudo modprobe usbserial vendor=0x12d1 product=0x1003"

Então, tente isso aí, mas lembre que os números referentes ao seu modem podem ser diferentes. Então não esqueça de executar "lsusb" para saber quais são. Depois é só ver se a conexão 3g que você criou já aparece listada no network manager.

Boa sorte!


7. muito obrigado

Fábio Ribeiro
fabis

(usa Outra)

Enviado em 01/12/2009 - 13:04h

Muito obrigado Edinilto e Lael!

O que seria dos iniciantes sem ajuda de vocês.

Que DEUS lhes abençoe sempre!

Caso Resolvido, como?

1 - Coloquei o modem fiz o procedimento de configuração normalmente.
2 - Usei a dica que o Edinilton passou.
3 - Tirei o modem e coloquei de novo. Bingo!

Obrigado a todos e principalmente a JESUS CRISTO que deu inteligência aos homens!


8. RE: Configurar o modem Huawei e156c.

Ednilton Santos de Oliveira
ednilton_so

(usa KUbuntu)

Enviado em 01/12/2009 - 13:37h

Olá,

Quem bom que resolveu. Mas você tá tendo problemas em reconectar? Por algum motivo eu estou tendo aqui. Ou seja, se a minha conexão cai ou eu desconecto, eu não consigo mais conectar com o Network Manager, só consigo conectar com ele novamente depois que reinicio o sistema. Se isso tiver acontecendo com você, a melhor solução é instalar o wvdial.

Abraços.


9. Modem Oi 3g Huawei E156C no Ubuntu

Alezy Oliveira
alezy_oliveira

(usa Ubuntu)

Enviado em 19/12/2010 - 16:12h

Eu tive problemas ao conectar o modem 3g da Oi - modelo Huawei E156C no Ubuntu. Tentei de inumeras maneiras, inclusive segui tutoriais do VOL mas não consegui. Encontrei, por acaso, uma maneira muito mais segura de resolver o problema (e o mais importante, FUNCIONOU!) utilizando os drivers Linux do modelo E226 da Huawei. Acabei de fazer um breve tutorial, ainda tá na versão "beta", mas pretendo torná-lo um passo-a-passo bem fácil de entender. Postei no meu site:

https://sites.google.com/site/alezycc/tutoriais/huawei-e156c-oi

Abraço a todos, espero que minha humilde contribuição tenha ajudado!


10. 3G OI Huawei DWM 152

Carlos Eduardo
barbalarga

(usa Ubuntu)

Enviado em 06/01/2011 - 13:10h

Olá amigos,

Vou aproveitar a deixa pra colocart a minha duvida!!!
estou inicando no ubuntu. Adquiri o modem Huawei DWM 152 da oi 3G. O sietma reconhece o modem, consigo fazer todos os passos para a conexão de rede, no entanto, o firefox não conecta!!!
Alguem pode me ajudar...já tentei de tudo!!!

obrigado!!!


11. Carlos

Ednilton Santos de Oliveira
ednilton_so

(usa KUbuntu)

Enviado em 06/01/2011 - 13:15h

Veja se o Firefox não está no modo Offline. Na janela dele, vá em "Arquivo" e procure a opção "Modo Offline". Se estiver marcado, desmarque e tente atualizar a página.

Se não resolver o seu problema, abra o terminal e execute
cat /etc/resolv.conf

e coloque o resultado aqui.

Boa sorte.


12. Obrigado

Carlos Eduardo
barbalarga

(usa Ubuntu)

Enviado em 06/01/2011 - 17:27h

Valeu Ednilton pela dica!! Vou tentar e depois aviso!!!!



01 02