Agora VMWare não rola no Lenny com Kernel 2.6.21

1. Agora VMWare não rola no Lenny com Kernel 2.6.21

Slipkd
slipkd

(usa Debian)

Enviado em 16/08/2007 - 15:34h

Quando configurar vmware-config.pl:


Using 2.6.x kernel build system.
make: Entrando no diretório `/tmp/vmware-config5/vmmon-only'
make -C /lib/modules/2.6.21-2-686/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entrando no diretório `/usr/src/linux-headers-2.6.21-2-686'
CC [M] /tmp/vmware-config5/vmmon-only/linux/driver.o
In file included from /tmp/vmware-config5/vmmon-only/linux/driver.c:80:
/tmp/vmware-config5/vmmon-only/./include/compat_kernel.h:21: error: expected declaration specifiers or ‘...’ before ‘compat_exit’
/tmp/vmware-config5/vmmon-only/./include/compat_kernel.h:21: error: expected declaration specifiers or ‘...’ before ‘exit_code’
/tmp/vmware-config5/vmmon-only/./include/compat_kernel.h:21: warning: type defaults to ‘int’ in declaration of ‘_syscall1’
make[2]: ** [/tmp/vmware-config5/vmmon-only/linux/driver.o] Erro 1
make[1]: ** [_module_/tmp/vmware-config5/vmmon-only] Erro 2
make[1]: Saindo do diretório `/usr/src/linux-headers-2.6.21-2-686'
make: ** [vmmon.ko] Erro 2
make: Saindo do diretório `/tmp/vmware-config5/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.


O que será que tem neste kernel 2.6.21 não ? sem Nvidia e sem Vware complica ...

O pior que voltei pro kernel 2.6.18-4 e 2.6.18-5, nada de instalar ...

:-|

[]'s




  


2. Re: Agora VMWare não rola no Lenny com Kernel 2.6.21

Rodolfo
azzarado

(usa Debian)

Enviado em 22/08/2007 - 15:17h

Olá,

Cara, tive esse mesmo problema e caí procurando no google... hehe

Encontrei uma solução aqui:
http://www.tintadigital.com/pergunte-nos/linux/erro-com-vmware-config.pl-unable-to-build-the-vmmon-m...

O patch não funcionou, mas são apenas 2 modificações no arquivo, então fiz "na mão" mesmo.


Depois, encontrei outro problema. Acho que apenas esse último resolveria o problema:

http://www.howforge.com/how-install-vmware-ubuntu-gutsy-gibbon

É para Ubuntu, mas usando o script indicado ali, funcionou perfeitamente aqui no Debian. Estou com o kernel 2.6.22-1-686.


Vlw!


3. Re: Agora VMWare não rola no Lenny com Kernel 2.6.21

Moisés Pereira dos Santos
mpsnet

(usa Slackware)

Enviado em 22/08/2007 - 15:25h

cara pra resolver isso é moleza

baixe este arquivo http://knihovny.cvut.cz/ftp/pub/vmware/vmware-any-any-update113.tar.gz
e descompacte em um diretorio, entre dentro deste diretorio e execute:

#./runme.pl

e ja era......rsrsrs


4. Re: Agora VMWare não rola no Lenny com Kernel 2.6.21

Slipkd
slipkd

(usa Debian)

Enviado em 22/08/2007 - 15:47h

Vou testar pessoal e posto o resultado !!

[]'s