Problema com instalação de programas

1. Problema com instalação de programas

Lucas José Franklin
lucfranklin

(usa Debian)

Enviado em 11/07/2014 - 21:31h

Opa, galera. Baixei o virtualbox e quando fui instalar deu o seguinte problema:
This package is uninstallable
Dependency is not satisfiable: libqt4-opengl (>= 4:4.7.2)

O que pode ser isso?


  


2. Re: Problema com instalação de programas

Hugo Cerqueira
hrcerq

(usa Outra)

Enviado em 11/07/2014 - 22:27h

Significa que vc não tem o pacote libqt4-opengl no seu sistema. Deve instalar esse pacote antes de instalar o VirtualBox.

Vc está instalando pacote debian? Se for o caso, sugiro instalar via apt-get. O apt-get já resolve todas as dependências pra vc, o que é melhor do que vc ficar instalando as dependências uma por uma, manualmente.


3. Re: Problema com instalação de programas

Lucas José Franklin
lucfranklin

(usa Debian)

Enviado em 11/07/2014 - 22:34h

Estou instalando pacote debian sim... Como posso fazer de outra forma? Sou totalmente inexperiente no linux. haha


4. Re: Problema com instalação de programas

Hugo Cerqueira
hrcerq

(usa Outra)

Enviado em 11/07/2014 - 22:46h

Você não tem qualquer familiaridade com o terminal de comandos?

Na realidade é bem simples, vc abre o terminal de comandos e digita:

sudo apt-get install virtualbox

E então digita sua senha.

Mas vc pode procurar também na central de software, se vc se sentir mais à vontade com ferramentas gráficas...


5. Re: Problema com instalação de programas

Paulo
paulo1205

(usa Ubuntu)

Enviado em 12/07/2014 - 00:46h

O que essa pergunta tem a ver com a linguagem de programação BASIC no Linux?


6. Re: Problema com instalação de programas

Lucas José Franklin
lucfranklin

(usa Debian)

Enviado em 12/07/2014 - 12:05h

Outro problema... Sempre que vou tentar instalar algo pelo terminal acontece o mesmo...
~$ sudo apt-get install virtualbox
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote virtualbox



7. Re: Problema com instalação de programas

Hugo Cerqueira
hrcerq

(usa Outra)

Enviado em 12/07/2014 - 12:35h

Paulo,

acredito que ele colocou em Basic no Linux por acreditar que essa categoria é referente a conhecimentos básicos sobre o sistema operacional...

lucfranklin,

É o seguinte, essa mensagem aparece quando o pacote não foi encontrado nos repositórios do sistema. Executa primeiro o comando:

sudo apt-get update

E deopois:

sudo apt-cache search ^virtualbox

Isso vai listar todos os pacotes que tenham alguma referência ao virtualbox (porque talvez o nome do pacote seja um pouco diferente, então é bom fazer essa busca primeiro)

Posta o resultado desse comando aqui.


8. Re: Problema com instalação de programas

Lucas José Franklin
lucfranklin

(usa Debian)

Enviado em 12/07/2014 - 13:22h

O resultado do primeiro comando é esse (outras vezes que tentei esse comando deu a mesma coisa):

[email protected]:~$ sudo apt-get update
0% [Trabalhando]
Atingido http://dl.google.com stable Release.gpg
Ign http://ppa.launchpad.net wheezy Release.gpg
Atingido http://dl.google.com stable Release.gpg
Ign http://ppa.launchpad.net wheezy Release
Atingido http://dl.google.com stable Release
Atingido http://dl.google.com stable Release
Atingido http://dl.google.com stable/main i386 Packages
Atingido http://dl.google.com stable/main i386 Packages
Err http://ppa.launchpad.net wheezy/main Sources
404 Not Found
Err http://ppa.launchpad.net wheezy/main i386 Packages
404 Not Found
Ign http://ppa.launchpad.net wheezy/main Translation-pt_BR
Ign http://ppa.launchpad.net wheezy/main Translation-pt
Ign http://ppa.launchpad.net wheezy/main Translation-en
Ign http://dl.google.com stable/main Translation-pt_BR
Ign http://dl.google.com stable/main Translation-pt
Ign http://dl.google.com stable/main Translation-en
Ign http://dl.google.com stable/main Translation-pt_BR
Ign http://dl.google.com stable/main Translation-pt
Ign http://dl.google.com stable/main Translation-en
W: Falhou ao buscar http://ppa.launchpad.net/colingille/freshlight/ubuntu/dists/wheezy/main/source/Sources 404 Not Found

W: Falhou ao buscar http://ppa.launchpad.net/colingille/freshlight/ubuntu/dists/wheezy/main/binary-i386/Packages 404 Not Found

E: Falhou o download de alguns ficheiros de índice. Foram ignorados ou os antigos foram usados em seu lugar.







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts