alguém me ajuda com esse problema ? (arachni) (n encontrei uma subcategoria para meu problema por i

1. alguém me ajuda com esse problema ? (arachni) (n encontrei uma subcategoria para meu problema por i

victor silva
victor66

(usa Arch Linux)

Enviado em 11/09/2017 - 19:55h

Bom galera, fui instalar o scanner Arachni no meu arch liux KDE, porém, quando tava instalando, apareceu isso aqui

[[email protected] ~]$ yaourt -S arachni
Senha:
atenção: arachni-1.5.1-1 está atualizado -- reinstalando
resolvendo dependências...
procurando por pacotes conflitantes...

Pacotes (1) arachni-1.5.1-1

Tamanho total instalado: 8,45 MiB
Alteração no tamanho: 0,00 MiB

:: Continuar a instalação? [S/n]
(1/1) verificando chaves no chaveiro [####################################] 100%
(1/1) verificando integridade do pacote [####################################] 100%
(1/1) carregando arquivos do pacote [####################################] 100%
(1/1) verificando conflitos de arquivo [####################################] 100%
(1/1) verificando espaço em disco disponível [####################################] 100%
:: Processando alterações do pacote...
(1/1) reinstalando arachni [####################################] 100%
Don't run Bundler as root. Bundler can ask for sudo if it is needed, and installing your bundle as root will
break this application for all non-root users on this machine.


viu pessoal ? isso aqui : Don't run Bundler as root. Bundler can ask for sudo if it is needed, and installing your bundle as root will
break this application for all non-root users on this machine.

dps continua, ai aparece isso aqui :

make: *** [Makefile:239: mini_ssl.o] Error 1

make failed, exit code 2

Gem files will remain installed in /usr/share/arachni/vendor/bundle/ruby/2.3.0/gems/puma-2.14.0 for
inspection.
Results logged to
/usr/share/arachni/vendor/bundle/ruby/2.3.0/extensions/x86_64-linux/2.3.0/puma-2.14.0/gem_make.out

An error occurred while installing puma (2.14.0), and Bundler cannot continue.
Make sure that `gem install puma -v '2.14.0'` succeeds before bundling.

In Gemfile:
arachni was resolved to 1.5.1, which depends on
puma
erro: comando não executado corretamente
:: Executando hooks pós-transação...
(1/1) Arming ConditionNeedsUpdate...
[[email protected] ~]$


ai não instala galera

da esses erros ai

tradução :

Don't run Bundler as root. Bundler can ask for sudo if it is needed, and installing your bundle as root will
break this application for all non-root users on this machine.

Não execute o Bundler como root. O Bundler pode pedir sudo se for necessário e instalar seu pacote como root
interrompa este aplicativo para todos os usuários não-root nesta máquina.


(n tem como instalar sem usar root)

(lembrando, n consigo usar sudo no meu arch, da erro ksksksk só consigo usar su )




  


2. Re: alguém me ajuda com esse problema ? (arachni) (n encontrei uma subcategoria para meu problema por i

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 11/09/2017 - 21:28h

veja isto:

adding SUDONOVERIF=1 (note: this is not a typo and it should not have Y at the end) to /etc/yaourtrc


veja esta Home-Page: Sudo and Yaourt problems:

http://www.hivmr.com/db/3c8f93k19kaz3kkx8j1p11fjxkmm3zz3


¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts