[Firefox] Instalação de Flash Player 10

Publicado por Perfil removido (última atualização em 07/10/2009)

[ Hits: 10.780 ]

Download getaflash




Este script baixa e instala o Adobe Flash Player 10 para o Firefox. Deverá rodar em qualquer distro Linux e qualquer versão do Firefox para Linux suportada pela versão 10 do AFP.

A ideia é liberar as perguntas dos novos usuários sobre como instalar o plugin. Peço a gentileza de redirecionar este povo a este script.

Obrigado.

  



Esconder código-fonte

#!/bin/sh
#
# getaflash - instalador do plugin flashplayer para Firefox/Linux
#
# Copyright (C) 2009 Valter Ferraz Sanches <[email protected]>
#
cat <<EOF
Bem vindo ao instalador de Adobe (R) Flash Player para Firefox

Este script não testará nada. Execute-o como 'root' ou não espere erros

Vamos lá. Pressione ENTER.
EOF

read crap

echo "Baixando do servidor principal." && sleep 2

wget --progress=dot -c http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz

echo "Desempacotando." && sleep 2

tar zxvf install_flash_player_10_linux.tar.gz

echo "Instalando." && sleep 2
mv libflashplayer.so /usr/lib/firefox-?.?.?/plugins/

echo "OK. Flash Player Instalado. Reinicie seu Firefox"
exit 0

Scripts recomendados

Backup de N diretórios e arquivos

Instalar MP3 (e outros formatos) no ubuntu dapper automaticamente

Script de instalação do VLC completo (via slackbuilds)

tradcon

simplemail.sh


  

Comentários
[1] Comentário enviado por gzc em 07/10/2009 - 12:07h

De fato muitos users (principalmente eu) tenho dificuldades na instalação de muitas coisas ainda no linux.

O que ajuda bastante são esses .sh que facilitam a vida de muita gente :D

Muito obrigado por compartilhar.

[2] Comentário enviado por georgedearaujo em 09/10/2009 - 18:33h

Show de bola. Mas só um detalhe, meu debian 5 não funcionou. Mais eu descobri porque. ÔÔÔÔÔ, como eu sou esperto.
Não uso o firefox e sim o iceweasel. Ai foi só alterar a linha:

mv libflashplayer.so /usr/lib/firefox-?.?.?/plugins/

para:

mv libflashplayer.so /usr/lib/iceweasel/plugins/

Valeu.

[3] Comentário enviado por premoli em 14/10/2009 - 21:44h

Notei que no local havia um arquivo .so, devo removê-lo? Tenho problemas para exibir certos videos do tube, atuAlizar ainda não resolveu meu problema, mais o script manerassso!!! Viva o Linux!!!

[4] Comentário enviado por adelio em 15/08/2010 - 21:32h

tentei várias vezes mas todas sem sucesso, de qualquer maneira obrigado

[5] Comentário enviado por evelysousa em 23/08/2010 - 11:03h

olá bom dia! nao consigo instalar o plugin do flash 10 instalei e desisntalei via apt-get trabalho com o linux educacional e ele só instala a versão 9 o que faço?


Contribuir com comentário