kernel 3.12.9 - Instalação no Debian e derivados

Publicado por Emanuel em 29/01/2014

[ Hits: 4.757 ]

Blog: http://www.sempreupdate.org

 


kernel 3.12.9 - Instalação no Debian e derivados



Saiu do forno, a nova versão do kernel Linux 3.12.9 e todas as pessoas que já estão usando o kernel em sua versão 3.12.X, devem atualizar para esta versão.

Ao contrário do que se imagina, desta vez as alterações foram estruturais e com poucas correções. Você também pode consultar a nota de lançamento enviada por Greg Kroah-Hartman no link abaixo:
Para instalar, vamos usar o script que vai otimizar o seu trabalho, o script vai baixar e instalar os pacotes necessários e, em seguida, vai reiniciar o seu computador.

Obs.: selecione todo o código destacado e cole no seu terminal.

Selecione todas as linhas abaixo, esse script vai reiniciar o seu computador automaticamente:

cd /tmp && wget https://dl.dropboxusercontent.com/u/7570113/sempreupdate/kernel-3.12.9-trusty -O kernel-3.12.9-trusty && chmod +x kernel-3.12.9-trusty && sudo sh kernel-3.12.9-trusty && sudo update-grub && sudo reboot

Caso tenha problemas, fique tranquilo, a instalação do novo kernel é reversível, execute o comando abaixo:

sudo apt-get purge linux-image-3.12.9-*
Linux: kernel 3.12.9 - Instalação no Debian e derivados

Fonte:
Outras dicas deste autor

Conheça o buscador SempreUpdate Linux

Compilando o MSN-Pecan no Mageia

Leitura recomendada

Problemas com kernel 3.1.0-1-amd64 + Xen + Debian Wheezy

Resolvendo problema de gráficos e instalando o Ubuntu 10.04

Kernel patch de Con Kolivas (otimização para desktops)

Sincronizando relógio de máquinas virtuais VMware no Ubuntu

Compilando corretamente o kernel 2.4.x no Slackware

  

Comentários
[1] Comentário enviado por izaias em 30/01/2014 - 23:50h

Instalei no Ubuntu 13.10.

Ficou ótimo!
O script funcionou perfeitamente.

[2] Comentário enviado por Shadowtri em 01/02/2014 - 14:06h

Olá, tive alguns problemas ao tentar instalar o novo Kernel:

"dpkg: problemas com dependências impedem a configuração de linux-headers-3.12.9-031209-generic:
linux-headers-3.12.9-031209-generic depende de libc6 (>= 2.14); porém:
Versão libc6:amd64 no sistema é 2.13-38.

dpkg: erro ao processar linux-headers-3.12.9-031209-generic (--install)
problemas com dependências - deixando desconfiguado"

"Error! Bad return status for module build on kernel: 3.12.9-031209-generic (x86_64)
Consult /var/lib/dkms/fglrx/12.104/build/make.log for more information

Error! Bad return status for module build on kernel: 3.12.9-031209-generic (x86_64)
Consult /ver/lib/dkms/vboxhost/4.3.6/build/make.log for more information"

O que pode ter acontecido?

Obrigado.

[3] Comentário enviado por izaias em 01/02/2014 - 14:47h

Você tem o pacote DKMS instalado por causa do Virtualbox, certo?

Remova o kernel da dica e o pacote mencionado, sugiro até mesmo remover o Virtualbox também.
Depois de instalado o novo kernel, reinstale o DKMS e o Virtualbox.

Já o erro do DPKG, não entendi

[4] Comentário enviado por Shadowtri em 01/02/2014 - 15:17h

Obrigado pela resposta izaias, essa questão do DKMS foi resolvida.

Só falta o problema de DPKG, que não sei como resolver.

OBS: Minha distro é o Debian Wheezy.

[5] Comentário enviado por izaias em 01/02/2014 - 15:23h

Pois é, é um problema de pacotes antigos. Isso é bem típico do Debian!
Terá que resolver essa dependência se quiser usar o novo Kernel.

E olha, se o seu Debian está bom assim com o Kernel corrente, deixe como está.
O Debian presa pela estabilidade, valorize isso.

[6] Comentário enviado por Shadowtri em 01/02/2014 - 15:38h

Sim, ele está bom, funcionando bem com o Gnome 3.

Porém, as vezes, quando tento visualizar imagens em modo full screen,
ou mesmo quando tenho vários programas funcionando ao mesmo tempo,
a sessão é reiniciada subitamente (volta para a tela de login) e perco tudo que estava fazendo.

Me falaram que isso pode ser um problema no Kernel, por isso gostaria de atualizar.

Mas tirando esse problema (que acontece raramente), estou muito satisfeito com o Debian.

[7] Comentário enviado por izaias em 01/02/2014 - 17:12h

Então seu problema pode ser de driver e não de Kernel.

[8] Comentário enviado por Targueriano em 19/04/2014 - 23:44h

Deixa eu ver se ficou claro para mim, não posso perder arquivos dessa máquina. Se der algum erro, basta usar o último comando e tudo voltará a ficar bem?

Minha conexão por cabo não funciona no Elementary OS, uso o kernel 3.2.0-51-generic. No Bodhi com kernel 3.8... funciona. Não tive problemas com os drivers da Nvidia, tudo funciona tão lindo, será que corro o risco de ter erros e problemas com Nvidia após a mudança?



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts