Ubuntu: Instalando em computador com placa de vídeo ATI

Publicado por Andre L em 07/11/2012

[ Hits: 16.487 ]

Blog: http://casadopinduvoz.wordpress.com/

 


Ubuntu: Instalando em computador com placa de vídeo ATI



Computadores com placa de vídeo ATI, modelo HD 6970 (e outros, da mesma série), não rodam o CD/USB de instalação do Ubuntu 12.04, pois falta suporte comunitário à citada placa.

Para que o Ubuntu, ou seus "primos", possam ser instalados, é necessário o "desvio" (workaround), que é objeto desta dica.

Dado o boot pelo LiveCD (ou LiveUSB) da "família" Ubuntu, a primeira tela será a seguinte:
Linux: Ubuntu: Instalando em computador com placa de vídeo ATI
Na tela da imagem, que é do Lubuntu 12.04 (a do Ubuntu é praticamente igual), é preciso digitar F6 para que surja o menu que está à direita, abaixo, onde se navega com as setas e se marca as opções com a barra de espaço.

E as opções que precisam ser marcadas são as que estão na imagem ("acpi=off" e "nomodset").

Após o boot, que deverá ocorrer sem erros, é possível prosseguir com a instalação.

Ocorre, no entanto, novo problema ao iniciar o Ubuntu instalado, que será revolvido com a instalação do driver proprietário da ATI. Para isto, escolha a opção marcada na tela abaixo ("modo de recuperação"):
E no próximo menu, escolha "terminal de root" e, logo após o boot, atualize o sistema e instale o driver proprietário da ATI, reiniciando em seguida.

Em tempo, para atualizar o sistema e instalar o driver da ATI no "terminal de root" (em texto), rode os seguintes comandos (um por linha):

# apt-get update && apt-get dist-upgrade
# apt-get install fglrx


E para reiniciar:

# reboot

Até a próxima dica.

Outras dicas deste autor

MATE 1.6 - Habilitando o compositor

Bleachbit - Limpando o SSD do seu Linpus/AA1

Mint Menu no Ubuntu 10.04

Troque senhas perdidas com um Live CD/USB

Flash 64 bits Fácil

Leitura recomendada

Site de documentação

Forçar resolução de tela no GNU/Linux

Notebook com KDE 4.4.3 e tela escurecendo

Download de livros do Open Books Project, da Editora O'Reilly

Executar scripts com o botão direito do mouse no Gnome

  

Comentários
[1] Comentário enviado por clodoaldops em 21/04/2013 - 22:42h

Favoritado!

[2] Comentário enviado por claudenir em 26/11/2013 - 10:01h

olá, e o que eu faço quando não aparece nem a tela inicial? (é nesta tele que trava) minha placa de video é ati radeon hd 6570

[3] Comentário enviado por BichoCarpinteiro em 22/02/2015 - 10:21h

Marquei as duas opções, mas continua não entrando.
Placa amd radeon r7 series 7480d.
Queria muito instalar o Lubuntu!

[4] Comentário enviado por Kleston123 em 18/07/2016 - 16:22h

também estou tendo problemas na hora de instalar o Ubuntu 15.10, depois que eu seleciono "install ubuntu" a tela fica cinza como se fosse continuar e da uma leve escurecida, depois nao sai mais disso, alguem me indicaria ou uma possibilidade além desse que vou testar hoje assim que chegar em casa, ou um outro sistema operacional que tenha uma interface amigavel?

[5] Comentário enviado por mangabas em 31/12/2016 - 03:04h

Primeiramente me desculpe ressuscitar o post,
segui os passos acima mas quando rebooto já no "ubuntu-16.04-desktop-amd64" e escolho qualquer das opções da 2º imagem do post recebo esta mensagem:

[ 2.157227] xhci_hcd 0000:03:00.0: can't setup: -19
[ 2.157263] xhci_hcd 0000:03:00.0: in it 0000:03:00.0 fail. -19
[ 2.198414] pata_atiixp 0000:00:14.1: can't enable device: BAR 0 [io size 0x0008] not assigned
[ 2.201776] firewire_ohci 0000:02:00.0: failed to reset ohci card
[ 2.201983] pata_acpi 0000:00:14.1: can't enable device: BAR 0 Cio size 0x00008] not assigned
[ 2.212993] r8169 0000:06:00.0 (unnaned net_device) (uninitialized): rtl_cbipcmd_cond == 1 (loop: 100, delay: 100).
[ 2.224032] r8169 0000:06:00.0 eth0 : rtI_counters_cond == 1 (loop: 1000, delay: I0).
[ 2.226304] [drn:radeon_init [radeon]] *ERR0R* No UMS support in radeon noduIe!
[ 2.247514] r8169 0000:06:00.0 enp6s0: rtI_counters_cond == 1 (loop: 1000, delay: 10).

Gave up waiting for root device. Common problems:
- Boot args (cat /proc/cmdline)
- Check rootdelay= (did the system wait long enough?)
- Check root= (did the system wait for the right device?)
- Missing modules (cat /proc/modules; Is /dev)
ALERT! UUID=ddfca2eb-52ff-4789-b988-667200bd9bc5 does not exist. Dropping to a shell!

BusyBox v1.22.1 (Ubuntu 1:1.22.0-15ubuntu1) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs) _


Então digito as linhas de comando indicadas e o resultado é: apt_get "não encontrado"
Meu desktop:
AMD FX(tm)-8320 Eight-Core Processor
ATI Radeon HD4250
16G Ram (2x8)
Sata 1TB particionado (onde esta instalado Windows 10)
Pata 160GB particionado (onde estou tentando instalar o Ubuntu)
Asus M5A88-V EVO

Obrigado!



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts