Ubuntu 13.04 em Ultrabook com SSD

Publicado por Adriano Antonucci em 21/10/2013

[ Hits: 19.397 ]

Blog: http://www.adrianoantonucci.com.br

 


Ubuntu 13.04 em Ultrabook com SSD



Depois de vários dias quebrando a cabeça na instalação do Ubuntu 13.04 no meu Ultrabook, até que enfim achei uma solução.

Quando era feita a instalação, geralmente eu deixava 20% do meu disco para o sistema (/), o dobro da memoria RAM para SWAP e o restante do disco para /home.

Com esse procedimento, o sistema operacional instalava normalmente, mas quando reiniciava o equipamento, ele não carregava mais o S.O.

Lendo vários artigos na Internet durante vários dias, acabei descobrindo que o /boot, se eu deixasse no SSD, ele não iria funcionar.

Com isso, fiz o seguinte:
  • O ponto de montagem /, eu deixei no SSD com o tamanho total (32 GB);
  • /boot, eu deixei no SATA com um tamanho de 250 MB;
  • /var, /opt e /home, eu também deixei no SATA.

E para não ter problemas com o UEFI, eu deixei reservado um espaço de 250 MB como FAT32. Dessa maneira, o meu sistema operacional inicia normalmente e com uma velocidade de aproximadamente uns 10 segundos.

Espero que ajude alguém.

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Usando o VLC para visualizar imagens de webcam em WM

Criador de ficha D&D no GNU/Linux

Mantenha-se atualizado com RSS

TeamViewer no Fedora 18

Habilitando USB no VirtualBox no Debian Squeeze

  

Comentários
[1] Comentário enviado por marcos_zanotti em 21/10/2013 - 01:26h

Boa noite Adriano, fiz como voce disse e o Sistema tambem nao inicializa, obrigado por compartilhar sua experiencia, vou fazer o sugerido para solucionar este problema e posto o resultado!!

[2] Comentário enviado por marcos_zanotti em 21/10/2013 - 02:16h

Rodrigo, obrigado por sua dica!! Funcionou lindo!! Estou com um inspiron i5 com 8GB de memoria, ficou excelente o desempenho!! Unico problema e que esta esquentando muito, li que e devido ao driver de video, vou continuar a pesquisa para deixar 100%

[3] Comentário enviado por vitorgatti em 21/10/2013 - 08:44h

Só a minha opinião para complementar...

Se sua BIOS tiver opção de desativar o UEFI e voltar ao sistema de boot antigo, faça-o. Ainda mais se for fazer dual-boot, o Linux ainda se perde um pouco nas partições quando o UEFI está ativado e Windows instalado (experiência própria). Na BIOS do meu laptop Dell tenho a opção de "Legacy Boot", o que faz demorar 3 segundos a mais pra bootar, mas pelo menos não tive mais dor de cabeça.

A partição /boot não precisa nem de 512MB de espaço. Só o kernel é armazenado lá, o que normalmente ocupa uns 20MB (cada kernel). Colocar 25GB é desperdício...!

[4] Comentário enviado por madrugada em 22/10/2013 - 06:06h


[3] Comentário enviado por vitorgatti em 21/10/2013 - 08:44h:
[...]A partição /boot não precisa nem de 512MB de espaço. Só o kernel é armazenado lá, o que normalmente ocupa uns 20MB (cada kernel). Colocar 25GB é desperdício...!


Não posso opinar sobre UEFI, pois não possuo hardware pra isso. Mas o espaço de 25GB pra /boot realmente é um exagero. 500MB dá e sobra espaço.

Mas também não é só para o kernel, os arquivos utilizados pelo grub/grub2 durante o boot também se encontram neste diretório.

[5] Comentário enviado por izaias em 22/10/2013 - 08:52h

Acredito que tenha sido um erro de digitação, a partição "/boot" estar com 25 GB na dica.
Uso Linux a 4 anos e sempre deixei essa partição com 100MB no máximo. E foi com Windows e 5 distribuições instaladas.

Aguardando o autor para correção.

[6] Comentário enviado por lcavalheiro em 22/10/2013 - 12:39h

Cara... é muito mais provável ser swap do que /boot - na verdade, seria ridículo se fosse qualquer uma das duas...

[7] Comentário enviado por adrianoantonucci em 22/10/2013 - 23:35h

Pessoal peço desculpas pelo erro na digitação o tamanho que utilizei para o /boot foi de 250 Mb. Foi bobeira minha ao digitar e acabei errando.

[8] Comentário enviado por paulodiovani em 23/10/2013 - 00:16h

Não entendi o porque dos 250 MB em FAT32.

[9] Comentário enviado por izaias em 23/10/2013 - 00:17h

Corrigido. :)

[10] Comentário enviado por Britaocvp em 28/10/2013 - 23:59h

Ola, tenho um Dell inspiron 5423 e tenho o mesmo problema com o dual-boot, não inicia pelo Linux, tem um SSD de 32 gb, e sou iniciante, ja li todos os tópicos mas realmente não entendi patavinas, no Windows vista e seven já consegui fazer dual boot de maneira simples, mas com esse novo windows8 nem sai do lugar, se tiver alguém ai pra me dar uma "luz" desde ja agradeço.

[11] Comentário enviado por fabio_gyn em 13/11/2014 - 12:49h

So um detalhe, nos computadores modernos que tem uma quantidade grande de memoria não é mais preciso usar o dobro da memoria como swap, pq veja bem, a swap é muito mais lenta, se vc tiver muito uso de swap, vc vai ter um desempenho menor, então o melhor é ter pouca swap. Uso somente 512MB de swap e roda numa boa qualquer linux que tenho, mas tenho 8GB de memoria.

O esquema do dobro da memoria como swap era feito antigamente qdo as memorias eram muito caras, ai pra não deixar os serviços sem memoria, se usava swap, mas hoje como ta bem barato, não é mais recomendado.

[12] Comentário enviado por jere2001 em 11/12/2014 - 23:25h

Cara, vc nem precisa mandar o /boot pro disco rígido, é só criar uma partição pequena para o /boot porém ela precisa ser formatada com FAT ou escolher "EFI" no instalador do Ubuntu.

No meu sistema fiz da seguinte forma o particionamento:

SSD: /boot (opção "EFI" no instalador do Ubuntu) /

HDD: swap, /var (deixei o /var no HDD para evitar excesso de escrita/reescrita no SSD), /home

[13] Comentário enviado por ayslan20 em 24/03/2015 - 21:47h

Cara, fiz desse jeito, mas, ao reiniciar aparece a mensagem
Reboot and select proper boot device...

O que pode ser??

Detalhe: Na BIOS não aparece os HDs...

Notebook Asus Core i5, SSD 24GB, HD 500Gb



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts