Ralink RT2870/RT3070 Wireless Adapter no Debian Squeeze

Publicado por Ramon em 16/06/2011

[ Hits: 23.781 ]

 


Ralink RT2870/RT3070 Wireless Adapter no Debian Squeeze



Testando um Tenda W311U no Debian ele era detectado, mas não funcionava. Primeiro, foi necessário instalar o firmware da Ralink. Abra o Terminal como root (Aplicativos -> Acessorios -> Terminal como root), digite a senha de root e edite o /etc/apt/sources.list com:

# nano /etc/apt/sources.list

Mude uma linha ou adicione no arquivo:

deb http://ftp.br.debian.org/debian/ squeeze main contrib non-free

Ainda como root, execute:

# apt-get update
# apt-get install firmware-ralink wireless-tools


Conecte o adaptador ao computador e, se não funcionar diretamente, rode:

# modprobe rt2870sta

Se ainda não funcionar, execute no Terminal ainda como usuário root:

# echo "blacklist rt2800usb" > /etc/modprobe.d/rt2800usb.conf

E reinicie.

Outras dicas deste autor

FATAL: Module ndiswrapper not found - Linux Mint Debian

Esconder menu 'Atividades' no Cinnamon

Leitura recomendada

Faça sua rede sem fio funcionar no Positivo V43

Dica pra instalar diversos modens

Configurando algumas webcams no pinguim

Novo driver Nvidia 185 no Ubuntu

SoundBlaster SB16 non PNP ISA

  

Comentários
[1] Comentário enviado por corsairbr em 03/08/2011 - 16:07h

To quase loco nao consigo fazer funcionar meu USB RT3070 no Linux Educacional.....

Ja tentei de tudo =/

[2] Comentário enviado por lucasdona em 12/08/2011 - 16:33h

Assim você vai conseguir, basta você atualizar o kernel desta forma:

sudo apt-get update
sudo apt-get install linux-image-2.6.35-25-generic
sudo apt-get install linux-headers-2.6.35-25-generic

Reinicie o sistema e sua rt3070 irá funcionar perfeitamente.

[3] Comentário enviado por lobonilo em 16/10/2011 - 21:22h

Ótima dica. Funcionou bem no Debian. Acredito que algo semelhante funcione também no Ubuntu, só que acho que a linha a ser adicionada no /etc/apt/sources.list deve ser diferente de "deb http://ftp.br.debian.org/debian/ squeeze main contrib non-free".
Alguém pode confirmar?

[4] Comentário enviado por ramonzitos em 05/11/2011 - 19:10h

@lobonilo

Sim, mas o Ubuntu suporta nativamente esse driver.

[5] Comentário enviado por Shadowmaxx em 02/08/2016 - 23:25h

Olá pessoal!! Estou com um problema que não consigo resolver, uso o kali Linux2.0 e a minha placa USB ralink RT2870/RT3070 reconhece normal, entra em monitor, reconhece as redes, mas na hora de atacar pelo reaver da aquela msg warning: failed to associate with [bssid] testei em várias redes e sempre à msm msg, todas com o sinal forte e o kali 2.0 está instalado em dual boot. Se alguém souber me orientar ficarei muito grato. Já procurei muito essa resposta é não obtive em nenhum fórum daqui ou de fora.

[6] Comentário enviado por removido em 10/03/2017 - 16:02h

hoje é só fazer:

apt-get update

apt-get install -y firmware-ralink wireless-tools

Funciona 100%

Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter

kernel 3.16



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts