Opera Developer no Debian e Ubuntu

Publicado por edps em 22/04/2015

[ Hits: 2.982 ]

Blog: https://edpsblog.wordpress.com/

 


Opera Developer no Debian e Ubuntu



E finalmente o pessoal da Opera Software resolveu liberar um port 32 Bits de seu novo navegador (agora baseado no Chromium). Veremos então como instalá-lo no Debian Wheezy i686.

Instalação manual

O meio mais prático, se você não tem o repositório do Opera em seu "/etc/apt/sources.list", é instalá-lo manualmente. Que durante a instalação, esse repositório será adicionado ao diretório "/etc/apt/sources.list.d":

wget -nv http://get.geo.opera.com.global.prod.fastly.net/pub/opera-developer/30.0.1833.0/linux/opera-developer_30.0.1833.0_i386.deb

sudo dpkg -i opera-developer_30.0.1833.0_i386.deb
sudo apt-get -f install

Se você estiver com o repositório Debian Backports habilitado, tudo ocorrerá bem. Do contrário, a instalação falhará devido à falta do pacote "pepperflashplugin-nonfree".

Para instalá-lo e, por consequência, concluir com êxito a instalação do Opera, adicione a linha abaixo em seu /etc/apt/sources.list:

deb http://http.debian.net/debian/ wheezy-backports main contrib non-free

* Isso vale somente para o Debian Wheezy, o pacote "pepperflashplugin-nonfree" já vem disponível com o Debian Jessie, desde que você deixe habilitada, pelo menos, as seções main e contrib no arquivo "/etc/apt/sources.list".

Em seguida, prossiga com:

sudo apt-get update
sudo apt-get -f install

Instalação via repositório

Agora, se você é como eu e já tinha o repositório do Opera habilitado em seu "sources.list", bastará isso para instalá-lo:

sudo apt-get install opera-developer

Obviamente, se estiver com o repositório Backports habilitado. Se não estiver, siga a parte citada anteriormente sobre o seu acréscimo do mesmo ao "sources.list".

Durante a instalação via apt-get, somos perguntados se desejamos criar um arquivo que contenha o repositório lá em "/etc/apt/sources.list.d", basta responder NÃO. Afinal, isso não é Ubuntu com aquela bagunça de arquivos ".list" e ".save" lá em "/etc/apt/sources.list.d".

Quando cito a bagunça de arquivos em "/etc/apt/sources.list.d", é porque uso um único, onde concentro todos os extras para o meu SO. Alguns deles podem ser vistos no link abaixo:

Ubuntu

E por falar em Ubuntu, qualquer um dos métodos acima poderá ser seguido nos *buntus (Trusty, Utopic e Vivid) ou em qualquer distro deles derivadas, isto é, desde que o repositório multiverse esteja habilitado no "sources.list", visto que é nele que o pacote "pepperflashplugin-nonfree" encontra-se.

Problemas?

Caso tenham problema ao baixar o pacote manualmente, basta acessar o endereço abaixo:

Referências

Imagens das etapas e do navegador em uso, incluindo o teste em HTML5, poderão ser vistas a partir do 2° link abaixo, local da publicação original:
IntÉ!

Outras dicas deste autor

SBoupgrade - Atualize seu SlackBuild!

Pesquisa de arquivos e executáveis em pacotes .deb

Instalação do LibreOffice no Debian

Adicionando os repositórios do VirtualBox no Debian e Ubuntu

sources.list para o Ubuntu 10.04 Lucid Lynx

Leitura recomendada

Instalando NVIDIA no Debian

Para você que sente falta do famoso Daemon Tools, conheça e instale o Gmount-iso

Calligra - Salvar arquivos em DOCX e DOC [Método alternativo]

Instalando Grub Customizer no LMDE-2

Mortal Kombat para Linux

  

Comentários
[1] Comentário enviado por edps em 25/04/2015 - 09:32h


ADENDO:

esta mesma versão já está disponível para a plataforma amd64:

http://get.geo.opera.com/pub/opera-developer/30.0.1835.6/linux/

[2] Comentário enviado por removido em 12/05/2015 - 02:57h

Sera que nao tem um jeito de instalar no 12.04?Eu tentei,mais nao consegui,fui instalar o ubuntu 14.04 e meu pc chiou e ficou na tela cinza ¬¬Nem debian ele aguenta to sem saida pra instalar o opera 30.

A liberdade indocil e domada pela propria desgraça -William Shakespeare

[3] Comentário enviado por edps em 12/05/2015 - 10:32h

Baixe a versão mais atual:

i386:

http://get.geo.opera.com.global.prod.fastly.net/pub/opera-developer/31.0.1857.0/linux/opera-develope...

amd64:

http://get.geo.opera.com.global.prod.fastly.net/pub/opera-developer/31.0.1857.0/linux/opera-develope...

E tente instalar com:

$ sudo apt-get update
$ sudo dpkg -i opera-developer_31.0.1857.0_*.deb
$ sudo apt-get -f install

Caso não funcione, crie um post no fórum.

Caso instale, mas o programa não abra, tente abrir o mesmo pelo terminal e informe no post que criar o que aparece ao digitar:

$ opera-developer

IntÉ!

-----------------------------------------------
Together we stand, divided we fall!
-----------------------------------------------

[4] Comentário enviado por removido em 12/05/2015 - 16:18h

Eu forcei a instalaçao sudo dpkg -i --force-depends opera-developer_31.0.1857.0_i386.deb e olha no que deu quando eu clico no icone do painel http://i.imgur.com/O673gKQ.png

A liberdade indocil e domada pela propria desgraça -William Shakespeare

[5] Comentário enviado por edps em 12/05/2015 - 16:39h


[4] Comentário enviado por SamsonBurke em 12/05/2015 - 16:18h

Eu forcei a instalaçao sudo dpkg -i --force-depends opera-developer_31.0.1857.0_i386.deb e olha no que deu quando eu clico no icone do painel http://i.imgur.com/O673gKQ.png

A liberdade indocil e domada pela propria desgraça -William Shakespeare


Execute o comando 'opera-developer' pelo terminal, ao que parece o ícone está procurando um caminho errado.

$ opera-developer

Ou tente com:

$ /usr/lib/i386-linux-gnu/opera-developer/opera-developer

Como já falei... abra um post no fórum assim com os logs de instalação (normal sem forçar) e execução (pelo terminal) dá para ter uma ideia do que ocorre.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts