OpenJDK7 64 bits e Banco do Brasil [RESOLVIDO]

Publicado por Xerxes em 22/01/2013

[ Hits: 10.030 ]

Blog: https://static.vivaolinux.com.br/imagens/dicas/comunidade/300.jpg

 


OpenJDK7 64 bits e Banco do Brasil [RESOLVIDO]



Abrir o aplicativo de senha do Banco do Brasil usando a versão livre do plugin do Java, o OpenJDK ao invés do plugin da Oracle, é possível!

A dica foi testada com o Firefox no Arch Linux .

Basta instalar o OpenJDK e o IcedTea-Web. No caso, eu instalei a versão 7 dos dois:

# pacman -S icedtea-web-java7 jdk7-openjdk

Depois, precisa executar:

# mkdir -p /etc/.java/.systemPrefs
$ rm -rf ~/.java ~/.icedtea


Abra o Firefox:
  • Na barra de endereços digite: about:config
  • Pressione: Enter
  • No campo de busca coloque: dom.ipc.plugins.java.enabled

E dê dois cliques para mudar o valor de FALSE para TRUE. Se já estiver TRUE, deixe assim.

Reinicie o navegador.

Entre no seguinte endereço: http://www.java.com/en/download/testjava.jsp

Espere uns 20 segundos para ver a mensagem de que o Java está funcionando.

Depois acesse o site do Banco do Brasil

Abraço!

Referências


Outras dicas deste autor

Formato da data e hora no Fluxbox

Repositórios Multimídia no Debian 7

LMDE elegante

Comando ifconfig do Arch Linux não funciona [RESOLVIDO]

Mintmenu no Fedora 12

Leitura recomendada

Instalando o "Kubuntu" no Ubuntu 10.10

Reconfigurar as "LOCALES" passando de UTF-8 para ISO-8859-1

Som no flash do Ubuntu

Manipulando repositórios no openSUSE Leap 15.2

Configurar fontes MS True Type no Linux

  

Comentários
[1] Comentário enviado por bertux em 22/01/2013 - 17:39h

Eu resolvi o problema removendo o openjdk e instalando o jre da Oracle que está no AUR.

Eu fiz com os seguintes comandos:

sudo pacman -R jdk7-openjdk jre7-openjdk-headless

pode aparecer algumas dependências, desinstale-as junto com o jdk, após ter o instalado o jre reinstale esses pacotes novamente.

Para instalar o jre:

yaourt -S jre


É uma outra opção de usar o java para o BB. Testei com o FireFox.

[2] Comentário enviado por xerxeslins em 22/01/2013 - 19:56h


[1] Comentário enviado por bertux em 22/01/2013 - 17:39h:

Eu resolvi o problema removendo o openjdk e instalando o jre da Oracle que está no AUR.

Eu fiz com os seguintes comandos:

sudo pacman -R jdk7-openjdk jre7-openjdk-headless

pode aparecer algumas dependências, desinstale-as junto com o jdk, após ter o instalado o jre reinstale esses pacotes novamente.

Para instalar o jre:

yaourt -S jre


É uma outra opção de usar o java para o BB. Testei com o FireFox.


Muito bom!

Eu sempre usava o java oracle porque o JDK não funcionava... mas agora vi que funciona! Mesmo assim essa outra oppão é excelente!

[3] Comentário enviado por removido em 29/01/2013 - 19:50h

Obrigado pela dica! estava usando o java da oracle pois não conseguia usar o site do BB no JDK, mas agora tudo funciona perfeitamente!



Contribuir com comentário