MS Internet Explorer no Linux (IEs4Linux)

Publicado por Ricardo Brito do Nascimento em 02/06/2008

[ Hits: 10.000 ]

Blog: http://brito.blog.incolume.com.br

 


MS Internet Explorer no Linux (IEs4Linux)



Como é de vasto conhecimento, algumas aplicações que não obedecem os padrões w3c, não funcionam corretamente em navegadores diferentes do IE. Por este motivo a comunidade livre procurou facilitar a criação de scripts que fazem a instalação do IE no Linux.

1. Site oficial:
2. Requisitos necessários para instalação:
  • Wine
  • Cabextract

3. Instalando os requisitos necessários:

Abra um terminal, logado como super usuário (root), para instalar as dependências do Internet Explorer no Linux.

3.1. Fedora, CentOS e Red Hat:

# yum install wine* cabextract

PCLinuxOS:

# apt-get install wine cabextract

3.2. Ubuntu, KUbuntu e Xubuntu:

Nas variantes de Ubuntu será necessário incluir os seguintes repositórios no arquivo "/etc/apt/sources.list":

deb http://us.archive.ubuntu.com/ubuntu edgy universe
deb http://wine.budgetdedicated.com/apt edgy main

Após a edição execute os comandos abaixo:

$ wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt-key add -
$ sudo apt-get update
$ sudo apt-get install wine cabextract


3.3. Debian:

No Debian será necessário incluir os seguintes repositórios no arquivo "/etc/apt/sources.list", para instalação do wine e libxxf86dga1:

# wine
deb http://wine.sourceforge.net/apt/ binary/
# backports
deb http://www.backports.org/debian/ sarge-backports main

Após a edição execute os comandos abaixo:

# apt-get update
# apt-get install wine libxxf86dga1 libxxf86vm1 cabextract


4. Obtendo o script de instalação do IEs4Linux:

Execute o logoff do super usuário e efetue o login como usuário comum. Logado como usuário comum execute em um terminal o comando:

# wget http://www.tatanka.com.br/ies4linux/downloads/ies4linux-latest.tar.gz

5. Instalando o IES4Linux:

Ainda logado como usuário comum execute em um terminal o comando:

$ tar zxvf ies4linux-latest.tar.gz -C ~/
$ cd /tmp/ies4linux-*
$ ./ies4linux


Bibliografia:
Outras dicas deste autor

Utilizando o comando rsync

Convertendo formato de pacotes com alien

Fixar processo em um núcleo de processador

Tabela de horário de verão 2007/8

Criando pacotes RPM com o rpmbuild

Leitura recomendada

Thunderbird - Como exportar seus emails do Windows para Linux

Mostrar a previsão do tempo com PHP

Arch Linux - como instalar kernel LTS e usar múltiplos kernels

Configurando o Ubuntu 10.04 para rodar os principais codecs, plugins e Java

Convertendo RMBV para DivX com mencoder

  

Comentários
[1] Comentário enviado por juliaojunior em 03/06/2008 - 00:58h

vou testar.

[2] Comentário enviado por uberalles em 03/06/2008 - 10:17h

Dá pra instalar o IE7 ?
Tô vendo no script uma variável que indica IE7 e um arquivo ie7.REG, mas devido às restrições da Microsoft, teríamos que executar a remediação de ativação?

[3] Comentário enviado por rbn_jesus em 20/08/2008 - 12:14h

quanto ao IE7, nunca tive a necessidade de instalá-lo, mas segunda o microsoft, o IE é um software livre.

[4] Comentário enviado por thiagobh1 em 05/01/2010 - 21:35h

ola pessoal.. sou iniciante e tem 10 dias q tento instalar o iexplorer mas nao consigo.

preciso dele para acessar o bradesco net empresas... so roda no iexplorer Triste


instalei o wine 1.1.35 ... mas nao consigo instalar o ies4linux ... baixei ele no tatanka... extrai... executei... ai ele aparece a janelinha para selecionar 6.0, 5.5 versao... dando ok ... ele nao instala .. da o seguinte erro:

O IEs4Linux 2 foi desenvolvido para usar as versões mais recentes do Wine (0.9.x). Parece que você está usando uma versão antiga (wine-1.1.35). Recomenda-se que você atualize seu Wine para a última versão (Vá para: winehq.com).

/home/acer/ies4linux-2.99.0.1/ui/pygtk/ies4linux-gtk.py:399: GtkWarning: Invalid text buffer iterator: either the iterator is uninitialized, or the characters/pixbufs/widgets in the buffer have been modified since the iterator was created.
You must use marks, character numbers, or line numbers to preserve a position across buffer modifications.
You can apply tags and insert marks without invalidating your iterators,
but any mutation that affects 'indexable' buffer contents (contents that can be referred to by character offset)
will invalidate all outstanding iterators
gtk.main()
ui/pygtk/python-gtk.sh: linha 6: 2167 Falha de segmentação python "$IES4LINUX"/ui/pygtk/ies4linux-gtk.py
acer@acer-laptop:~/ies4linux-2.99.0.1$


se possivel uma help...

abs

Thiago.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts