Instalando o The Conquerors no Ubuntu 6.10

Publicado por Marcelo Ribeiro em 06/05/2007

[ Hits: 11.112 ]

 


Instalando o The Conquerors no Ubuntu 6.10



Inicialmente instalei o Wine 0.9.34. Usei o apt-get, daí simplesmente instalei o AOE o TC a partir do CD, mas como nada é perfeito, quando eu rodava o jogo aparecia uma mensagem dizendo que não foi possível iniciar o sistema gráfico.

Levei uma surra do programa até descobrir no site do projeto que existe um bug no arquivo Wine3d_interface.h e infelizmente este bug afeta todas as versões após o Wine 0.9.31. Para resolver o bug temos que recompilar esta biblioteca removendo a seguinte linha:

IwineD3DDevice::EnumDisplayModes

Instalei todos os módulos necessários para recompilar o Wine e rodei os seguintes comandos:

$ ./configure
$ make depend && make


Após recompilar o wine copiei a biblioteca Wine3D.dll.so para o diretório onde o wine estava instalado e pronto, tudo ficou normal.

Para quem não quer quebrar a cabeça, basta instalar o Wine 0.9.31 que jogo rola numa boa!

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Samba 4 - Desabilitando suporte a impressoras (CUPS)

Habilitar cliques do Touchpad no Debian LXDE

Instalação do Slackware Linux passo-a-passo

Ícones na Área de Trabalho do KDE 4

BUG da transparência no konsole do KDE

  

Comentários
[1] Comentário enviado por albertguedes em 07/05/2007 - 13:17h

Valeu pela dica Marcelo, mas só para ficar mais completo, você pode pode dizer a sua distro, processador, memória e placa de vídeo.
Eu sei que estou abusando, mas esta informação serve de guia para mexer no wine e ter uma idéia se surgir algum problema.
Falou ? Até mais.

[2] Comentário enviado por fabiano_shark em 09/05/2007 - 09:33h

Roda multiplayer? E o patch, é possível instalar?

[3] Comentário enviado por malinha em 18/05/2007 - 12:59h

euquero saber como estala esse jogo

[4] Comentário enviado por geoscience em 02/06/2007 - 19:41h

Amigo, sobre a dica você tem razão preciso deixar mais completa. Meu pc é um P4 Prescott 3GHz, 1Gb de RAM, Placa de video ATI 9600XT Saphire. No momento da instalação do TC eu usava os drives proprietários da ATI. Hoje vou instalar e testar com os drives do X-org. Quanto ao multiplayer eu não testei.
Abraços,

Marcelo Ribeiro



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts