Instalando drivers de placas de vídeo ATI no Ubuntu Linux

Publicado por Augusto André Souza em 27/04/2009

[ Hits: 39.726 ]

Blog: http://www.google.com

 


Instalando drivers de placas de vídeo ATI no Ubuntu Linux



Realizar esse procedimento, a princípio, parece complicado, mas na realidade é mais fácil do que parece. Vou postar a solução que encontrei juntando informações de fóruns na internet e a pedido do membro do VOL Pinduvoz.

A instalação dos drivers da ATI funcionam melhor manualmente. Comece com os seguinte comando para instalar os pacotes necessários:

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++5 dkms linux-headers-$(uname -r)

Depois baixe o driver no site da ATI e salve-o numa pasta qualquer. Execute os seguintes comandos num terminal:

cd /home/usuário/pasta onde baixou
$ chmod +x ati-driver-installer-9-3-x86.x86_64.run
$ sudo ./ati-driver-installer-9-3-x86.x86_64.run


O instalador será aberto. Basta selecionar a instalação automática, aceitar as condições de uso e pronto. Ele vai gerar o driver e instalar tudo bonitinho.

Depois basta configurar o xorg.conf. Se não tiver condições de configurar manualmente, rode o comando para o configurador do driver mexer no xorg:

sudo aticonfig --initial -f

Reinicie e máquina, abra o terminal e digite:

fglrxinfo

Se tudo deu certo, vai aparecer na tela a versão do seu driver devidamente instalado. Se aparecer tudo "mesa" é porque houve algum problema e a instalação deve ser refeita.

Se a instalação for feita no Linux Ubuntu 8.10 ou posterior, isso é suficiente, os efeitos gráficos poderão ser habilitados normalmente. Já na versão 8.04 ou anterior o Ubuntu não carrega o driver automaticamente, mesmo que esteja especificado no xorg. Portanto, deve-se forçar o carregamento do mesmo. Abra o arquivo /etc/rc.local e adicione os seguintes comandos:

modprobe -r radeon
modprobe fglrx

Depois confira na parte "Device" do seu xorg.conf se a opção "driver" está como "fglrx" e as seguintes linhas estão presentes:

Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"

Essas linhas dizem respeito ao Aiglx, necessário para usar o Compiz. Coloque no xorg se quiser os efeitos.

Obs.: Para baixar o driver vá ao site da AMD.

E lembre-se de verificar antes se o Catalyst comporta o driver de sua placa. Caso não, procure no site a versão correta.

Outras dicas deste autor

Instalando driver de vídeo ATI no Debian Lenny (5.0) sem desastres

Instalando pacotes txz no Slackware 12.2

Leitura recomendada

Verificando identificador físico da HBA Fiber Channel (WWN ou WWID)

Placa de vídeo Intel i915 no BackTrack - Conflito resolvido

Usando um ZipDrive IDE interno no Linux

Verificando o nível de tinta de sua impressora

Emuladores para ajudar em aulas

  

Comentários
[1] Comentário enviado por laffite em 29/04/2009 - 14:25h

Estou com um problema. Fiz a instalação desses pacotes necessários, sem nenhum problema. Fui no site da ati e baixei o unico drive referente a minha placa de video, que no caso é a 9550 Series.
No entanto quando tento executar o o instalador me aparece um erro " ./default_policy.sh not support version default:v2:i686:lib::nome:2.6.28-11-generic "
Estou com o Ubuntu 9.04 / Kernel 2.6.28-11 (como pode ver)

Não entendi bem o por que desse erro. Será que poderia me ajudar.

Desde ja grato.

[2] Comentário enviado por kirabouts em 01/05/2009 - 21:00h

pra que todos estes pacotes amigo?
grato desde jah!

[3] Comentário enviado por augustouser em 02/05/2009 - 21:24h

Laffite,

Pois é companheiro, não sei como te ajudar. Sou noob também. Por que não dá uma googlada e tenta descobrir qual o melhor método para instalar o driver proprietario da ATI no teu Jaunty? Essa dica foi publicada recentemente mas a elaboração foi feita já a algum tempo e deu certo no Hardy e Intrepid. Resolvi partir pra outras distros, mas realmente vi muita gente nesses fóruns afora com dificuldades com drivers proprietarios nesse novo Ubuntu. Procura que acha.. Ou então abre um tópico aqui no VOL.

oz_sampa,

Só pra garantir mesmo.
Antes de chegar a isso, ficava pedindo pacotes adicionais...

[4] Comentário enviado por llord em 09/05/2009 - 21:04h


Cara suas dicas foram batata... funcionaram na hora, parabéns...!

[5] Comentário enviado por chagalrpg em 14/05/2009 - 18:06h

O novo driver da ATI parece que não suporta mais as placas de vídeos antigas.

No meu caso, tenho uma ATI Radeon X300, o novo driver não oferece suporte a ela, não tenho certeza se é isso, mas sei que não funciona.

Tá rolando um bafafá sobre isso no fórum da comunidade Ubuntu Brasil.

[6] Comentário enviado por fernandoborges em 25/06/2009 - 14:32h

Tive problemas com uma ATI.
Sua dica funcionou perfeitamente com Ubuntu 8.04 + Sapphire X1050 ATI Radeon.
Obrigado e parabéns!

[7] Comentário enviado por Felipepes em 13/07/2009 - 22:34h

OI pessoal
então esse tutorial não funcionou comigo na parte de
$ cd /home/usuário/pasta onde baixou
ele acusa que o arquivo ou pasta não existe
mas ele está lá
não sei oque fazer ...
ATI Radeon HD 3200
Por favor ajude-me !

[8] Comentário enviado por augustouser em 14/07/2009 - 10:51h

Felipepepes,

Verifique se não está cometendo nenhum erro de grafia. Lembre-se de que o Ubuntu diferencia letras maiúsculas e minúsculas.

Lembre também que o driver deve ser exatamente o recomendado para sua placa de video. Pro seu caso, a versão é esta: http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.7&product=2.7.4.3.3.3.1&l...


[9] Comentário enviado por fernandofei em 16/07/2009 - 10:59h

E ae laffite, beleza???

O problema é que o ultimo driver lançado pela ATI não é compativel com o kernel 2.6.28 pra frente... se eu não me engano, a versão atual é a 9.3...

Pode tentar instalar no Ubuntu, Fedora, Slackware (current), em nenhum deles vai rodar o driver proprietario até ser lançada a nova versão...

o jeito é esperar mesmo...

[10] Comentário enviado por geanceretta em 09/08/2009 - 02:12h

Siga este tutorial: https://help.ubuntu.com/community/RadeonDriver
Ele ensina a configurar manualmente a sua placa, sem utilizar drives prioritários (ensina também a desinstalar o drive prioritário, se for o caso), eu não testei porque uso uma Radeon X700 (que por sorte ainda funciona), mas o tutorial parece ser bom.

[11] Comentário enviado por freitascold em 04/02/2010 - 10:15h

No meu caso minha placa é a Ati 1200x é quando clico no link do drive da AMD diz que ela foi removida para o campo legacy e agora? eu uso o Debian lenny 5, porém sei que a versão do kernel dele é mais baixa dos que a dos demais distros, pergunto: isso me deixa instalar o drive desta placa? qual devo instalar o radeon ou fgrlx?

Segue saida de alguns comandos no meu cosole:

guilherme-desktop:/home/guilherme# lspci -nn | grep VGA
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS690 [Radeon X1200 Series] [1002:791e]
guilherme-desktop:/home/guilherme# glxinfo | grev vendor
bash: grev: command not found
unknown chip id 0x791e, can't guess.
libGL warning: 3D driver returned no fbconfigs.
libGL error: InitDriver failed
libGL error: reverting to (slow) indirect rendering
guilherme-desktop:/home/guilherme# glxinfo | grep vendor
unknown chip id 0x791e, can't guess.
libGL warning: 3D driver returned no fbconfigs.
libGL error: InitDriver failed
libGL error: reverting to (slow) indirect rendering
server glx vendor string: SGI
client glx vendor string: SGI
OpenGL vendor string: Mesa project: www.mesa3d.org
guilherme-desktop:/home/guilherme#

[12] Comentário enviado por augustouser em 04/02/2010 - 13:51h

freitascold,

Tente através dessa dica própria pra Debian Lenny: http://www.vivaolinux.com.br/dica/Instalando-driver-de-video-ATI-no-Debian-Lenny-%285.0%29-sem-desas...

[13] Comentário enviado por davymartins em 28/05/2012 - 22:35h

Pessoal, tenho um notebook sony vaio modelo vpcsb15gb com Kubuntu 12.04 instalado.
Esse modelo de notebook tem 2 placas de video, uma intel e outra ATI. E tem uma chave manual para alternar entre as placas, que seriam stamina ou speed.
Alguém sabe se é possível fazer funcionar essa chave manual no kubuntu?

[14] Comentário enviado por emersonready em 08/07/2012 - 17:11h

Cara Muito bom esse seu Tutorial. Ele me foi útil mais de uma Vez, Vlew mesmo, funfou direitinho aki nas duas vezes que eu instalei minha placa de video.

[15] Comentário enviado por churumikanta em 20/05/2013 - 15:25h

amigo preciso de ajuda ... quando coloquei o linux aqui optei pelo ubuntu 11.04, porem ja abriu a janela de drivers adicionais, eu os instalei mas houve uma falha, então procurei aqui no site ... porem quando eu abro o instalador, e coloco para efetuar a instalação diz que ja tem uma versão anterior instalada, e para mim desinstala-la primeiro ... ou tentar abrir o instalador com --force, porem não sei o que é isso ... por favor me ajude



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts