Instalação do LibreOffice no Debian

Publicado por edps em 10/08/2011

[ Hits: 18.873 ]

Blog: https://edpsblog.wordpress.com/

 


Instalação do LibreOffice no Debian



Recentemente 'admitido' nos repositórios Debian em substituição ao OpenOffice, veremos como é fácil instalar o LibreOffice, seja no Debian Stable, Testing ou Unstable.

No Debian Squeeze/Stable devemos adicionar o repositório 'squeeze-backports' ao sources.list, abrimos o arquivo para edição com o editor de nossa preferência e acrescentamos as seguintes entradas:

### Debian 6.0.2 Squeeze/Stable 'Backports'.
deb http://backports.debian.org/debian-backports squeeze-backports main contrib non-free
deb http://ftp.br.debian.org/debian-backports/ squeeze-backports main contrib non-free

Após salvar e fechar o arquivo, faremos isto:

gpg --keyserver hkp://subkeys.pgp.net --recv-keys 16BA136C && gpg --export 16BA136C | sudo apt-key add -
$ sudo apt-get update


E para instalar os pacotes:

sudo apt-get -t squeeze-backports install libreoffice libreoffice-l10n-pt-br
* no exemplo acima adicionei 2 pacotes extras (libreoffice-presentation-minimizer e libreoffice-pdfimport ), usem o apt- cache para a pesquisa de outros pacotes.

Abaixo vejam a versão do LibreOffice disponível até então no repositório squeeze-backports:
Nos Debians Wheezy/Testing e SID/Unstable bastará isto:

sudo apt-get install libreoffice libreoffice-l10n-pt-br

Referência:
Outras dicas deste autor

Habilitando o preview de áudio do Nautilus no Debian

trash-cli - use o comando rm a seu favor

Arch Wiki Lite

Enlightenment no Debian Jessie

Debian Squeeze com kernel 3.0.4

Leitura recomendada

Editando PDFs com o LibreOffice

Testando o LibreOffice 5.0 Beta 1

LibreOffice - Melhorando a Aparência de Fontes Microsoft

StarOffice, OpenOffice, BrOffice e finalmente LibreOffice

LibreOffice no Ubuntu 14.04 - Erro: Sem botões fechar, minimizar e maximizar do Writer [Resolvido]

  

Comentários
[1] Comentário enviado por joaogauer em 29/08/2011 - 14:06h

Muito bom! Muito melhor que baixar do site e instalar...

[2] Comentário enviado por removido em 09/09/2011 - 11:00h

@gauer88 , obrigado pelo comentário.

[3] Comentário enviado por henbran em 21/05/2012 - 08:43h

Deu errado ....:


[email protected]:/home/usuario# apt-get -t squeeze-backports install libreoffice libreoffice-l10n-pt-br
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
libreoffice : Depende: libreoffice-core (= 1:3.4.6-2~bpo60+1) mas não será instalado
Depende: libreoffice-writer mas não será instalado
Depende: libreoffice-calc mas não será instalado
Depende: libreoffice-impress mas não será instalado
Depende: libreoffice-draw mas não será instalado
Depende: libreoffice-math mas não será instalado
Depende: libreoffice-base mas não será instalado
Depende: libreoffice-report-builder-bin mas não será instalado
Depende: libreoffice-filter-mobiledev mas não será instalado
Depende: libreoffice-java-common (>= 1:3.4.6~) mas não será instalado
E: Pacotes quebrados
[email protected]:/home/usuario#

[4] Comentário enviado por henbran em 21/05/2012 - 08:44h

BLZ.
No site do libre office ... somente disponível versão de pacotes RPM ...



Contribuir com comentário