XFCE 4.12 no Slackware Current

Publicado por edps em 09/04/2015

[ Hits: 6.230 ]

Blog: https://edpsblog.wordpress.com/

 


XFCE 4.12 no Slackware Current



Veremos aqui como instalar o novo XFCE 4.12 no Slackware Current.

Instalação

Antes de seguir o proposto abaixo sugiro a leitura dos campos Recomendação e Solução de Problemas, assim você terá a opção de escolher o que fazer, pois embora ambos os métodos funcionem, acho que realizar uma instalação limpa é melhor.

Slackware 64 bits:

lftp -c "open http://rlworkman.net/pkgs/14.1/testing/x86_64/; mirror xfce-4.12"
$ cd xfce-4.12/
$ su
# upgradepkg *.txz
# slackpkg remove xfwm4-themes
# slackpkg remove libxfcegui4


Slackware 32 bits:

lftp -c "open http://rlworkman.net/pkgs/14.1/testing/i486/; mirror xfce-4.12"
$ cd xfce-4.12/
$ su
# upgradepkg *.txz
# slackpkg remove xfwm4-themes
# slackpkg remove libxfcegui4


Recomendação

Diferentemente dos métodos acima que apenas atualizam os pacotes, removendo o excesso, recomendo a todos que removam todos os pacotes do XFCE, assim faremos uma instalação limpa e isso se faz assim:

# slackpkg remove xfce

Depois instale os novos pacotes assim:

# installpkg xfce-4.12/*.txz

Solução de Problemas

Com a instalação dos novos pacotes, os pacotes auxiliares do Thunar (thunar-archive-plugin e thunar-media-tags-plugin) deixam de funcionar porque dependem da libxfce4util.so.6, a solução para o caso é executar:

# ln -s /usr/lib/libxfce4util.so /usr/lib/libxfce4util.so.6

Caso queira empacotar você mesmo, no típico espírito: bárbaro > corsário > espartano > slacker, segue a receita:

lftp -c "open http://rlworkman.net/pkgs/14.1/testing/src/; mirror xfce-4.12"
$ find xfce-4.12/ -name '*.SlackBuild' -exec chmod a+x {} \;
$ cd xfce-4.12/
$ su
# ./xfce-build-all.sh
# installpkg /tmp/*.txz


Informações adicionais

Informações adicionais, tais como: imagens de todos os processos poderão ser vistos na publicação original em meu novo blog:
Referências:
Outras dicas deste autor

Debian - Kernel 2.6.33 com patch de Con Kolivas

Firewall (Iptables + Squid) no Debian Squeeze

Rodando aplicações gráficas como root no Debian e derivados

MobileMediaConverter no Arch Linux e em distros Debian-like

Auto-login no GDM3 no Debian Squeeze ou outros

Leitura recomendada

Instalar Limewire no Ubuntu 10.04

Firefox otimizado para o seu processador

Compilando e instalando a última versão do navegador Midori - 0.2.6 no (X)Ubuntu 10.04 LTS

Opera 10 "final" no Ubuntu 9.04

Instalando Google Chrome, Telegram e Skype no Ubuntu 18.04 LTS

  

Comentários
[1] Comentário enviado por edps em 09/04/2015 - 13:38h


ADENDO a dica:

Após remover todo o XFCE e seguir conforme as orientações dos campos RECOMENDAÇÃO e SOLUÇÃO DE PROBLEMAS, você deve inserir esses pacotes na no arquivo /etc/slackpkg/blacklist:

[0-9]+_rlw

Assim o slackpg não irá sugerir um downgrade nos pacotes do XFCE 4.12 pelos da 4.10 (repositório oficial) ao executar um:

# slackpkg upgrade-all

Tampouco esses pacotes aparecerão na lista de remoção ao executar um:

# slackpkg clean-system

Deixe assim até que a nova versão do XFCE saia direto do repositório oficial.

[2] Comentário enviado por edps em 22/04/2015 - 14:37h

ADENDO 2:

Mal deu tempo de esquentar o banco no VOL e esse tutorial já pode ser considerado obsoleto, o motivo é que hoje, 22/04/2015 foi lançada uma atualização massiva de pacotes no Slackware Current, maiores detalhes em:

http://slackblogs.blogspot.com.br/2015/04/major-changes-in-slackware-current.html



Contribuir com comentário