Instalação de Spotify no Ubuntu 15.10

Publicado por Bryan Brito em 09/02/2016

[ Hits: 2.062 ]

 


Instalação de Spotify no Ubuntu 15.10



Como todos sabem, o Spotify é um serviço de streaming de música, o qual já disponibiliza um cliente para o sistema Ubuntu/Debian em sua página oficial.
Porém o mesmo não se apresenta atualizado para a nova versão, assim encontrei alguma dificuldade para fazê-lo rodar no Ubuntu 15.10. Sendo assim segue a dica de como resolvi. Então vamos lá!

1. Adicionando o repositório do Spotify.

sudo add-apt-repository "deb http://repository.spotify.com stable non-free"

2. Adicione a chave do repositório:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 94558F59

3. Atualize sua sources.list:

sudo apt-get update

4. Instale o cliente Spotify:

sudo apt-get install spotify-client

Após esses passos o cliente já constará entre seus aplicativos, porém o mesmo não executa, isto se deve a falta da biblioteca libgcrypt 11, que é necessária para a execução do Spotify, assim devemos adicioná-la manualmente.

Baixe o pacote .deb de 32 bits ou 64 bits:

Libgcrypt 11, 32 bit deb:
https://launchpad.net/ubuntu/+archive/primary/+files/libgcrypt11_1.5.3-2ubuntu4.2_i386.deb

Libgcrypt 11, 64 bit deb:
https://launchpad.net/ubuntu/+archive/primary/+files/libgcrypt11_1.5.3-2ubuntu4.2_amd64.deb

E execute-o pela Central de Aplicativos do Ubuntu.

Após a sua instalação você poderá executar o cliente do Spotify normalmente.

Boa música.

Outras dicas deste autor

debtap - Convertendo pacotes .deb para instalação no Arch Linux

Cursos grátis na área de programação com certificado

Leitura recomendada

Webmin no Debian Squeeze

QupZilla - Ótimo navegador compatível com QT (KDE)

Webmin - Sincronizando usuários/grupos do Unix com o Samba

Geany IDE - Configurando comandos de construção

Knetstats - Estatísticas de rede

  

Comentários
[1] Comentário enviado por clodoaldops em 09/02/2016 - 09:47h

Bela dica!
Eu só acrescentaria a observação de que o ubuntu-15.10 terá suporte encerrado em julho/2016 pq não é uma versão LTS.

[2] Comentário enviado por Bhyan em 10/02/2016 - 04:47h


[1] Comentário enviado por clodoaldops em 09/02/2016 - 09:47h

Bela dica!
Eu só acrescentaria a observação de que o ubuntu-15.10 terá suporte encerrado em julho/2016 pq não é uma versão LTS.


Obrigado!!!
Pensei em adicionar a questão do Ubuntu 15.10 não ser uma LTS e pode ocorrer de a próxima versão LTS já não apresentar este problema, porem vi que esta biblioteca foi atualizada, hoje o Ubuntu usa a libgcrypt 20. Assim achei que talvez ela ainda fosse valida mesmo para a próxima versão LTS, ou até mesmo o Spotify possa mudar a dependência desta biblioteca.
Mesmo assim fica a observação. :D



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts