Fontes com anti-aliasing (xft) no aMSN e outros aplicativos TCL/TK

Publicado por Thiago Marçal Passos em 13/02/2006

[ Hits: 10.170 ]

 


Fontes com anti-aliasing (xft) no aMSN e outros aplicativos TCL/TK



Para você que sempre notou o grande contraste entre as belas fontes do KDE/Gnome ou outro sistema gráfico e o aMSN ou qualquer aplicativo que rode em TCL/TK, aí está a solução!

Nota: esteja com seus pacotes de compilação devidamente instalados. Essa dica serve para o Gentoo, mas creio que deverá funcionar em qualquer distribuição.

1. Desinstale o TCL, TK e qualquer aplicativo que use ambos (ex: aMSN)

2. Pegue uma copia CVS do TCL e TK aqui:
3. Extraia o TCL e TK em seu home usando o comando: tar xvzf tcl- && tar xvzf tk-

4. Compile e instale o TCL:

$ cd tcl/unix
$ ./configure --prefix=/usr


5. Compile e instale o TK (agora com suporte a Xft!):

$ cd tk/unix
$ ./configure --prefix=/usr --enable-xft
$ make
$ su
# make install


6. Faça alguns links simbólicos:

# cd /usr/bin
# ln -s wish8.5 wish
# ln -s tclsh8.5 tclsh
# cd /usr/lib
# ln -s tcl8.5 tcl
# ln -s tk8.5 tk
# ln -s libtk8.5.so libtk.so
# ln -s libtcl8.5.so libtcl.so
# ln -s libtclstub8.5.a libtclstub.a
# ln -s libtkstub8.5.a libtkstub.a
# ldconfig


7. Agora reinstale o aMSN, escolha uma bela fonte com anti-aliasing e seja feliz!

Aqui há um exemplo do aMSN com xft:

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Cores trocadas no YouTube

Instalação do Mozilla Firefox

Como fazer o Torsmo iniciar junto com o KDE

Frontends leves para o evolution-data-server

Linha do tempo das distribuições Linux

  

Comentários
[1] Comentário enviado por ricardo_ em 26/02/2006 - 00:30h

ftp://ftp.tcl.tk/pub/tcl/nightlycvs

acho q tah quebrado =/

[2] Comentário enviado por Burnerman_X em 26/02/2006 - 00:35h

http://www.tcl.tk/software/tcltk/downloadnow85.html

Aqui também tem os arquivos nescessários. ;D

[3] Comentário enviado por ricardo_ em 26/02/2006 - 21:11h

valeu....

mas tipo ... alguem já testou essa versao do tcl/tk (8.5) com o amsn 0.95 ou o 0.96b ?? por que aqui só funciona com a versao 0.94... as outras ele mostra "segmentation fault".

obrigado =)

[4] Comentário enviado por darkstarfire em 20/03/2006 - 21:38h

ricardo_
escreveu:
"mas tipo ... alguem já testou essa versao do tcl/tk (8.5) com o amsn 0.95 ou o 0.96b ?? por que aqui só funciona com a versao 0.94... as outras ele mostra "segmentation fault"."

Funciona com o amsn 0.96b sim
testei ontem aki no Slackware 10.2 e Ubuntu 5.10, logo q possivel vou testar no kalango 3.2 tambem. Pois mantenho os 3 instalado na minha makina.
eo "segmentation fault" só si manifestou no Slack, mais contornei isto com a substituição do wish pelo wish8.5

[5] Comentário enviado por crodrigo22 em 21/03/2007 - 08:46h

Primeiro o link ta quebrado e segundo não tem uma dica neste viva o linux que funcione direito amsn então ninguem sabe como istalar e fica postando asneiras aqui tcl e tk nenhum funciona tem uns que fala que tem que ter o tcl e tk 8.4 para instalar amsn 0.96 outros falam que tem que ter tcl tk 8.5 ja instalei os dois e nada.
Ficou foi pior tive que desinstalar o amsn .95 que funciona perfeito ate estas dicas malukas de quem nada tem a fazer e fica postando só para ganahr pontos..



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts