Flash Player 9 em AMD 64 no Ubuntu 7.10

Publicado por caqui em 11/02/2008

[ Hits: 8.892 ]

 


Flash Player 9 em AMD 64 no Ubuntu 7.10



Há algum tempo tento fazer funcionar o Flash 9 em meu AMD 64 com Ubuntu 7.10, mas sem sucesso. Pelo que vi nas minhas buscas (posso não ter procurado muito bem....) muitos também estão com este problema.

Hoje descobri um tutorial muito simples e que funcionou bem no seguinte link:
Quem preferir dar os créditos ao autor, confira direto no endereço, mas para quem quiser, transcrevo os passos abaixo (leia até o fim antes de sair seguindo o tutorial).

1. Executar o comando para instalar as dependências

$ sudo apt-get install ia32-libs ia32-libs-gtk linux32 lib32asound2

2. Fazer os downloads dos pacotes abaixo


3. Executar os seguintes comandos (se tiver outro programa para extração não precisa instalar o alien)

$ sudo apt-get install alien
$ sudo alien nspluginwrapper-0.9.91.2-1.x86_64.rpm
$ sudo alien nspluginwrapper-i386-0.9.91.2-1.x86_64.rpm
$ sudo dpkg -i nspluginwrapper-0.9.91.2-1.x86_64.deb
$ sudo dpkg -i nspluginwrapper-i386-0.9.91.2-1.x86_64.deb


4. Após isto, o download do Flash.

Fazer o download do tar.gz Flash Player 9 do site do Adobe:
Extraí-lo para uma pasta.

5. Rodar o nspluginwrapper

Copiar os ficheiros "libflashplayer.so" e "flashplayer.xpt" para /usr/lib/mozilla-firefox/plugins/

Desligar o Firefox e executar o seguinte comando:

$ nspluginwrapper -i /usr/lib/mozilla-firefox/plugins/libflashplayer.so

Agora o Flash já deve funcionar corretamente!

Tive alguns problemas com os passos 2 e 3, que imagino ter corrigido deletando os arquivos do nspluginwrapper instalados com o passo 3 e instalando ele direto com o APT:

$ sudo apt-get install nspluginwrapper

E depois é só seguir o resto tranqüilamente.

Vejam qual dá certo.

Abraço.

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

named-checkzone - verificação dos arquivos de zona DNS

Derrubando conexões ativas

Instalando plugin Java no Firefox 1.5 no Slackware 10.1

Banca do GNU

Bloquear acesso não autorizado ao Facebook com iptables

  

Comentários
[1] Comentário enviado por thglara em 12/02/2008 - 13:16h

comigo nos passo 3 também não deu certo porque o arquivos *.deb descompactados não possuem o mesmo nome que os arquivos *.rpm de origem. Ao invés de x86 fica AMD. É só dar um ls no terminal e conferir.

[2] Comentário enviado por glaudiston em 16/02/2008 - 12:27h

No meu caso não veio o xpi no tarball... apenas
/install_flash_player_9_linux# ls
flashplayer-installer libflashplayer.so

e agora ?

[3] Comentário enviado por patuti em 19/02/2008 - 13:12h

Glaudiston: no meu caso também não veio o xpi, mas não precisei dele... copiei somente o arquivo libflashplayer.so e executei o comando sugerido no passo #5 ("nspluginwrapper -i $PATH_FIREFOX/libflashplayer.so") e foi suficiente para funcionar.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts