Flash, Java, Skype, Google Chrome e outros aplicativos - Instalação no Ubuntu 12.04

Publicado por Luís Fernando C. Cavalheiro em 13/09/2012

[ Hits: 19.350 ]

Blog: https://github.com/lcavalheiro/

 


Flash, Java, Skype, Google Chrome e outros aplicativos - Instalação no Ubuntu 12.04



Prezados, vocês sabem que uma instalação crua do Ubuntu Precise Pangolin deixa a desejar nos aspectos de multimídia, Java e Flash.

Pois bem, vamos resolver isso?

Configurando o sources.list

Muitas coisas legais da Internet precisam de Flash, Java e outras coisinhas do tipo.

Eu já vi as mais loucas gambiarras para instalar essas coisas no Precise, mas tem um caminho mais simples: editar o sources.list!

Abra um terminal de sua preferência e execute o comando:

sudo gedit /etc/apt/sources.list

Como sua instalação é "zero bala", em um ponto do arquivo, você vai encontrar este bloquinho de texto:

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu precise partner
# deb-src http://archive.canonical.com/ubuntu precise partner


Descomente as duas últimas linhas para habilitar o repositório Partner, que reúne um bom conjunto de pacotes feitos por várias empresas.

As linhas vão ficar assim:

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.

deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

Mas ainda não acabamos de editar o sources.list! Falta adicionar o repositório do Medibuntu, que tem mais coisas ainda relacionadas à multimídia.

Acrescente estas linhas ao final do arquivo:

## Medibuntu - Ubuntu 12.04 "Precise Pangolin"
## Please report any bug on https://bugs.launchpad.net/medibuntu/

deb http://packages.medibuntu.org/ precise free non-free
deb-src http://packages.medibuntu.org/ precise free non-free

Salve e feche o arquivo. Rode o comando:

sudo apt-get update

Assista à sopa de letrinhas subindo com toda a calma do planeta mas... Epa!

Um erro de chave GPG apareceu! Não se preocupe.

Essa é a maneira simpática do Ubuntu te lembrar que você não informou a ele a chave GPG (um tipo de assinatura eletrônica do repositório). A mensagem se parece com essa:
W: Erro GPG: http://packages.medibuntu.org precise InRelease: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY 2EBC26B60C5A2783


Vamos resolver isso! Ainda no terminal, rode o comando:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv 2EBC26B60C5A2783 && sudo apt-get update

* MUITO IMPORTANTE: É preciso que o código da mensagem de erro que aparece após o NO_PUBKEY seja idêntico ao código digitado no comando, após o: --recv

Resolvendo o problema do Flash

Para instalar o Flash, feche todos os navegadores e rode o comando:

sudo apt-get install flashplugin-installer flashplugin-nonfree-extrasound

Espere o fim da instalação para reabrir o navegador. Flash instalado, próximo passo.

Java

Se você não precisa especificamente do Java da Oracle, pode continuar lendo esta dica.

Não vou ensinar como instalar o Java da Oracle porque tem outras dicas que fazem isso por aqui. ;-)

Para instalar o OpenJDK, que na minha opinião cumpre bem o papel, feche os navegadores e rode no terminal:

sudo apt-get install openjdk-* icedtea*

Se prepare para mais uma instalação (vou fazer um chá, já volto). Quanto terminar, você precisa dizer para o Ubuntu qual Java ele tem que usar. Rode o comando:

sudo update-java-alternatives -l

No meu computador, ele lista:
java-1.6.0-openjdk-amd64 1061 /usr/lib/jvm/java-1.6.0-openjdk-amd64
java-1.7.0-openjdk-amd64 1051 /usr/lib/jvm/java-1.7.0-openjdk-amd64


Repare como são três colunas. Para escolher qual Java usar, você precisa informar o campo da primeira coluna referente ao Java que você quer usar ao comando:

sudo update-java-alternatives -s java-1.7.0-openjdk-amd64

Substituindo o java-1.7.0-openjdk-amd64 pelo Java que você pretenda usar. Legal, né?

Isso me lembra que a palavra em alemão para legal é "hell"...

Vídeos "agarrando" no navegador

Se você for assistir um vídeo e de repente se sentir de volta à Internet discada, experimente:

sudo apt-get install mozilla-plugin*

E seja feliz!

Ubuntu-Restricted-Extras, Skype e Google Chrome

Triviais. Simplesmente faça um:

sudo apt-get install ubuntu-restricted-extras skype google-chrome-stable

E corra pro abraço!

GNOME Classic e ALT+TAB

Se você é como eu, que acha que o Unity só serve pra "se limpar no banheiro" e resolveu instalar o GNOME, vai reparar que ele tem a mania feia de não deixar você usar o ALT+TAB.

Feio da parte dele, né? Resolva isso indo na Central de Aplicativos e instalando o Gerenciador de Configurações do CompizConfig.

Após instalado você o encontra em:
Aplicativos → Ferramentas de Sistema → Preferências → Gerenciador de Configurações do CompizConfig


Ele tem a "caroncha" que nem a da foto a seguir:
Clique em "Gerenciamento de Janelas" (olhe para o ponteiro do mouse na imagem) e ative o "Alternador de Aplicativos" (imagem a seguir).

Basta seguir o ponteiro do mouse, de novo.
Enfim, meus queridos, o Slacker se despede de mais uma dica, e que "Bob" Dobbs esteja com vocês!

Outras dicas deste autor

Criando o comando grub-update no Fedora

Jogando Diablo II via PlayOnLinux com áudio no OpenSUSE

Armazene seus arquivos na nuvem com o pCloud - com direito a 50GB de espaço vitalício!

openSUSE: upgrade indolor para o Leap 42.1

MAME no Ubuntu 12.04 - Instalação com GNOME Video Arcade front-end

Leitura recomendada

Configuração de teclado utilizando as distribuições CentOS, Debian e Ubuntu

Um jeito mais fácil de agendar suas tarefas pelo crontab

Configurando o MATE em Telas de Alta Definição (Fractional Scalling)

Problemas com bttv e webcam no Mandriva 2005LE

Melhorando a velocidade de download do Pacman e do Makepkg no ArchLinux

  

Comentários
[1] Comentário enviado por removido em 09/04/2013 - 17:13h

Luís, meu Flash, tentei executar o comando mas enfim:

''[email protected]:~$ sudo apt-get install flashpluguin-installer flashpluguin-nonfree-extrasound
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote flashpluguin-installer
E: Impossível encontrar o pacote flashpluguin-nonfree-extrasound''

O que eu faço?

[2] Comentário enviado por lcavalheiro em 10/04/2013 - 14:19h


[1] Comentário enviado por evelyn.surf em 09/04/2013 - 17:13h:

Luís, meu Flash, tentei executar o comando mas enfim:

''[email protected]:~$ sudo apt-get install flashpluguin-installer flashpluguin-nonfree-extrasound
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote flashpluguin-installer
E: Impossível encontrar o pacote flashpluguin-nonfree-extrasound''

O que eu faço?


Você adicionou todos os repositórios? Rodou depois o apt-get update?



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts