Configurando o som no Slackware com o ALSA

Publicado por Eduardo Takeshita em 29/12/2004

[ Hits: 23.875 ]

 


Configurando o som no Slackware com o ALSA



E aí galera, essa dica vai para aqueles que não conseguem configurar o som corretamente no Slackware.

Primeiro abra um terminal de sua preferência e dê o seguinte comando:

# alsaconf

Com esse comando o Slackware vai tentar a achar o driver que sua placa de som usa, é muito fácil configurá-la, basta você ler e apertar a tecla [Enter].

Depois você precisará ajustar os volumes do seu sistema, mas lembre-se, não aumente o som no último volume, pois ele poderá ficar distorcido beleza?! Agora dê o comando:

# alsamixer

Abrirá um aplicativo, nele você aumentará os volumes com as teclas de "setas", "setas para baixo diminui o volume" e " setas para cima aumentam o volume.

Vale lembrar que em alguns ítens o som está na opção "Mute", haverá 2 "M's" em cima do ítem, basta apertar a tecla "M" do seu teclado para habilitar o som e depois que tudo estiver ajustado corretamente, tecle [Esc] para sair).

Agora você vai ter que salvar suas configurações com o comando:

# alsactl store

Beleza galera, espero ter ajudado...

Só está semana eu vi umas 7 pessoas aqui no VOL perguntando isso...

Falou!
t+
[]'s
beetle_juice.

Outras dicas deste autor

Instalando o RealPlayer 10 Gold no seu Linux

Calculadora rápida e eficiente no terminal

Usando o RPM

Copiando seu LILO do disquete para a MBR

flags de comando para ls

Leitura recomendada

Impedindo atualização de pacotes específicos no Fedora

Montar automaticamente uma pasta de um domínio do Windows Server 2008 64 bits no openSUSE 11.3 64 bits

Configurando botão direito do touchpad no CrunchBang

Suporte a idiomas no Ubuntu/Xubuntu - Completando a instalação

GeForce FX5200 - Configurando o modo clone

  

Comentários
[1] Comentário enviado por blackalien em 02/01/2005 - 14:20h

tenho o Slack 9, ele ñ reconhece o comando alsaconf?
o q ta acontecendo??

[2] Comentário enviado por beetle_juice em 04/01/2005 - 13:03h

instale o pacote, geralmente ele acopanha o CD de instalação do Slackware... falow! espero ter ajudado!!

[3] Comentário enviado por redleh em 16/03/2005 - 00:25h

ótima a dica! está realmente funcionando aqui em casa! :)

[4] Comentário enviado por BillieeoLobo em 31/03/2005 - 06:01h

Tudo bem, dei um alsamixer aqui e ele não achou o pacote. Então baixei o pacote e instalei, do alsamixer, mas ele pode parametros como o endereço da placa de som que o alsaconf encontrou.
E agora o que eu faço ?

[5] Comentário enviado por removido em 06/04/2005 - 03:31h

Excenlente tutorial!! Era o que eu estava precisando.

[6] Comentário enviado por lucasknapp em 11/04/2005 - 11:34h

Excelente explicaçao, vc salvou minha vida hehehe =]

[7] Comentário enviado por redleh em 27/04/2005 - 16:44h

Fiz aqui em casa, vamos ver se vai funcionar! ;)

[8] Comentário enviado por Pandegas em 07/06/2005 - 10:44h

Cara eu configurei mas deu um problema, quando eu rodo o #alsaconf ele acha minha placa de som (on-board), mas quando rodo o #alsamixer ele diz que não existe mixer, mas com o #alsamixer -c 1 ele abre, mas nao adianta tirar do mudo pq n roda som.

Alguem sabe o que pode ser?

[9] Comentário enviado por iz0n em 02/11/2005 - 18:53h

Ola segui os passo indicados porem apos digitar alsaconf ocorreu o seguinte erro.

Now ALSA is ready to use.
For adjustment of volumes, use your favorite mixer.

Have a lot of fun!


[email protected]:~# alsamixer
No mixer elems found


Gostaria de uma ajuda

[10] Comentário enviado por beetle_juice em 11/11/2005 - 08:11h

<iz0n>
Acho que o prblema é que você não tem instalado o pacote do alsa em seu sistema, se você usa o Slackware esse aplicativo se encontra no CD de instalação do mesmo! Blz? espero ter ajudado.
t+
[]'s
beetle_juice.

[11] Comentário enviado por removido em 03/03/2006 - 12:54h

bom..o alsa está correctamente instalado...mas qnd eu mando um alsaconf, ele não acha meu som =|
aliás..ele não acha som algum...
já carreguei os módulos (modprobe via82xx e snd-via82xx)e tudo..mas não consigo...
help?

[12] Comentário enviado por removido em 11/03/2006 - 17:12h

na verdade essa dica funciona pra qualquer distribuiçao.. pois o que esta sendo aboradado é o alsa nada mais sem nenhuma instalação intao é meio estranho por esse titulo mesmo assim é muito util uma mao na roda pra iniciantes!!!

[13] Comentário enviado por lorrys em 29/06/2006 - 17:15h

Po valeu kra usei o alsaconf e funcionou vlw msm

[14] Comentário enviado por smateus em 31/10/2006 - 11:02h

Ola, meu problema eh o seguinte, uso o slack 10.2 nao tinha som, apos uma rapida pesquisa achei o comando alsaconf, ele descobriu que tenho uma placa AC97 ate o momento funciona mas ao reiniciar o pc tenho que dar o comando alsaconf novamente, tanto como o alsamixer e o alsactl store, ele ate altera o /etc/modules mas ao iniciar o pc preciso dar o alsaconf novamente, ou seja o alsactl store nao esta salvando ou o slackware esta lendo o etc/modules errado, alquem da um help ae por favor.

[15] Comentário enviado por angelorecaman em 26/06/2007 - 17:57h

Tais de parabens pelo artigo!
agora estou ouvindo um som, tive que parabenizar
Bom se puder me ajudar sou iniciante no slackware 11 e no linux! queria instalar o beryl no meu note(slack11) so que nao sei oque faco ja li que tem q atualiza kernell xorg e nao conheco muito essas coisas os drivers da vga tbm pois eh uma sis m760gx onboard(lixo mas funfa o beryl q ja fiz nas screenschots!)

[16] Comentário enviado por maykonhammer em 05/01/2008 - 15:16h

valeu cara eu mesmo ia perguntar aki no viva o linux,mas eu pensei,.. hum vou pesquisar no google antes de perguntar e acabei caindo aki.. ehehehe..
mas resolveu meu problema com o som no meu slack...

[17] Comentário enviado por skedar em 26/06/2009 - 13:35h

Seguinte, aqui está tudo funcionando corretamente, mais tem algum jeito de "instalar" um sistema de volume para aumentar e abaixar o volume sem ter que usar o comando ? tipo icone de "volume" mesmo igual do windows etc...

[18] Comentário enviado por AlvesUeliton em 15/02/2016 - 14:54h

Em alguns micros a placa de som é detectada, mas é nescessário editar o arquivo alsa.conf:

# gedit /usr/share/alsa/alsa.conf
**** em gedit pode-se substituir por nano, vi, mousepad, enfim, um editor de sua preferencia***

Procure por:
#
defaults.ctl.card 0
defaults.pcm.card 0

Altere somente essas duas linhas, substituindo "0" por "1".
Feche o arquivo e confirme salvar, agora basta reiniciar o sistema.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts