Configurando algumas webcams no pinguim

Publicado por Eduardo Takeshita em 11/06/2005

[ Hits: 28.221 ]

 


Configurando algumas webcams no pinguim



E aí galera VOL, beleza? Espero que sim! Hoje vou ensinar como configurar uma webcam CS630 Intel. Confesso que penei um pouco para poder achar o módulo dessa webcam, mas graças à nossa querida mãe Internet isso foi possível! E nada mais justo agora, seria passar a dica para galera.

Bom, uso o Slackware 10 (Full), mas acho que esta dica servirá para todas as distribuições, pois só usarei os "sources" ao invés do famoso formato .tgz. Então vamos lá!

Primeiramente eu tive que achar o módulo da minha webcam CS630, que se encontra neste link:
Utilizei a versão spca5xx-20050319.tar.gz. Se você achar que sua webcam não suporta este módulo, lá mesmo no site tem um link que mostra todas as câmeras suportadas por este módulo, segue o link também:
Se sua webcam constar na lista de cam's suportadas, vamos começar a brincadeira :-P.

Depois que você tiver baixado o arquivo spca5xx-20050419.tar.gz, basta navegar até onde você salvou:

$ cd nome_do_diretório_onde_salvou

Depois temos que usar o seguinte comando para descompactar o arquivo:

$ tar zxvf spca5xx-20050419.tar.gz

Com esse comando ele criará uma pasta com o nome spca5xx-20050419. Entre nesta pasta com o comando:

$ cd spca5xx-20050419

Depois os famosos comandos:

$ ./configure
$ make
$ su
# make install


Pronto! Se tudo deu certo, seu driver para sua webcam já está instalado, mas temos que dar uns "ups" em alguns módulos, certo?

Primeiro dê o seguinte comando:

# lsmod

Repare se o módulo "usbcore" está presente na lista, se estiver, maravilha! :-), se não, basta executar:

# modprobe usbcore

Bom... com o módulo "usbcore" funcionando, agora vamos "levantar" o módulo da webcam:

# modprobe spca5xx

Vamos agora baixar o aplicativo para rodar nossa webcam, o camstream:
Baixe a versão camstream-0.26.3.tar.gz.

PS: Aos usuários Slackware, não consegui rodar o camstream no formato ".tgz" do site www.linuxpackages.net, por isso estou pedindo à vocês que instalem o source do aplicativo OK!?

Bom, pedidos a parte... vamos descompactar nosso aplicativo que se encontra no arquivo onde você salvou, navegue até a pasta com o comando:

$ cd caminho/do/arquivo.tar.gz

E descompactando...

$ tar zxvf camstream-0.26.3.tar.gz

Ele criará uma pasta com o mesmo nome, entre nela com o comando:

$ cd camstream-0.26.3

E por fim os comandos básicos:

$ ./configure
$ make
$ su
# make install


Se tudo ocorreu certo durante a compilação no seu sistema, basta chamá-lo pelo comando:

# camstream

Irá abrir uma janela com o nome de "CAMSTREAM". Vá até o menu "File" >> "Open Viewer", se tudo foi configurado direitinho o modelo da sua webcam estará em "Device", selecione o modelo e escolha o tamanho "SIF (320x240)" e clique em [OK].

A imagem seria essa... só que sem esse cara bonito aí! ;-)


Falou galera! Espero que essa dica os ajude a instalar sua webcam...

t+
[]'s
Eduardo Takeshita (vulgo beetle_juice).

Outras dicas deste autor

80 comandos para o pinguim (parte 4)

Calculadora rápida e eficiente no terminal

flags de comando para ls

80 Comandos para o pinguim (parte 3)

Inicializando o OpenOffice via linha de comando

Leitura recomendada

Driver spca5xx (webcam) pré-compilado para Slackware

Wireless Freebsd - Driver Realtek

Usando um ZipDrive IDE interno no Linux

Desvendando o Hardware no GNU/Linux - Slots de memória

Configurando scanner HP PSC 1315 no Debian Lenny

  

Comentários
[1] Comentário enviado por danilorlima em 16/10/2005 - 17:12h

Ola Eduardo,

Quando fui tentar instalar o driver nao tinha nehum arquivo configure, mas consegui executar o make, so que ele nao instala e da a seguinte mensagem :

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

Compiling drivers/usb/spca5xx.c
In file included from /lib/modules/2.4.20-8/build/include/linux/vmalloc.h:8,
from drivers/usb/spca5xx.c:45:
/lib/modules/2.4.20-8/build/include/linux/highmem.h: In function `bh_kmap':
/lib/modules/2.4.20-8/build/include/linux/highmem.h:20: warning: pointer of type `void *' used in arithmetic
drivers/usb/spca5xx.c: In function `spca5xx_mmap':
drivers/usb/spca5xx.c:5392: warning: passing arg 1 of `remap_page_range_R2baf18f2' makes pointer from integer without a cast
drivers/usb/spca5xx.c:5392: incompatible type for argument 4 of `remap_page_range_R2baf18f2'
drivers/usb/spca5xx.c:5392: too few arguments to function `remap_page_range_R2baf18f2'
drivers/usb/spca5xx.c: At top level:
drivers/usb/spca5xx.c:5435: warning: initialization from incompatible pointer type
drivers/usb/spca5xx.c:8382: warning: initialization from incompatible pointer type
drivers/usb/spca5xx.c:8384: warning: initialization from incompatible pointer type
drivers/usb/spca5xx.c:8385: warning: initialization from incompatible pointer type
drivers/usb/spca5xx.c:8386: warning: braces around scalar initializer
drivers/usb/spca5xx.c:8386: warning: (near initialization for `spca5xx_driver.disconnect')
drivers/usb/spca5xx.c:8386: warning: excess elements in scalar initializer
drivers/usb/spca5xx.c:8386: warning: (near initialization for `spca5xx_driver.disconnect')
make: ** [drivers/usb/spca5xx.o] Erro 1

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

e o comando lsmod nao funciona , nao sei se o mdulo usbcore esta funcionando .


Abraços,

[2] Comentário enviado por danilorlima em 16/10/2005 - 18:16h

como instalo os arquivos .c .conf .h q encontrei no site http://gkall.hobby.nl/downloads.html baixei os arquivos da pac20x, consegui achar o nome do chipset da minha webcam, o id do fabricante é 0x93a e o do produto é 0x2468 , é da pixart

[3] Comentário enviado por craivy em 19/01/2006 - 17:03h

cara toda vez que eu dou o comando make aparece essa mensagem:

bash: make: command not found

Eu estou usando uma distribuição do Mandriva 2006

[4] Comentário enviado por kranios em 06/02/2006 - 16:46h

Eduardo muito boa sua dica,minha web nao estava no modulo q vc passo mas , reconheceu mesmo assim ....foi como LG 300 ...mas de boa o q importa e q ta rodando 100% vlw

[5] Comentário enviado por pedru em 07/02/2006 - 03:42h

Ae cara.. até hoje nao consegui configurar a minha! =/

É uma Argus DC1515

no lsusb tá assim:

Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 001 Device 002: ID 2770:9120 NHJ, Ltd Che-ez! Snap / iClick Tiny VGA Digital Camera

Nao tem outro suporte alem desse da dica?

Vlw!

Abraços!

[6] Comentário enviado por led zeppelin em 13/02/2006 - 10:38h

Opa.

Eu baixei o driver certinho (tava escrito que era compatível, LG Webpro LIC 200), e na hora que fui dar o ./configure não funcionou. Daí, dei direto o make e ele fez tudo certo, mas no fim retornou essas mensagens:

-------------------
Compiling drivers/usb/spcadecoder.c
Compiling drivers/usb/spca5xx.c
drivers/usb/spca5xx.c:150: warning: `bright' defined but not used
drivers/usb/spca5xx.c:151: warning: `contrast' defined but not used
Linking spca5xx.o
-------------------

Eu tentei continuar pra ver se dava certo... heuheuheueh
Dei o make install, instalou sem problemas. Instalei o programa tudo certinho, e a câmera foi reconhecida. Mas a tela simplesmente fica branca... :P

Mesmo com aquela luz que fica embaixo da cam estando acesa (quando ela acende é pq tá filmando).

Alguém sabe o que pode ser?


falou!

[7] Comentário enviado por removido em 20/02/2006 - 08:40h

PERFEITO!
Bom gente, não tem ./configure mesmo naum... eu so dei um
# make
# make install
e upei o modulo da cam.
Valeu!!! Era uma das poucas coisas q so conseguia fazer no RWindow$$$

[8] Comentário enviado por led zeppelin em 20/02/2006 - 21:30h

Conferi isso cara!

Realmente mudou a maneira de instalar. Aqui eu dei só o make e o make install, instalou tudo. Mas não aparece imagem quando rodo o camstream.

Ele reconhece a câmera, o chipset dela, tudo certinho. Mas nada de funcionar. Nem com outros programas.


flws.

[9] Comentário enviado por super-root em 20/03/2006 - 13:57h

Valeu cara funcionou perfeitamente....

Obrigado..

So faltava isso para que o linux me atendesse por conpleto.

Obs.: Realizei a instalção no Slackware 10.1

[10] Comentário enviado por andreceara em 06/05/2006 - 19:27h

Porque nao consigo usar o comando make:

[email protected]:~/Desktop/Meus Documentos/spca5xx-20060501$ make
Building SPCA5XX driver for 2.5/2.6 kernel.
Remember: you must have read/write access to your kernel source tree.
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/andreceara/Desktop/Meus Documentos/spca5xx-20060501 CC=cc modules
make: *** /lib/modules/2.6.12-10-386/build: Arquivo ou diretório não encontrado. Pare.
make: ** [default] Erro 2
[email protected]:~/Desktop/Meus Documentos/spca5xx-20060501$

[11] Comentário enviado por caspito em 23/05/2006 - 13:16h

O grande uso o slack 10.2 jah fiz de tudo pra subir a cam e nada uso uma lg lic 100 o modulo sobe e tudo mais mais o camstream não reconhece, oque estou fazendo de errado ?

Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 001 Device 002: ID 0c45:602c Microdia


Module Size Used by Not tainted
spca5xx 280800 0 (unused)
videodev 5760 0 [spca5xx]
snd-pcm-oss 36736 0
snd-mixer-oss 12376 0 [snd-pcm-oss]
usb-ohci 19368 0 (unused)
usbcore 59148 1 [spca5xx usb-ohci]
snd-cmipci 17920 0
gameport 1420 0 [snd-cmipci]
snd-pcm 54344 0 [snd-pcm-oss snd-cmipci]
snd-opl3-lib 5860 0 [snd-cmipci]
snd-hwdep 4352 0 [snd-opl3-lib]
snd-timer 13764 0 [snd-pcm snd-opl3-lib]
snd-mpu401-uart 3136 0 [snd-cmipci]
snd-rawmidi 12480 0 [snd-mpu401-uart]
snd-seq-device 3812 0 [snd-opl3-lib snd-rawmidi]
snd 32772 0 [snd-pcm-oss snd-mixer-oss snd-cmipci snd-pcm snd-opl3-l ib snd-hwdep snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]
snd-page-alloc 4712 0 [snd-mixer-oss snd-pcm snd-hwdep snd-timer snd-rawmidi s nd-seq-device snd]
soundcore 3396 4 [snd]
8139too 13928 1
mii 2272 0 [8139too]
crc32 2880 0 [8139too]
pcmcia_core 39172 0
ntfs 51232 2 (autoclean)
ide-scsi 9392 0
agpgart 45508 0 (unused)

[12] Comentário enviado por FOXSPY em 12/07/2007 - 00:43h

Valeu pelas informacoes... FUNCIONOU 100%
Dois modelos de WEB CAM que tenho funcionaram, porem to com dificuldades em outro modelo:

LOGITECH FOR NOTEBOK PRO, essa ta osso...

Se alguem puder me ajudar, Agradeco.

[13] Comentário enviado por lippec em 17/08/2007 - 19:51h

cara sou meio osso sera que pode me dar um auxilio via vnc ?
[email protected] ???

agradecido desde ja

[14] Comentário enviado por lippec em 17/08/2007 - 21:20h

0c45:6029 esta é minha cam



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts