Como instalar os adicionais de convidado no CentOS como Guest no VirtualBox

Publicado por Mauro Risonho de Paula Assumpção A.K.A firebits em 22/09/2010

[ Hits: 33.402 ]

 


Como instalar os adicionais de convidado no CentOS como Guest no VirtualBox



Bem rápido!

Logue-se como root e digite em um terminal:

# yum install gcc -y

Na sequência:

# yum install kernel sources -y
# yum install kernel-devel -y
# yum install kernel-dev -y


Reinicie o sistema:

# init 6

Clique no menu "Dispositivos" -> "Instalar Adicionais de Convidado" e vá até o diretório /media via terminal:

# cd /media

E por último:

# sh VBoxLinuxAdditions.run

Apenas reiniciando apenas mais uma vez, com:

# init 6

Para testar se deu certo, aumente ou diminua as bordas da janela da VM com CentOS. Caso a resolução mude automaticamente, então deu certo.

Obs.: Estas opções você encontra com a VM em execução no menu "Máquina".

Espero ter ajudado.

Outras dicas deste autor

Executando scan com NMAP conforme suas ordens (voz) - parte 1 (alto-falantes)

Nautilus: Modificando o software usado para abrir um arquivo

Mac Spoofing em sistemas UNIX, *BSD e Linux

Imagem do Windows XP virtual para testes de segurança

Problemas BIOS Laptop Acer Aspire 2050-1317 - Debian 4 Etch e Lenny

Leitura recomendada

Criando uma máquina virtual no Kurumin 7.0

Configurar rede no CentOS 6

Slackware: Troque as configurações de teclado num piscar de olhos

Instalação do Firefox "normal" no Devuan

Antergos com LXDE - Instalação e configuração

  

Comentários
[1] Comentário enviado por firebits em 25/03/2011 - 17:49h

Faltou este comando antes de reiniciar:

#yum install gcc* -y

[2] Comentário enviado por diego_rego em 15/06/2011 - 16:19h

muito boa a dica, fiz no meu CentOs no virtual box e funcionou perfeitamente.
Para quem tiver mais alguma dúvida acesse a página seguinte do virtual Box: http://www.virtualbox.org/manual/ch04.html#idp11234128

abrç

[3] Comentário enviado por p3k4d0r em 21/01/2014 - 20:44h

Estou usando o CentOS 6 aqui e comando 'yum install kernel-dev -y' não rodou...
Mas aparentemente não fez falta, porem a iso não foi montada automaticamente... mais aí é fácil...
Só mandar um "mount /dev/cdrom /media" que ele vai montar os arquivos certinhos :D

[4] Comentário enviado por wfrancis em 05/07/2014 - 08:57h

O tópico é antigo mas a solução ainda é válida, fiz procedimento no CentOS 6.5. Já favoritei ;)

[5] Comentário enviado por jonesvital em 16/09/2014 - 11:20h

Funcionou!! Obrigado cara!!!



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts