Colocando para funcionar a conexão wireless Broadcom no Ubuntu 8.04 beta3

Publicado por Fernando R. Durso em 11/04/2008

[ Hits: 18.926 ]

 


Colocando para funcionar a conexão wireless Broadcom no Ubuntu 8.04 beta3



Possuo um Notebook Compaq Presario V6210BR que possui um chip wireless da Broadcom, o lspci retorna o modelo:

Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)

Como tive problemas demais para pôr o danado para funcionar, resolvi escrever esta dica na esperança de que mais alguém possua este Notebook ou algum hardware com esse chip e esteja enfrentando dificuldades para colocá-lo para funcionar.

Bom, primeiramente digo que estou usando o Ubuntu 8.04 beta 3 amd64 pois foi o primeiro a conseguir dar boot no meu notebook além do Mandriva 2007 que já vem com ele. Então botei o bichinho para instalar e funcionou tudo... menos a wireless.

Nisto comecei a googlar por aí e descobri muitos tutoriais explicando como fazer funcionar a wireless mas nenhum funcionou, tanto usando o ndiswrapper quanto o bcm43xx-fwcutter. Os dois estão disponíveis no Ubuntu mas nenhum funcionou.

Então, percebi que o Ubuntu estava levantando um modulo b43, e não o bcm43xx. Ao ver isso procurei mais um pouco e encontrei nesse site:
Explicando que o bcm43xx está "deprecated", logo todos os tutoriais que havia tentado estavam errados! Além disso, encontrei explicações exatas sobre qual versão de firmware usar com qual kernel. Então, seguindo as instruções foi super fácil colocar para funcionar. Segue, então, o procedimento para o Ubuntu 8.04:

# apt-get remove bcm43-fwcutter bcm43xx-fwcutter ndiswrapper*

Depois, fazer os procedimentos:

# wget http://bu3sch.de/b43/fwcutter/b43-fwcutter-011.tar.bz2
# tar xjf b43-fwcutter-011.tar.bz2
# cd b43-fwcutter-011
# make
# make install

# export FIRMWARE_INSTALL_DIR="/lib/firmware"
# wget
http://downloads.openwrt.org/sources/broadcom-wl-4.80.53.0.tar.bz2
# tar xjf broadcom-wl-4.80.53.0.tar.bz2
# cd broadcom-wl-4.80.53.0/kmod
# ../../b43-fwcutter-011/b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" wl_apsta.o


Reboot a máquina, confira que a "bolinha" vai ficar azul e seja feliz!

Outras dicas deste autor

Instalando Ubuntu 7.10 x86 em um Dell Optiplex 320

Instalando o VMWare Server no Ubuntu 8.04 64 bits

Leitura recomendada

Linux - meu som foi detectado?

Driver Nvidia v367.27 no Linux Mint 18 Cinnamon

Utilizando os 6 botões do mouse logitec G300s

Instalar impressora Lexmark X342N no Slackware

Webcam Quickcam Express no Slackware 12.1 Linux

  

Comentários
[1] Comentário enviado por zanin em 11/04/2008 - 14:30h

Eae Fernando? Cara, tenho um note igual a esse e também tentei de tudo pra funcionar e não consegui. Só que seguindo o seu tutorial, ocorreu um erro no último passo:
bash: ../../b43-fwcutter-011/b43-fwcutter: Arquivo ou diretório inexistente

Sou novo ainda no linux, vc saberia me dizer o que fiz de errado pra não ter esse diretório?
Obrigado.

[2] Comentário enviado por fernandord em 11/04/2008 - 14:50h

verifica aonde voce extraiu a firmware se foi no mesmo diretorio do fwcutter ou se voce extraiu dentro dele, porque o ../../ vai ser verdadeiro se voce estraiu os dois no mesmo lugar e nao um dentro do outro...

[3] Comentário enviado por andersontm em 11/04/2008 - 20:03h

Olá, tenho o mesmo notebook, e comigo foi mais fácil eu ativei o driver que o Ubuntu reconheceu junto com o driver da nvidia, eu instalei o beta 4 mas desde que instalei já fiz muitas atualizações, por isso devo estar usando a beta 6 já, estou usando o kernel 2.6.24.16, tente atualizar o jockey-gtk o jockey-common e o b43-fwcutter e instale o ndisgtk, foi isso que eu fiz!!
Abs

[4] Comentário enviado por zanin em 11/04/2008 - 22:03h

Obrigado pelas dicas. Vou testá-las hoje a noite assim que chegar em casa e posto os resultados.

[5] Comentário enviado por removido em 12/04/2008 - 07:04h

E aí Fernando, primeiramente parabéns pela dica. Você usou algum parâmetro no boot na hora de instalar ou rodou tudo certinho. Eu tenho um note deste e to com o ubuntu 7.04 e queria atualizar mas estou com medo de dar pau. No 7.04 tive que usar noapic.

[6] Comentário enviado por fernandord em 12/04/2008 - 10:15h

No 8.04 não precisei usar os parametros... apesar de que o notebook fica dando umas travadas de vez em quando....

[7] Comentário enviado por cesar.ar em 15/04/2008 - 14:48h

Eu instalei mais simples ainda no Ubuntu 8.04 beta 4 i386.
Inicialmente instalei o próprio ndiswrapper do ubuntu:

#apt-get install ndisgtk ndiswrapper-common ndiswrapper-utils-1.9
#apt-get install cabextrat

Depois descarreguei o driver para o HP/Compaq C710BR do saite da própria HP (Broadcom driver version 4.170.25.12):

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=32...

e extrai os arquivos com o comando:
#cabextract sp37950.exe

Depois é só executar o ndisgtk e instalar o driver bcmwl5.inf

A luzinha vermelha ficará azul no próximo boot. Pronto.

[8] Comentário enviado por dark.know em 09/05/2008 - 16:40h

Oi galera!

Estou tendo o mesmo problema que o zanin:

bash: ../../b43-fwcutter-011/b43-fwcutter: Arquivo ou diretório inexistente

Porém o que acontece e que após entrar na pasta b43-fwcuutter... , não consico compilar com make, gernado erros de bibliotecas basicas, como se eu não tivesse nenhum compilador instalado.
Seria necessário alguma atualização da versão do ubuntu 8.04 antes de fazer estes procedimentos? instalar mais alguma biblioteca? alterar algum parametro de variável? o que aparentemente demonstra e que não se encontra os caminhos das bibliotecas, por conseguencia não e gerado o arquivo mencionado. Caso alguem tenha a pasta completa e ja compilada, se importaria de mandar pra mim?
Grato

[9] Comentário enviado por dark.know em 09/05/2008 - 18:32h

Galera...
Descobri que faltava o pacote build-essentials, por isso dava erro de compilacao.

Vlw

[10] Comentário enviado por elirenato em 09/05/2008 - 21:59h

Olá,

Depois de ler vários tutoriais, somente com este eu consegui colocar pra funcionar minha placa.

Li vários, vários e vários tutoriais em português e inglês, todos seguem por 2 vertentes: Usando ndiswrapper ou o driver b43/b43xx.

Somente faltou você adicionar a informação para comentar as entradas no blacklist que desabilitam o b43, no meu caso isto foi preciso, pois como disse tentei várias e vários vezes e em alguns tutorias usando o ndiswrapper eles pediam para comentar o b43 no blacklist.

Segue abaixo as entradas comentadas.

#blacklist bcm43xx
#blacklist b43

Obrigado, o seu tutorial foi muito útil.

[11] Comentário enviado por esthinri em 16/05/2008 - 23:56h

Boa Noite,


Tenho a mesma broadcom que vc e fiz tudo o q tem na tua dica mais o meu não ta funcionando ainda, le não axa rede nenhuma... a algo q eu possa fzer?
eu lembro que quando instalei o ubuntu 8.04 ele localizo e 'funcionou' so não aceitava a senha wap mais eu reiniciei o pc e ela não funcionou mais...


o q pode ser??

[12] Comentário enviado por fernandord em 20/05/2008 - 10:24h

Só pra constar, com o Ubuntu 8.04 final esses procedimentos não foram necessários, aqui funcionou direto após instalar....

[13] Comentário enviado por masterboyx em 12/03/2010 - 09:47h

Bom dia Fernando,

muito boa essa dica que vc passou. me ajudou muito.

Parabens...


Obrigado

Gustavo Afonso Hito

[14] Comentário enviado por del*.* em 02/04/2011 - 23:07h

Segui os passos recomendados pelo CESAR.AR e conseguir instalar o driver. Muito obrigado a todos.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts