Claro 3G: modem não respondendo

Publicado por Perfil removido em 08/08/2009

[ Hits: 9.546 ]

 


Claro 3G: modem não respondendo



Um problema que os usuários de modens 3G, eu incluso, têm enfrentado, são os erros de modem não respondendo, especialmente quem configurou seu modem com meus scripts ou o SmartConnect3G.

Não sei qual o problema, pois ocorre mesmo com o modem devidamente configurado. A solução é simplesmente rodar meu script runwv, que está publicado em: script Wvdial ativo com shell script.

Na real, basta desconectar o modem e manter o wvdial rodando e desligando, o que pode ser feito com a linha de comando:

while [ 0 ]; do wvdial; sleep 2; done

Às vezes é necessário o wvdial executar e morrer bem umas dez vezes antes de conectar direito. Isso tem ocorrido especialmente com o modem Huawei, mas no final ele se conecta e a conexão é excelente.

No mais, se isto não resolver, é necessário verificar as configurações particulares de cada modem.

HTH!

Outras dicas deste autor

Compilando o kernel do Linux para outras arquiteturas de forma (muito) rápida

Configurando placa de rede para IP fixo no Debian

Instalando o Java e NetBeans IDE no Linux

Monitorar a performance do MySQL com Mytop

IV Ciclo de Palestras sobre Software Livre CIRP - USP (arquivos e áudio do evento)

Leitura recomendada

Instalando o Firefox e Thunderbird em português (br)

Instalando Firefox e Thunderbird em Português no Slackware

Corrigir erro de DNS no NetworkManager

Redirecionando conexões terminal service de linux para o windows

Gabber x Trillian, a guerra dos messengers!

  

Comentários
[1] Comentário enviado por bilufe em 09/08/2009 - 09:49h

Não sei porque algumas distribuições Linux complicam tanto as coisas para o usuário que tenta se conectar com modem 3G. O Ubuntu enfrenta problemas com a configuração DNS pois o modem conecta e não navega, é necessário mudar os servidores DNS para resolver o problema (e isto requer conhecimentos que a maioria dos usuários não tem).

O Biglinux é a distribuição que melhor facilita a vida do usuário com internet 3G, pois o discador KPPP facilita a vida do usuário.

[2] Comentário enviado por mcnd2 em 09/08/2009 - 11:11h

Concordo com o "bilufe".

O "kppp" é excelente para executar uma configuração bem sucedida com o modem 3G.

Já testei essa configuração no Slax rodando de um pendriver e foi tranquilo, apesar de gostar do "GNOME", não foi dificíl configurar o modem pelo "KDE".

OBS: tem que ter os dados para preencher o configuração no kppp.

Vlw...

[3] Comentário enviado por Teixeira em 09/08/2009 - 20:19h

Não é exatamente o Linux que complica as coisas.
O que acontece é que se os fabricantes de modems se ativessem aos protocolos necessários (e que não são poucos) tudo estaria bem.
Porém todos desejam puxar uma brasa para a sardinha do windows (o que nem sempre funciona, e o tiro sai pela culatra)...

Tenho aqui modems antigos que funcionam bem no Linux (qualquer um) mas quando é para configurá-los no windows "tal" a coisa é bem diferente do "outro" windows.
Aí temos de quebrar a cabeça mesmo.

Alguns modems "modernos" V92 (winmodems) não funcionam direito nem no windows e nem no linux, a menos que sejam configurados como se estivessem no México e não no Brasil (!!!!!!).
(Essa dica veio do site do Engenheiro Laércio Vasconcellos).

Em 3G é a mesma coisa, a mesma esquisitice. Infelizmente. E não depende tanto assim da operadora.
Resumindo, internet no Brasil é para quem dá sorte.
É uma experiência que tem 50% de chances de termos alegria ou frustração: Ou funciona, ou não funciona nem a pau, Juvenal.




[4] Comentário enviado por removido em 28/08/2009 - 20:23h

Olá Valter,

Sempre tive vontade(inclinação ideológica) de utilizar sistema operacional linux, mas, problemas com modem eram fatores limitantes(desde quando tentei usar a discada em winmodem e somente conseguia 14Kb/s). Bom, no 3G(da Claro) utilizei os Scripts, conforme tenho encontrado em Blogs, e por surpresa descobri(não sozinho, li em outro blog) que um detalhe de configuração pode acabar com o problema conhecido: Conecta mas não navega.

Utilizei o seguinte trajeto(no Ubuntu 9.04)
1- Depois de conectado(ou antes, se já criou perfil: Claro,Oi, etc...) vá em "Conexões VPN"=>"Configurar VPN" ou "Editar Conexões".
2-Selecione "Banda Larga Móvel", marque a conexão que pretende usar/editar(que já deve estar criada) e clique em "Editar", depois, "configurações IPV4".
3- É no IPV4 que a alteração deve ser realizada. Desmarque: "Somente endereços PPP" e Marque "Automático PPP". A razão disso(pelo que entendi) é fazer com que o Modem perceba e atualize as alterações de rede(no servidor ou central), e se adapte automaticamente.

Espero ter ajudado(por que esse problema me incomodou muito!!),

Abraço!!!!



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts