Bootsplash em kernel "não oficial" 2.6.X no Slackware

Publicado por Perfil removido em 30/01/2007

[ Hits: 6.309 ]

 


Bootsplash em kernel "não oficial" 2.6.X no Slackware



Se estiver instalando um kernel não oficial 2.6.X no seu Slackware, poderá ter a "grata surpresa" de não conseguir compilá-lo e obterá a seguinte mensagem de erro:

drivers/video/bootsplash/bootsplash.c:15:26: linux/config.h: Arquivo ou diretório não encontrado make[3]: ** [drivers/video/bootsplash/bootsplash.o] Erro 1 make[2]: ** [drivers/video/bootsplash] Erro 2 make[1]: ** [drivers/video] Erro 2 make: ** [drivers] Erro 2

Se for escolhido um kernel acima do 2.6.18 "oficial", até o momento em que escrevo esta dica, não existe um patch para aquele se baixado em www.kernel.org.

Mas o "patcheamento" poderá ser feito mesmo com o bootsplash-3.1.6-2.6.18.diff que tudo dará certo.

Mas como resolver o erro encontrado???

Muito simples: você deverá copiar o arquivo linux/config.h existente em /usr/src/seu_kernel_atual para /usr/src/kernel_a_ser_compilado.

No meu caso, tenho o 2.6.18 instalado e desejo compilar o 2.6.19.1. Então farei, como root, em /usr/src:

# cp /usr/src/linux-2.6.18/include/linux/config.h /usr/src/kernel_a_ser_compilado/include/linux/

Agora é só proceder à compilação, como de costume, que tudo dará certo!!!
;-)

Até a próxima!

Outras dicas deste autor

Fluxbox-devel em teu GDM

Corrigindo o bug no gnome-panel do Ubuntu 10.04

Ouvindo músicas e vendo vídeos no Ubuntu e Debian-like (interface gráfica)

Imprimindo fotos em lote com gnome-photo-printer

Instalando o aMSN 0.97-1 no Famelix 2.0

Leitura recomendada

Debian GNU/Linux-Libre - Sem softwares proprietários

Nova versão de driver da nVidia: perfeita para o kernel 2.6! :)

Atualização do kernel 3.18 no Ubuntu

Drivers da placa de vídeo ATI - agora com melhor suporte a OpenGL

Atualizar kernel e driver de placas de vídeo em Sabayon

  

Comentários
[1] Comentário enviado por removido em 30/01/2007 - 11:16h

O kernel genérico também pode ser enganado com:

# touch /usr/src/kernel_a_ser_compilado/include/linux/config.h

Um arquivo-texto em branco dá certo da mesma forma.

[2] Comentário enviado por tenchi em 30/01/2007 - 12:24h

Bem, eu estou usando aki o 2.6.19, com bootsplash normalmente.

O patch que eu usei se encontra no link:
http://www.lordlinux.cjb.net/bootsplash-3.1.6-2.6.19.diff


Desculpem por não citar o link de onde realmente tirei, porque já faz um tempo, e eu não lembro.. rsrss

Mas se alguém aí quiser um 2.6.19 já compilado por mim é só pedir. o arquivo tem 15MB, e não é nada generico (compilado somente para o vídeo savage, squashfs, supermount, bootsplash, processador:athlon/duron.. etc.)

Se alguém tiver interesse e tiver essa mesma configuração...


$ uname -a
Linux masaki 2.6.19-Ryo-Ohki #1 Sat Jan 13 19:23:27 BRST 2007 i686 athlon-4 i386 GNU/Linux

Falow.

[3] Comentário enviado por jairpn em 30/01/2007 - 12:40h

Desculpe cara! Mas, não entendi nada do que você quis passar com esse artigo. Eu sempre instalo kernel não oficial e nunca tive este erro. Como consigo provocá-lo?

[4] Comentário enviado por superflankerCTBA em 14/02/2007 - 12:24h

é só substituir o config.h por autoconf.h em cada arquivo em que ele aparece. Estou rodando kernel 2.6.20 e funciona.


[5] Comentário enviado por claitonjs em 25/07/2007 - 16:15h

Para resolver, crie os arquivos:

/usr/include/linux/config.h
/usr/src/linux*/include/linux/config.h

onde *=versão do seu kernel, com o seguinte código:

#ifndef _LINUX_CONFIG_H
#define _LINUX_CONFIG_H
/* This file is no longer in use and kept only for backward compatibility.
* * autoconf.h is now included via -imacros on the commandline
* */
#include <linux/autoconf.h>

#endif

Feito isto, é só continuar ;-)

flw!



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts