BRoffice 3 no Slackware Linux 12.1: Solução para teclas que não funcionam

Publicado por Luiz Henrique em 22/10/2008

[ Hits: 7.220 ]

 


BRoffice 3 no Slackware Linux 12.1: Solução para teclas que não funcionam



Atenção usuários do Slackware Linux!

Ao saber do lançamento do Broffice 3 logo fui atualizar minha versão, mas ao usá-lo vi que algumas teclas não funcionavam.

Se você instalou o Broffice usando rpm2tgz, certamente terá problemas (como eu).

Problemas como: as setas, backspace, page down etc não funcionarem.

Solução:

Renomear o arquivo default.xm para default.xml, na pasta "/opt/openoffice.org/basis3.0/share/config/soffice.cfg/modules/swriter/accelerator/en-US/", não sei o que aconteceu, mas na instalação o Slack "comeu" essa letra.

=)

Procedimento:

# cd /opt/openoffice.org/basis3.0/share/config/soffice.cfg/modules/swriter/accelerator/en-US
# mv default.xm default.xml


Depois disso tudo voltou ao normal...

Abraços.

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Acelerando (ainda mais) a abertura do LibreOffice

Lançada a revista BrOffice.org 09

Mageia 2 - Instalando Apache OpenOffice 3.4

Resolvendo o problema do "erro ao carregar BASIC" no OpenOffice.org no Linux

Fedora 11 + BROffice.org ou OpenOffice: erro com biblioteca libuno_sal.so.3

  

Comentários
[1] Comentário enviado por andre.vmatos em 22/10/2008 - 14:43h

Nossa, parabéns pela dica. Muito boa mesmo. Na verdade, não tinha percebido esse problema ainda (pq tinha instalado, mas nao tinha tido a necessidade de usar o BrOffice). Mas, ai, fui testar, e vi q estava msm com esse problema. Fiz a sua modificação, e td voltou ao normal.
Não sei como vc descobriu isso, mas essa solução é perfeita. Vlww msm.

[2] Comentário enviado por irado em 23/10/2008 - 08:04h

havia instalado pelo script do slackbuild - muito bom e prático; mas não cheguei a ter esse problema, impliquei mesmo foi com a complicação do OO-3 não buscar/usar o template que eu havia criado e não consegui fazer um outro que funcionasse (o procedimento ficou complicadíssimo). Não gostei também da tela inicial, então parti pelo mais fácil: removi o bruto e voltei para o 2.3.3 (coisa assim).

Voltei a ser feliz :)

[3] Comentário enviado por IroN em 23/10/2008 - 18:21h

Eu fiz um pacote e estava com esse erro.
Agora corrigi ;-)

Se alguém interessar, vá ao até a dica, mas baixe utilizando os atalhos de minha postagem nos comentários:

http://www.vivaolinux.com.br/dica/Pacote-BrOffice-3.0.0-para-Slackware-Linux/

Abraços!
-----------------------------------------------------------------------

BrOffice.org 3.0.0 para Slackware: http://www.adrive.com/public/f33412f0dd373b4f3dacbe2cb6119501d637835562cda29a67abb58b243b47e5.html

MD5SUM: http://www.adrive.com/public/5245c038183cebbcf20e7ca73ddae4518b8197916f779a5a2b3867e6c72b9662.html
-----------------------------------------------------------------------

[4] Comentário enviado por VonNatur em 29/10/2008 - 20:06h

excelente dica eu estava como este mesmo problema.

[]'s

[5] Comentário enviado por timaum em 05/11/2008 - 16:06h

eu só queria entender como você descobriu isso...

morreria sem imaginar que seria algo do tipo...

[6] Comentário enviado por mafioso em 13/11/2008 - 01:20h

Huahauha! Muito boa mesmo! Já tava xingando o brOffice!!!! Valeu!

[7] Comentário enviado por gedalinux em 11/12/2008 - 21:41h

Parabens pela iniciativa, não tinha nem imaginado isso

[8] Comentário enviado por jaksonbt em 24/01/2009 - 20:24h

Valeu, resolvi esse problema, mas ainda tenho outro, no terminal, Kwrite e outros programas o teclado incluindo acentos funcionam numa boa, mas no BrOffice 3 não consigo acento nenhum. Todas as outras teclas funcionam menos os acentos como ,"´", "~", já consegui fazer eles funcionaram mas não ficam acimas das letras como: em vez de á, ficam 'a. Meu teclado é ABNT2, uso backtrack 3, derivado do slackware 12

[9] Comentário enviado por rafastv em 11/02/2009 - 22:05h

Valeu \o/

[10] Comentário enviado por bencid em 05/03/2009 - 01:36h

massa a dica... acabei de instalar o BROFFICE e algumas teclas nao funcionavam... como havia dito, usei o rpm2tgz... só responda uma pergunta que nao quer calar COM DESCOBRISTE ESSA DICA... kkkkk...k

abraços

[11] Comentário enviado por rootgauss em 05/03/2009 - 08:52h

Desculpe a demora para responder.

Estou sem slackware aqui, estou usando agora gentoo.

Mas eu lembro que usei o strace para analisar o funcionamento do openoffice, nos logs vi que ele procurava o arquivo "default.xml".

Então foi só questão de renomear o arquivo.

O uso do strace é basicamente é:

$strace [programa]

Desculpe a falta de informações mas foi isso que me lembro de ter feito.

Abraços

[12] Comentário enviado por rootgauss em 08/03/2009 - 15:03h

jaksonbt,

Isso aí já é problema de locais, o sistema inglês não tem acentos...etc.

Crie ou adicione no arquivo ~/.bashrc, (com)o seguinte conteúdo:

export LANG="pt_BR.UTF-8"
export LC_ALL="pt_BR.UTF-8"

Pela data você já deve ter corrigido o problema, mas fica aí como referência.

Abraços

[13] Comentário enviado por guiguix em 09/03/2009 - 19:24h

Loguei só pra AGRADECER o querido colega Luiz Henrique (rootgauss), instalei o BrO no meu Slack12 do jeito q ele disse, e tive o mesmo problema! Valew Cara! Além de resolver o problema, aprendi o comando $strace..... Qdo vier em Goiás, venha tomar uma pinga aqui conosco!

[14] Comentário enviado por cytron em 24/03/2009 - 09:50h

É!!! O cara foi esperto! Eu estava aqui tentando imaginar que "fenômeno hyper-sobrenatural" foi esse que aconteceu... Antes de bater cabeça pensei em ver se alguém passou por isso... bom, o problema é bem natural hehehe.

[15] Comentário enviado por Felipe Domingos em 09/04/2009 - 11:17h

Parabéns!
A Dica funcionou perfeitamente aqui!

T+

[16] Comentário enviado por jldomingos em 13/08/2009 - 02:56h

Muito obrigado pela dica. Não tinha idéia de como resolver. Mas, curioso, procurei por outros arquivos e não deu outra: vários com extensão incorreta. Pra corrigir todo mundo, (como root) usei este comando aqui:

find /opt/openoffice.org/ -name "*.xm" -exec mv '{}' '{}'l ';'

Valeu galera !



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts