Instalando / Atualizando o BrOffice 3.0/3.1 no Debian 5 Lenny

Publicado por marcelo cabral em 21/05/2009

[ Hits: 12.969 ]

 


Instalando / Atualizando o BrOffice 3.0/3.1 no Debian 5 Lenny



Estou colocando esta dica para quem estiver tendo dificuldades, como eu tive, em instalar ou atualizar o Broffice 3.0.0 / 3.1.0.

Consegui reunir estas informações após postar no fórum do VOL e com a ajuda de alguns comunitários, resolvi meu problema e ainda adicionei pequenos detalhes, que poderão ser o de alguns colegas. Abaixo fiz a manobra com o BrOffice 3.0, mas logo após baixei o 3.1 e fiz o mesmo procedimento com sucesso.

1 - Remova o Broffice 2.4 que vem com o Debian através do Synaptic.

2 - Baixar o Broffice:

BrOOo_3.0.1_LinuxIntel_install_pt-BR_deb.tar.gz
ou
BrOOo_3.1.0_LinuxIntel_install_pt-BR_deb.tar.gz

3 - Usando o terminal, descompacte com:

# tar -zxvf BrOo_3.0.1_LinuxIntel_install_pt-BR_deb.tar.gz

4 - Entrar no diretório criado na descompactação:

# cd OOO300_m15_native_packed-1_pt-BR.9379
# cd DEBS

5 - Dar permissão de execução aos arquivos neste diretório:

# chmod +x *deb

6 - Instalar os pacotes usando:

# dpkg -i *deb

7 - Criar os atalhos para o KDE/Gnome:

# cd DEBS
# cd desktop-integration/
# dpkg -i *deb


8 - Ainda usando o terminal digite:

# broffice.org3

9 - Verifique se o BrOffice executou normalmente, se não executou procure verificar que tipo de erro é produzido. Caso seja mostrada a seguinte mensagem de erro:

"o JRE esta com defeito. O broffice.org requer um JRE (java runtime environment) para executar esta tarefa. O JRE selecionado esta defeituoso. Selecione outra versão ou instale um novo JRE e selecione-o em Ferramentas-Opções-Broffice.org-java"

Proceda da seguinte forma:

10 - Instale o Java através da internet com:

# apt-get install openjdk-6-jre

11 - Em seguida execute novamente no terminal:

# broffice.org3

12 - Caso queira usar o BrOffice 3.1, basta descompactá-lo e no diretório que foi criado execute no terminal:

# ./update

E ele atualizará da versão 3.0 para 3.1. Bastando apenas você recriar os atalhos conforme o passo 7 acima.

Caso OK... tudo está resolvido. Tenha uma boa produtividade com seu BrOffice 3.0 ou 3.1 instalado. Espero que ajude.

Abraços e sucesso a todos.

Marcelo Cabral

Outras dicas deste autor

Tutorial Resumido de Instalação Lotus Notes 8.5.2 no Debian Squeeze

LibreOffice 3.4.0 no Debian 6

Dual boot Debian Squeeze + Windows XP

Atualizando / Instalando o BrOffice 3.1.0 no OpenSuSE 10.x e SuSE ES 10SP2

Leitura recomendada

Lançada a revista BrOffice.org 09

LibreOffice - Ctrl+c e Ctrl+v embaralhando texto ao enviar para outros editores [Resovido]

Como instalar OpenOffice Apache (DEB)

Instalação do OpenOffice no Arch Linux

OpenOffice 3: Instalando o corretor ortográfico e gramatical

  

Comentários
[1] Comentário enviado por Tonisley em 28/05/2009 - 04:22h

Gostei muitíssimo desta postagem sendo que tive problemas na hora de instalar a nova versão. Obrigado mesmo cara, tu me salvou.
Deus abençoe esta comunidade e o mundo Linux.

Um Abraço!!!

[2] Comentário enviado por mcabral em 28/05/2009 - 11:10h

Não há de que camarada ...

Afinal de contas este é um dos verdadeiros significados de "comunidade", e em se tratando de Linux, dobra-se o motivo.

Espero continuar ajudando.
Abraço
Marcelo Cabral

[3] Comentário enviado por schevenin em 24/07/2009 - 15:34h

Parabéns pelo artigo, fiz como descrito e funfo blz. no meu Kurumin 7 - Lenny ;-)

[4] Comentário enviado por schevenin em 01/08/2009 - 01:24h

Mcabral mais um vez agradeco sua dica desta vez instalei no Debian 5.0 e funfo tambem tudo blz! vlw mais uma vez. ;)
abraco do Bio

[5] Comentário enviado por mcabral em 03/08/2009 - 00:15h

Falou galera ... não há de que ...

Viver em comunidade é isso aí ... temos que estar sempre nos ajudando e construindo uma nova forma de pensar e agira no que diz respeito a Software ...

Ajudo e também gosto de ser ajudado
Abraço e Sucesso a todos
Marcelo Cabral

[6] Comentário enviado por mercinho45 em 07/08/2009 - 14:01h

Caro amigo,
Estou tentando atualizar o BRoffice 3.0 para o 3.1 utilizando a opção ./update mencionado em seu tutorial e está ocorrendo em um erro. você poderia me ajudar? O erro está descrito abaixo:

Configurando broffice.org3-base (3.1.0-11) ...
Configurando broffice.org3-calc (3.1.0-11) ...
Configurando broffice.org3-pt-br (3.1.0-11) ...
Configurando broffice.org3-draw (3.1.0-11) ...
Configurando broffice.org3-math (3.1.0-11) ...
Erros foram encontrados durante o processamento de:
./DEBS/desktop-integration/broffice.org3.1-debian-menus_3.1-9393_all.deb
[email protected]:~/OOO310_m11_native_packed-3_pt-BR.9399$

Fico no aguardo.

[7] Comentário enviado por mcabral em 08/08/2009 - 12:47h

Fala mercinho !

Pelo jeito esse erro que apresenta no update não aconteceu comigo e não foi relatado ate agora, mas como nosso objetivo em comunidade é resolver problemas e repassar a solução, vamos tentar certo !

Bem primeiramente tente fazer como no início da dica, removendo o BrOffice atual através do synaptic. Neste caso removerá o 3.0 e aí sim promova a instalação do 3.1 normalmente descrito pela dica.

Em resumo: siga todos os passos da dica, mas neste caso remova o 3.0 e instale o 3.1. Qualquer resultado por favor poste.

Um abraço
Marcelo Cabral


[8] Comentário enviado por walsinghan em 18/09/2009 - 13:37h

Olá,

Isso também pode ser feito usando o lenny-backports, ou seja, apenas alterando o sources.list do apt e usando um comando ao melhor estilo Debian, conforme descrito neste site: http://brofficeparaleigos.blogspot.com/2009/07/como-escrever-textos-perfeitos-no.html

Abraços

[9] Comentário enviado por romero.dinfo em 15/01/2010 - 10:33h

Bacana de mais valeu.....so que o openoffice conflita com o broffice3.1.1, então deve ser desisntalado via synaptic primeiro.
Obrigado. Grande abraço...



Contribuir com comentário