Atualizando o VMware-Sever no Ubuntu 8.10 Hardy Heron

Publicado por Gleudson Junior em 25/08/2008

[ Hits: 8.259 ]

Blog: http://www.gleudsonjunior.blogspot.com/

 


Atualizando o VMware-Sever no Ubuntu 8.10 Hardy Heron



Pessoal,

Durante toda essa semana passei os dias com uma tremenda dor de cabeça por conta de uma atualização que fiz no Ubuntu. Ao atualizar o S.O., acabei atualizando também a versão do kernel para 2.6.24-19, com isso, meu VMWare parou de rodar.

Depois de um bom esforço intelectual, o que é necessário para qualquer usuário do Linux ;), consegui achar a solução!

Seguinte:

Quando atualizei meu kernel, os módulos do VMWare não subiam mais no sistema, inviabilizando inicialização do mesmo. O que fazer?

1. Reinstalar o VMWare para que o sistema compile novamente os módulos. Depois reboot.

2. Instalar alguns pacotes que não são default:

sudo apt-get install build-essential linux-headers-$(uname -r) xinetd

3. Se o erro persistir, baixe o seguinte patch:
Abra um terminal e corra os seguintes comandos para instalação:

cd ~/tmp/vmware-any-any-update116
$ sudo ./runme.pl


Obs.: O patch é referência do Kernel -16, mas, também resolve o -19. ok!

4. Após aplicar o patch e instalar o VMWare é necessário criar os seguintes links simbólicos para que ele volte a funcionar:

sudo ln -sf /lib/libgcc_s.so.1 /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1
$ sudo ln -sf /usr/lib/libpng12.so.0 /usr/lib/vmware/lib/libpng12.so./libpng12.so.0


Pronto, é isso!

Se tiverem problemas, podem postar como comentário, tentarei responder aos questionamentos da melhor maneira possível.

Saudações...

"Free by necessity ... Linux by choice"

http://gleudson.blogspot.com/

Outras dicas deste autor

Servidores em modo gráfico com o Webmin

Damn Small Linux disponível para download

Recuperar/modificar passwords do Windows através do Linux

Livrando-se dos "pacotes órfãos"

Configurando o xorg.conf no Ubuntu

Leitura recomendada

Resolvendo o problema de autenticação no wvdial

Integrando o Firefox com o KDE4

Configurando placas wireless Broadcom no Linux

Linux Mint com LXDE: Caixas de som USB

Configurando a tecla PrintScreen pra capturar a tela no KDE

  

Comentários
[1] Comentário enviado por maxmilianlinux em 05/11/2008 - 15:56h

nao deu certo :(

/tmp/vmware-config3/vmmon-only/linux/driver.c:1781: error: too many arguments to function ‘smp_call_function’
make[2]: ** [/tmp/vmware-config3/vmmon-only/linux/driver.o] Erro 1
make[1]: ** [_module_/tmp/vmware-config3/vmmon-only] Erro 2
make[1]: Saindo do diretório `/usr/src/linux-headers-2.6.27-7-generic'
make: ** [vmmon.ko] Erro 2
make: Saindo do diretório `/tmp/vmware-config3/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.

[2] Comentário enviado por maxmilianlinux em 05/11/2008 - 16:06h

ja tentei compilar o vmware-any-any-update116 e o vmware-any-any-update115

mais sempre da o mesmo erro

eu ja estava usando no ubuntu 8.04 depois atulizao e que ele paro de funcionar ja tentei instalar de novo e nada sempre o mesmo erro

[3] Comentário enviado por Gleudson Junior em 05/11/2008 - 18:15h

@maxmilianlinux

Quais comandos vc ta utilizando para compilar o patch?
Preciso que vc seja mais claro, me parece que vc está tentando o make, é isso?

[4] Comentário enviado por maxmilianlinux em 06/11/2008 - 09:04h

Estou usando o sequintes comandos

tar zxvf vmware-any-any-update-116.tgz

cd vmware-any-any-update-116.tgz

sudo ./runme.pl

Obs: ja tive o mesmo problema no Ubuntu 8.10 e resolvi com esses mesmos comandos

mais ñ da certo no 8.10

gostaria resolver esse problema sem ter que formata ...

Obs: todos os pacotes de de pencecias ja estao instaladas pois eu ja estava usando no Ubuntu 8.04 sem problemas

[5] Comentário enviado por Gleudson Junior em 06/11/2008 - 13:56h

@maxmilianlinux

Bom, supondo que vc já tenha o VMware devidamente instalado.
Tente apenas correr os seguintes links simbólicos no seu console, sem instalar o patch:

$ sudo ln -sf /lib/libgcc_s.so.1 /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1
$ sudo ln -sf /usr/lib/libpng12.so.0 /usr/lib/vmware/lib/libpng12.so./libpng12.so.0

Obs: Eles só vão funcionar se realmente vc já tiver instalado todos os pacotes que não são nativos do Kernel.
Se precisar instale-os:
$ sudo apt-get install build-essential linux-headers-$(uname -r) xinetd



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts