Anon-proxy (um UltraSurf para Linux)

Publicado por Jose Ribeiro em 02/10/2009

[ Hits: 55.651 ]

Blog: https://otrsinbox.cloud

 


Anon-proxy (um UltraSurf para Linux)



Quem já precisou acessar algo na net e foi bloqueado por seu proxy ou firewall devem conhecer o Ultra-surf.

Mas quando se usa Linux há um problema: rodar pelo Wine. Para isso os meus testes não foram muito produtivos. Pensando nisso escrevo essa dica.

Esses passos foram realizados no Ubuntu 9.04.

Primeiro passo:

# apt-get install anon-proxy

Obs.: atenção na instalação, será perguntado se deseja alterar as variáveis de proxy do sistema. Sugiro clicar em NÃO e fazer as mudanças manualmente.

Segundo e último passo:

Configurar o proxy no seu navegador e nos programas.

No Mozilla Firefox: Editar -> Preferências -> Avançado -> Rede -> Configurar

Aí configure manualmente portas e IP de todos os protocolos para:

localhost (ou 172.0.0.1 ) e porta 4001.

Antes disso, para ter certeza que está funcionando:

# nmap localhost

A reposta deve ter uma porta assim:

4001/tcp  open  unknown

Feito isso deve funcionar tudo perfeitamente.

Abraços.

Outras dicas deste autor

Colabore com documentação para o Gambas

Entrando com argumentos em shell script

Gambas 2: Criando um navegador web

Hello world em 397 linguagens

Adicionado servidores no CruxPorts4Slackware

Leitura recomendada

Migrando do MS Outlook Express para Evolution

Solucionando erro: comm_select_init: epoll_create(): (38) Function not implemented

Corrigindo erro do Firefox no Debian (libgtk-x11-2.0.so.0)

Firefox versão 31 não carrega plugins [Resolvido]

Tubarão nas nuvens? Vá de Cloudshark!

  

Comentários
[1] Comentário enviado por rogeriojlle em 02/10/2009 - 11:22h

op's, é 127.0.0.1

[2] Comentário enviado por maran em 02/10/2009 - 14:23h

se funcionar igual o ultra surf é fera, se bem que aqui onde trabalho o Ultra Surf não funciona não viuu, e os cara pegaram ele rapidinho!!!
hahahahhaa!

[3] Comentário enviado por rogeriojlle em 02/10/2009 - 18:27h

esses programas, caso a instituição tenha uma política de não permitir o uso de ip's fixos na rede externa, tem realmente "vida curta"

[4] Comentário enviado por joserribeirojuni em 02/10/2009 - 19:13h

Tem como bloquear sim bem rápido na verdade.
Mas enquanto não bloquearem... usem :P
Abraço

[5] Comentário enviado por xdiegow em 09/10/2009 - 18:36h

Amigo, instalei ele funcionou bem, porem no logon seguinte ele nao funcionou, ja dei um restart no servico porem ele diz q esta iniciado mas nao funciona e tb nao libera a porta 4001 no nmap

o que sera que ta rolando ?
uso ubuntu tb

[6] Comentário enviado por santiagovie em 20/10/2009 - 17:49h

Rodou!
Lento!
Mas rodou!

[7] Comentário enviado por joserribeirojuni em 20/10/2009 - 18:31h

De fato anda um pouco lento isso....

[8] Comentário enviado por noslideneb em 06/03/2010 - 15:21h

Caro amigo Jose, fui tentar a sua dica, mas não consegui instalar o anon-proxy e fui tentar fazer o resto para ver se dava certo, nada deu certo ate que o meu firefox, o chrome que eu tambem uso ficaram bastante danificados e não consigo mais acessar a internet atraves de navegador, como faço para resolver essa parada? E como faço para instalar de maneira correta o anon-proxy? acho que se eu tinvesse instalado ele corretamente tinha dado tudo certo.

Aguardando respostas, vlw.

[9] Comentário enviado por joserribeirojuni em 06/03/2010 - 15:52h

Então... tenta remover ele e instalar a maneira correta, como você instalou ?


digite isso no terminal

nmap localhost


e copie a saida pra eu ver como ta.

Abraço..

[10] Comentário enviado por noslideneb em 08/03/2010 - 15:39h

Não consigo baixa nada pelo terminal, meus navegadores não funcionam, uns amigos meus me dissem para remover o ubuntu e depois colocar de novo, mas eu gostaria de soluciar esse problema. mas eu fazer fazer o que vc dise ja eu coloco vlw.

[11] Comentário enviado por noslideneb em 08/03/2010 - 17:12h

Starting Nmap 5.00 ( http://nmap.org ) at 2010-03-08 16:17 BRT
Warning: Hostname localhost resolves to 2 IPs. Using (nº do ip?)
Interesting ports on localhost (isso eu não vou mostrar):
Not shown: 997 closed ports
PORT STATE SERVICE
25/tcp open smtp
80/tcp open http
631/tcp open ipp

Nmap done: 1 IP address (1 host up) scanned in 0.18 seconds

tentei instalar novamente pelo terminal mas não deu certo ate usei --fix-missing

Ai carinha vamos conseguir resolver isso?

[12] Comentário enviado por joserribeirojuni em 08/03/2010 - 17:20h

Então na hora de instalar você mandou o anon-proxy, aplicar-se também ao proxy de sistema, por isso nada funciona, e como você pode ver ele não está iniciado, a porta 4001, não está aberta então para resolver isso.

1) inicie o anon-proxy ( /etc/init.d/anon-proxy start )
2) Retire o proxy do sistema, estar para localhost porta 4001 no gnome ( Sistema -> Preferencia -> Proxy da rede )
mande ele buscar proxy automaticamente. ( KDE nem lembro como faz, mas é só entrar no centro de controle do KDE para deve ter a opção).
Abraço....

[13] Comentário enviado por noslideneb em 08/03/2010 - 19:05h

Não existe anon-proxy no diretório /etc/init.d o que faço?

Marquei a opição configuração automática de proxy, porém nessa URL de auto configuração: O que eu coloco? eu deixo vazio?

[14] Comentário enviado por joserribeirojuni em 08/03/2010 - 19:10h

2) Retire o proxy do sistema, estar para localhost porta 4001 no gnome ( Sistema -> Preferencia -> Proxy da rede )
mande ele buscar proxy automaticamente. ( KDE nem lembro como faz, mas é só entrar no centro de controle do KDE para deve ter a opção).
Abraço....

[15] Comentário enviado por Breaker em 13/04/2010 - 13:02h

Já utilizei o anon-proxy e gostei do seu desempenho. Porém não estou conseguindo fazer a instalação via linha de comando, no final da instalação ocorre um erro (isso acontece pois o pacote contém a string "proxy", que é bloqueada pelo firewall). Então baixei o pacote (anon-proxy_00.05.38+20081230-1.1_amd64.deb) diretamente do repositório do ubuntu e fiz a instalação. Porém mesmo assim o proxy não funcionou.
Quais outros passos devo realizar para completar a instalação manualmente?

[16] Comentário enviado por valbertomoreno em 15/04/2010 - 10:54h

instalei aki no Laboratorio da minha escola e funcionou blz... vcs estão de parabens.

ja tinha procurado isso por todo lugar agradecido!!


vcs são feras

[17] Comentário enviado por jonasuea em 04/11/2010 - 18:55h

show de bola.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts