Unity Desktop no Arch Linux

Neste artigo irei ensiná-los a instalar a interface gráfica desenvolvida pela Canonical com base no GNOME, o Unity, padrão na distro Ubuntu que também é de autoria da Canonical. Ela vem se revelando com o tempo e mostrando sua beleza.

[ Hits: 13.803 ]

Por: Celio Rodrigues em 24/02/2015


Unity / Flat theme



Instalando o Unity

Obs.: ao ser instalado como primeira interface, sem o GNOME na máquina, ele apresentou vários erros, como perda de vídeo no login e vários outros, então para que tudo dê certo, vamos instalar primeiro o GNOME.

sudo pacman -S gnome

Após o término da instalação, ative o GDM para que ele seja o nosso gerenciador de login. O Unity, que será instalado, vem com o LightDM do Ubuntu, mas o mesmo apresentou bastante bugs, por este motivo ele foi substituído pelo GDM:

sudo systemctl enable gdm.service

Depois de ativar o GDM, devemos reiniciar a máquina para que o GNOME inicie e para que possamos fazer tudo dentro dele. Agora que estamos dentro do GNOME, vamos instalar o Unity:

sudo pacman -S $(pacman -Slq Unity-for-Arch)

No caso de algum pacote apresentar conflito, use o comando abaixo para solucioná-lo:

sudo pacman -S $(pacman -Slq Unity-for-Arch | grep -v 'pkg1' | grep -v 'pkg2')

Onde "pkg1" e "pkg2" são os pacotes que estão em conflito.

Alguns pacotes do GNOME serão substituídos, confirme toda a operação e aguarde o término. Após terminar, reinicie a máquina e no momento do login, clique na engrenagem ao lado do botão e selecione "Ubuntu". Faça login e pronto, você já tem o Unity instalado.

Instalando o Flat Theme

Um grande empecilho desta instalação, é que ao final o Unity inicia, mas sem nenhum tema. Então para que este problema seja sanado, desenvolvi um script que instala um tema e ícones bem bonitos para o Unity, o resultado pode ser visto nas screenshots da primeira parte.

O script pode ser baixado por este link no Dropbox.

Após o download, acesse o diretório que foi salvo o arquivo e digite o seguinte comando:

sudo chmod +x NOME-DO-ARQUIVO.sh

Rode o arquivo com o comando:

./NOME-DO-ARQUIVO.sh

Todo o processo será automático. Quando o Unity Tweak Tool iniciar:
  • Navegue até a aba "Tema" e selecione "Ambiance-flat-teal-pro".
  • Depois vá até a aba "Ícones" e selecione "Ultra-Flat-Icons".

Após isso, feche o programa.

Pronto, a instalação foi concluída e seu Unity já está pronto para uso.

Problemas? Deixe-me um comentário e tentarei sanar sua dúvida o mais rápido possível!

Página anterior    

Páginas do artigo
   1. Introdução / Screenshots / Pacman
   2. Unity / Flat theme
Outros artigos deste autor
Nenhum artigo encontrado.
Leitura recomendada

Desenhar um planeta com Gimp

Criando Fluxogramas? Use o Dia!

Monitorando interfaces virtuais com MRTG e IPFM

Água e submersos?

Letras brilhantes com Gimp

  
Comentários
[1] Comentário enviado por madrugada em 25/02/2015 - 16:51h

Legal.
Tira um print demonstrando o consumo de memória e CPU logo após boot e login.

[2] Comentário enviado por mapintar em 27/02/2015 - 12:32h

Testei o Unity algumas vezes no próprio Ubuntu. Achei horripilante. Chato, enfadonho, monótono. Creio que é questão de gosto pessoal. No Arch nunca usei.

[3] Comentário enviado por spylinux em 01/03/2015 - 15:06h

Legal o Post, pela curiosidade em si, mas, na "minha opinião", pegar um sistema leve e rápido como o Arch Linux e botar um DEsktop pesado como o Unity é um tremendo desperdício...vai contra o próprio sistema...rs

[4] Comentário enviado por lemuelroberto em 04/03/2015 - 16:01h

Ao contrário de muita gente, eu gosto muito da interface Unity. Acho muito mais fácil de usar.

Muito obrigado pelo artigo :)

[5] Comentário enviado por Root_ em 18/06/2015 - 18:31h

Na resolução de conflitos... Aceito ou não a substituição pelos subpacotes do Unity?
Aceitando todas as substituições, ao final tenho o seguinte:


erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: gnome-shell: requer nm-connection-editor

[6] Comentário enviado por kads em 18/01/2016 - 23:23h

#FAIL

[[email protected] ~]$ sudo pacman -S $(pacman -Slq Unity-for-Arch)
atenção: dee-ubuntu-1:1.2.7.15.04.20150304-2 está atualizado -- reinstalando
atenção: libunity-7.1.4.14.10.20140808-3 está atualizado -- reinstalando
resolvendo dependências...
procurando por pacotes conflitantes...
:: gnome-session-ubuntu e gnome-session estão em conflito. Remover gnome-session? [s/N] s
:: gnome-settings-daemon-ubuntu e gnome-settings-daemon estão em conflito. Remover gnome-settings-daemon? [s/N] s
:: gsettings-desktop-schemas-ubuntu e gsettings-desktop-schemas estão em conflito. Remover gsettings-desktop-schemas? [s/N] s
:: gtk2-ubuntu e gtk2 estão em conflito. Remover gtk2? [s/N] s
:: gtk3-ubuntu e gtk3 estão em conflito. Remover gtk3? [s/N] s
:: libdbusmenu-glib-ubuntu e libdbusmenu-glib estão em conflito. Remover libdbusmenu-glib? [s/N] s
:: libnm-gtk-ubuntu e nm-connection-editor estão em conflito (libnm-gtk). Remover nm-connection-editor? [s/N] s
:: libdbusmenu-gtk2-ubuntu e libdbusmenu-gtk2 estão em conflito. Remover libdbusmenu-gtk2? [s/N] s
:: libnautilus-extension-ubuntu e libnautilus-extension estão em conflito. Remover libnautilus-extension? [s/N] s
:: nautilus-ubuntu e nautilus estão em conflito. Remover nautilus? [s/N] s
:: libappindicator e libappindicator-gtk2 estão em conflito. Remover libappindicator-gtk2? [s/N] s
:: libindicator e libindicator-gtk2 estão em conflito. Remover libindicator-gtk2? [s/N] s
erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: gnome-shell: requer nm-connection-editor
[[email protected] ~]$ sudo pacman -Ss nm-connection-editor
extra/nm-connection-editor 1.0.10-1 [instalado]
NetworkManager GUI connection editor


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts