Slackware com kernel 2.6.10 - passo a passo

cvs

Nesse artigo vamos compilar o kernel no Slackware, porém ele também pode ser aplicado em outras distribuições. Artigo inspirado no "Debian com kernel 2.6.10 - passo a passo", porém sem o uso das ferramentas específicas para essa distribuição. Também cito conceitos diferentes, o que pode ampliar o conhecimento do usuário sobre o assunto.

[ Hits: 96.796 ]

Por: Thiago Alves em 20/02/2005 | Blog: http://www.seeufosseopresidente.com.br


Conclusões



Esse artigo ficou simples, não abordei muita coisa, pois o conteúdo é bem extenso e olha que quando estava no meio do artigo, esse Firefox deu pala, fechou e eu perdi o que já tinha escrito, mania de escrever direto aqui.

Bom, se houver alguma dúvida, podem entrar em contato, terei prazer em atender.

Quando se fala de kernel, pode ser e pode não ser, por ser uma configuração bastante extensa, pode-se esquecer certas partes ou confundir e assim se deparar com um kernel panic, mas nem tudo esta perdido, basta dar boot pelo outro kernel e assim recompilar, até pegar o jeito e aprender a maneira correta de fazer e aí quem sabe escrever um artigo sobre o assunto.

Foi utilizado de base a distribuição Slackware, versão 10.0 (because it works) hehehe... Mas creio que não vai haver problema nenhum em implementá-lo em outras distribuições.

Boa sorte!

Página anterior    

Páginas do artigo
   1. Introdução
   2. Baixando as tralhas
   3. Configurando
   4. Compilando e instalando
   5. Conclusões
Outros artigos deste autor

Gaim + Gaim Encryption - Bate-papo com segurança

Instalação e configuração do Gkrellm

Servidor FTP com NetBSD (PureFTPD + MySQL)

Instalação do CentOS 5.3

ProFTPD + MySQL - Servidor FTP com usuários em banco de dados

Leitura recomendada

Compilação comentada do kernel

Controle de tráfego utilizando HTB no Debian Sarge

Atualizando kernel de 2.4.31 para 2.6.13 no Slackware 10.2

Como mudar o logo no kernel 2.6

Compilando Kernel 2.6.34 usando Debian Lenny

  
Comentários
[1] Comentário enviado por hdoria em 20/02/2005 - 09:22h

cara ...
qdo eu recompilei meu kernel .. eu tive 2 problemas:

1) Minha net não xega nem a conectar mais. Sempre que tento inicializar o adsl com o comando adsl-start da timeout.

Minha placa de rede está como modulo. Também ja tentei colocar como built-in e deu o mesmo problema.

2) Durante a compilação ele não cria os devices. Ex: /dev/dsp .. /dev/snd e por aí vai.

Eu possuo o module-init-tools e o udev instalados:

$ ls /var/log/packages/ | grep module-init
module-init-tools-3.0-i486-1
(aqui eh a unica coisa diferente que tenho em relação ao tuto ... já que usei um pacote pre-compilado que baixei pelo swaret do slackware.at ao inves de compilar)

$ ls /var/log/packages/ | grep udev
udev-050-i486-1

E as versões dos pacotes do alsa instalados são:

$ ls /var/log/packages/ | grep alsa
alsa-driver-1.0.5a-i486-2
alsa-lib-1.0.5-i486-1
alsa-oss-1.0.5-i486-1
alsa-utils-1.0.5-i486-1

Alguma sugestão?

[2] Comentário enviado por cvs em 20/02/2005 - 09:58h

É, tenho que te falar que já vi esse problema, muita gente que atualizou o alsa não consegue mais configurar a placa de som... Pode ser problema lá na hora de configura a parte do som, vc pode escolher usar o ALSA ou o OSS, eu normalmente uso o OSS por causa do meu pc antigo... hehehe

Quanto ao modulo-init-tools, eu normalmente compilo ele, não testei com pacote pre-compilado pra ver se roda blz.

Em relacão a sua internet, não uso esse esquema de rp-pppoe mas creio que seja necessario ativar na configuracao como builtin ou modulo a parte de PPP.

[3] Comentário enviado por lynda em 20/02/2005 - 16:01h

ola pessoal!
sou meio que novata na area de linux..
gostaria de saber por alto qual a vantagem de recompilar minha kernel da 2.4.26 para a 2.6.10, e temo que erros, mesmo seguindo este tutor, sejam frequentes. são?

brigada!
nayarah

[4] Comentário enviado por tagallo em 20/02/2005 - 22:55h

alguem ae sabe se a config do 2.6.8.1 rola no 2.6.10, ou mudou alguma coisa? queria colocar esse kernel mas to sem tempo de refazer a config, seria uma mao na roda usar a mesma que eu ja tenho pronta e funcionando redondinha

[5] Comentário enviado por tagallo em 20/02/2005 - 23:06h

Oi Lynda... fui olhar suas fotos e descobri que tenho vc no orkut! haushaushasu nao sabia q vc curtia linux! muito massa... pega meu msn pra gente conversar: [email protected]

respondendo sua pergunta... vc vai sentir basicamente duas diferenças...
se vc usa uma compilacao padrao do 2.4 vai sentir uma baita diferença qdo fizer um config certinha pro seu hardware... o kernel que vem compilado nas distros vem com quase tudo habilitado como modulo, e mais uma penca de coisa build-in pra funcionar em praticamente qq maquina, muita coisa vc nao usa, nao precisa ou nao quer, entao pode desabilitar. Fazendo a config certinha, o sistema vai iniciar bem mais rapido, e economizar um pouco de ram.
a outra vantagem é a mudança do 2.4 pro 2.6 propriamente dita... as diferenças sao muitas, e se vc tem curiosidade merece ser pesquisado e testado... boa sorte pra vc! e se tiver problemas (que sao comuns, mas nao frequentes se vc souber oq esta fazendo) pergunta ae que o pessoal ajuda!

[6] Comentário enviado por streetlinux em 20/02/2005 - 23:18h

A parada do adsl que o mano n0z3y citou, tem que abilitar o suporte a ppp em networks. Eu tb tive esse problema ao compilar o kernel 2.6.10 aki.

O artigo ficou simples, mas tá legal de entender.

Falow!

[7] Comentário enviado por caiovinic em 23/02/2005 - 00:19h

Boa cvs!!

Simples e direto!

[8] Comentário enviado por fernandofei em 24/02/2005 - 00:28h

ae pessoal.. eh o seuginte... segui o passo a passo td certo mas no meu naum rolou hehehe... eh o seguinte.. tenho duas hds... a master (hda) tem o windows... a slave (hdb) tem o slack...
na hora do boot dah um kernel panic....
UDF -fs: No partition found (1)
Kernel panic -not syncing:VFS;
Unable to mount root fs on unknown-block (3,66)...

Q q tah errado???
Percebi q qdo gravo o lilo na MBR aparece uma mensagem
Warning: The boot sector and map file are on different disks.

Acredito q seja pq o lilo tah na hdb e a MBR eh do hda...
alguem pode me ajudar???

valew
fernandofei
[email protected]

[9] Comentário enviado por fernandofei em 25/02/2005 - 00:21h

ae... o erro era meu... faltou o modulo do reiserfs hehehe.. mals ae... agora posso dar nota... 10........

[10] Comentário enviado por verithrax em 26/02/2005 - 00:26h

Você esqueceu de mencionar que é melhor baixar o kernel de um mirror próximo (faz bem para você e para a Internet). O mesmo arquivo no mirror brasileiro fica em http://www.matrix.lkams.kernel.org/linux/kernel/v2.6/linux-2.6.10.tar.bz2

[11] Comentário enviado por __FERNANDO__ em 26/02/2005 - 21:37h

Segui todos os passos...adorei o artigo...mas sempre eu me ferro tentando compilar o kernel..hehehe...acho que é alguma opção no make menuconfig que selecionei ou deixei de selecionar..

Quando escolho no lilo a entrada referente ao novo kernel 2.6.10...começa com um monte de pontinhos (...........................) e depois reinicia a máquina.
Cara faz tempo que luta pra conseguir compilar um kernel viu..mas ainda num obtive susseço...mas uma hora eu vou conseguir..heheh.
Jà tentei com Debian, Conectiva e agora tõ no Slackware..queria mesmo conseguir com Slackware... mas tô numa maré viu..hehe.

Se tiver alguma idéia e puder me ajudar fico muito grato....
Obrigado,

E parabéns novamente pelo aritgo.

Fernando.

[12] Comentário enviado por MARCOCARA em 07/03/2005 - 10:56h

AMIGO TUTORIAL EH 10 , EU USO SLACKWARE 10.1 KERNEL 2.4.29, TO COM UM PROBLEMINHA EU USO DOIS HDS SCSI , NA HORA DE INSTALAR USO O KERNERL ADAPTEC.S , TIPO MUDO O QUE PARA ELE RECONHECER OS MEUS HDS ..DESDE DE JA OBRIGADO

MADMAX SLACkWARE NA VEIA ...VIVA O LINUX

[13] Comentário enviado por 76ers em 29/03/2005 - 19:06h

ae, eu to com o memo problema do fernadofei ae:
UDF -fs: No partition found (1)
Kernel panic -not syncing:VFS;
Unable to mount root fs on unknown-block (3,2)

como resolve, q eu nao consegui d nenhum jeito.....soh me dah uma luz ae, plz
vlw
flw
(qlqr coisa manda pra cá: [email protected])

[14] Comentário enviado por caiovinic em 04/06/2005 - 17:05h

tbm tô com o problema do n0z3y...
num criar os /dev/dsp nem a pau!
alguém conseguiu resolver?

[15] Comentário enviado por Lpareal em 14/12/2005 - 21:53h

Fala Thiago!
Fiz a prova dos noves aqui e testei as informações do artigo compilando o kernel 2.6.14.3. Ficou sensacional. Fiz exatamente "timtim por timtim" e o boot ficou bem mais rápido e otimizado.

Obrigado pela dica.

Abs.,
Luciano Areal

[16] Comentário enviado por pixe1man em 25/02/2006 - 16:17h

ai cara..
eu tentei atualizar o kernel do meu slack 10.2
para a versao 2.6.15
ocorreu tudo bem
mas quando eu do boot nele
o teclado simplesmente nao funciona... nem no console, aparece o campo para digitar login e senha e o teclado nao funciona.. saberia me dizer o q falto?


abs.
gustavo

[17] Comentário enviado por LUNIX_777 em 11/05/2006 - 14:02h

Deu tudo certo até o reboot, quando entrei no novo kernel, o sistema não conseguil montar o root em /dev/hda2 (onde se encontra o meu linux) parecido com os erros q aconteceram c o 76ers e o fernadofei ( deu kernel panic também), so q o meu ta tudo num HD só. O q pode ter acontecido?

[18] Comentário enviado por Wesllay em 04/08/2006 - 04:44h

Pelo o que eu to vendo tá cheio de gente com o mesmo problema do que eu, mas será que nim saber resolver este problema do "kernel panic -not sysncing?????

[19] Comentário enviado por cvs em 04/08/2006 - 07:33h

Esse problema é apenas porque não colocaram suporte ao sistema de arquivos que vocês utilizam... por isso esse erro :)

[20] Comentário enviado por /root em 20/09/2006 - 22:52h

Em qual seção habilito suporte a ppp na configuração para compilação do kernel 2.6 ?
Por exemplo : Network -> (caminho)

[21] Comentário enviado por joao.claudio em 06/10/2006 - 14:20h

DICA

Para instalar o DB4
Verifique a existência do Pacote Berkeley DB no Slackware:

# ls /var/log/packages/ | grep db4
Se "a saída acima não ocorrer" então
1) Monte o CD1 do Slack 10;
2) entre no diretório slackware/l/;
3) execute # installpkg db4-4.2.52-i486-2.tgz;

Abraços

[22] Comentário enviado por Gilmar_GNU/Slack em 24/03/2007 - 13:20h

Olha só ..
O Slackware tem que digitar o codigo fonte do kernel se no caso o sistema for instalado apeenas ele seco !

[23] Comentário enviado por removido em 03/04/2007 - 22:13h

Rapaiz do céu. É muito bom. Dá certo, mas não deu no meu. Deu problema de tipo... na hora do reboot, e de escolher o SO no lilo, eu vou no Linux-Novo. Mas na hora de reconhecer a placa de rede, ele fala lá: endereço MAC e uns números, mas pára ali. Antes também dá um fail não sei o que. Vou tentar tirar 1 placa de rede que tenho no slot PCI que eu não uso. Será que pode ser isso?

Muita gente está tendo vários problemas, de teclado, na hora de boot e coisarada. Será que tem outra maneira de fazer isso?

Abraço e muito obrigado!


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts