Ocomon - Instalação e configuração

Galera, sei que aqui no VOL existem vários artigos de como implementar o Ocomon e suas configurações, mas lendo alguns me deparei com algumas impossibilidades na hora de instalá-lo e por isso resolvi escrever meu próprio artigo.

[ Hits: 105.961 ]

Por: Rafael da Silva Rosa em 22/11/2010 | Blog: http://rafaelsuporteonline.blogspot.com.br/


Upgrade para a versão Rc6



Como mencionado, a versão 2.0RC5 apresentou incompatibilidades com acentuação entre outros probleminhas que ocorreram nos meus testes, então depois de instalado e testado na versão 2.0RC5 eu atualizei a versão para a 2.0RC6. Como?

Fiz o download da versão 2.0RC6 no site do programa e baixei na pasta /usr/local/src.

# cd /usr/local/src
# tar -zxvf ocomon 2.0-RC6.tar.gz
# mv ocomon 2.0RC6 ocomon


Feito isso temos que alterar como antes os arquivos config.ini.php-dist para config.ini.php e alterar dentro dele também as opções do banco de dados. No arquivo conecta.class.php também alterar as opções de banco de dados. Feito isso temos que renomear a pasta ocomon dentro do /var/www.

# cd /var/www
# mv ocomon ocomon_old


Depois copiar o ocomon novo para a pasta /var/www:

# cp -r /usr/local/src/ocomon /var/www

Feito isso temos que dar um upgrade no banco de dados.

# cd /var/www/ocomon/install/2.0RC6/
# mysql -u root -p ocomon < UPDATE-FROM-2.0RC5-TO-2.0RC6.SQL


Ele vai pedir senha e atualizar o banco de dados para a versão 6.0. Caso apresente algum erro, revise os passos das configurações. Depois de atualizado temos que descompactar o arquivo ocomon_2.0RC6-patch-01.tar.gz, dentro dele existem duas pastas, a pasta includes com o arquivo versao.php e a pasta ocomon, geral com o arquivo encerramento.php.

Esses arquivos devem substituir os arquivos que estão dentro da pasta /var/www/ocomon. Lembrando que esses arquivos devem substituir os originais e devem ser substituídas também suas permissões.

Para resolver de vez por todos os problemas de incompatibilidades, no meu caso o maior problema era o de acentuação, após alterar um chamado eu usei o phpmyadmin e alterei o collation do meu banco de dados e resolvi meus problemas com acentuação, junto com as alterações dos arquivos descritos acima. O collation do banco de dados ficou latin1_swedish_ci.

Página anterior     Próxima página

Páginas do artigo
   1. Download dos pacotes necessários
   2. Ocomon - Um breve resumo
   3. Problemas nos testes
   4. Instalação feita com a versão Rc5
   5. Configurações e scripts da versão
   6. Upgrade para a versão Rc6
   7. Explicações finais e bibliografia
Outros artigos deste autor

Backuppc - Solução de backup corporativo

Conexão do Vindula com o Active Directory Server 2008 R2

Configurando um servidor DNS e DHCP na rede

Cacti + Plugins (Settings, Monitor, Thold e Weathermap) - Instalação e configuração

Plugin MSofficeKey para OCS Inventory

Leitura recomendada

Anthares, um sistema voltado para o usuário final

Bing: Medindo velocidade da conexão no Linux

Instalando o Gentoo GNU/Linux

SnipeIT - Gerenciamento de Ativos de TI

Acesso seguro a um desktop remoto utilizando Linux, OpenVPN e Nxserver

  
Comentários
[1] Comentário enviado por paulorvojr em 23/11/2010 - 00:19h

Belo how to, artigo, parabens, continue assim.

Mas tutorial não foi feito pra seguir a risca, por isso como você mesmo disse não serviam para instalação.
Tutoriais não são receitas de bolo, até receitas de bolo falham, mas te dão o caminho das pedras.

Ocomon é muito bom, eu uso em 3 empresas ja, e claro sempre quem quizer testar

http://helpdesk.paulojr.info/

abraços

[2] Comentário enviado por rafaelrsr em 23/11/2010 - 10:10h

Obrigado paulorvojr pela sua postagem, a intenção era realmente essa mostrar como fazer e não uma "receita". Abraço.

[3] Comentário enviado por leandrod_86 em 23/11/2010 - 11:30h

Tche preciso de uma mão olha só o erro que está apresentando para mim...
quando tento acessar a pagina
_________________________________________________________________________________________________________
Parse error: syntax error, unexpected '@' in /var/www/ocomon/includes/classes/conecta.class.php on line 54

---------------------------------------------------------------------------------------------------------------------------------------------------------

eu utilizei a seguinte configuração neste arquivo.

$this->con=mysql_connect(localhost,root,[email protected]@)or die(mysql_error());
$this->db=mysql_select_db(ocomon,$this->con);

olhei pelo phpmyadmin e a tabela ocomon está lá, verifiquei mais 1 erro, ao restartar o mysql ele me retorna:
#/etc/init.d/mysql restart
* Stopping MySQL database server mysqld [ OK ]
* Starting MySQL database server mysqld [ OK ]
* Checking for corrupt, not cleanly closed and upgrade needing tables.

Agradeço a ajuda

[4] Comentário enviado por paulorvojr em 23/11/2010 - 13:22h

pelo que o erro informa, é erro de sintaxe na linha 54, é o @ da sua senha, tire isso, senhas com @ não são legais em php.

$this->con=mysql_connect(localhost,root,[email protected]@)or die(mysql_error());

como teste bota senha 12345 mesmo, em produção bota senha dificil.

abraços

[5] Comentário enviado por rafaelrsr em 23/11/2010 - 13:49h

Olá leandrod 86 tudo bem?
Cara seguinte: Em relação ao erro realmente pode ser com a senha como o amigo paulorvojr disse, tente trocar por uma senha sem caracteres especiais. Até porque se o servidor apache for o mesmo que vc está usando para o servidor de ocomon ele tem que ser localhost mesmo e o usuário é o root então o problema é na senha mesmo. E em relação a mensagem do mysql não é erro não é apenas uma checagem nas tabelas.
Qualquer posta ae e obrigado paulo pela força.

[6] Comentário enviado por leandrod_86 em 23/11/2010 - 16:07h

blz, vou testar alterar e posto o resultado aqui, abraço.

[7] Comentário enviado por rafaelrsr em 24/11/2010 - 09:24h

Blza leandrod 86 altera e testa, depois posta ae.
Abraço

[8] Comentário enviado por leandrod_86 em 24/11/2010 - 11:46h

Bah, muito fera, agora vou dar uma olhada mais a fundo... Valeu mesmo tá bombando.

Só mais uma questão quando seleciona o grafico na aba Inventario > inicio , ele me retorna:

Fatal error: Call to undefined function imagecreatefromstring() in /var/www/ocomon/includes/jpgraph/src/jpgraph.php on line 5648

alguma ideia?

[9] Comentário enviado por rafaelrsr em 24/11/2010 - 15:54h

Olá leandro, eu não uso o modo inventário aqui na empresa, mas testei para ver se o meu também retornaria erro. Nos meus teste não retornou erro algum então fui até o arquivo que você disse estar dando erro e obtive as seguintes linhas

function CreateFromString($aStr) {
return imagecreatefromstring($aStr);


Confere com seu arquivo jpgraph.php e ve se obtem alguma diferença. Qualquer volte a postar. Abraço.

[10] Comentário enviado por paulorvojr em 24/11/2010 - 17:04h

leandrod_86,

o sistema ainda não é 100%, a parte de inventário esta em fase beta, mas funciona perfeitamente.

primeiro deixe seu inventário vazio, e clique em gerar gráfico, devera aparecer o resultado

JpGraph Error
empy data array, xxxxxxxxxxxxxxx

ou seja não é erro, informa que voce não tem nada, mas a função foi executada, se aparecer diferente disso, é porque você não tem alguma dependencia.

Tente 2 formas e depois reporte,

1 - abra o php.ini
descomente (tire o ponto e virgula) a seguinte linha:

#extension=php_gd2.so

2 -Baixe o pacote em http://sourceforge.net/projects/jpgraph/
descompacte, copie tudo em /ocomon/includes/jpgraph/src
- Feche o Ocomon e abra novamente.

Como nosso amigo autor do artigo também não usa o inventário, pouca gente usa e quando usa não usa os relatorios do ocomon por serem simples

com uma boa query, voc6e exporta os dados, bota num excel, e gera qualquer gráfico pra direitoria e funcionários.

Abraços

Paulo Roberto Junior
www.paulojr.info
http://www.vivaolinux.com.br/~paulorvojr

[11] Comentário enviado por marquinhos1875 em 24/11/2010 - 21:08h

Massa o artigo
mas é o seguinte, o ocomon está descontinuado então não espere melhoras nem alterações
tanto o rc5 quanto o rc6 dão uma certa dorzinha de cabeça mas quando acerta tudo, nao da mais dor de cabeça, é usar ate o hardware dar defeito
Ja uso na empresa e estou tentando uma forma de adaptar para provedores de clientes meu

[12] Comentário enviado por rafaelrsr em 25/11/2010 - 16:59h

Obrigado paulo pela ajuda com o colega e obrigado marquinhos pela postagem.
Hã Paulo aproveitando estou implementando o Openfire na empresa através de seu artigo, muito bom e muito obrigado pela ajuda, aconselho a todos darem uma olhada, muito bom.
Abraço a todos.

[13] Comentário enviado por paulorvojr em 30/11/2010 - 17:29h

rafaelrsr, falou! obrigado!

depois quando der bota com o openfire por acesso publico, VPN, essas coisas, ai pessoal externo com notebook ou em casa tem comunicação.

depois integra ele com o asterisk (tem plugin e tudo) ou seja vai ter voip, conferencia, siga-me off-line, tudo e o que mais imaginar rsrsrs

Abraços

Paulo Roberto Junior
www.paulojr.info
http://www.vivaolinux.com.br/~paulorvojr

[14] Comentário enviado por removido em 08/09/2011 - 09:55h

Olá Rafael.

Fiz a instalação do Ocomon conforme o tutorial, mas baixei a versão mas nova da software RC6.

A página na web /ocomon abre em branco não possui nada além, entre no diretório /var/www/ocomon verifiquei os arquivos e possuem. Poderia me ajudar? Obrigado.

Obrigado.

[15] Comentário enviado por rafaelrsr em 10/09/2011 - 13:36h

Olá Bino posso te ajudar sim, mas me add no skype para que possamos trocar melhor as informações. Segue meu skype rafaelrsr2003, fico no aguardo e obrigado.

[16] Comentário enviado por rafaelrsr em 06/03/2012 - 22:02h

Recebi um email pedindo ajuda para enviar emails pelo ocomon, gostaria de falar que não usei envios de email, mas acredito que basta configurar um servidor de email no mesmo servidor do ocomon.

[17] Comentário enviado por paulorvojr em 07/03/2012 - 02:24h

Galera

basta configurar seu server para envio de email, o chato se não configurar direito para outros servidores é tido como spam, mas se enviar pra sua rede local vai tranquilo

e alem do mais, basta ter um smtp valido, da pra usar até gmail, ou smtp simples de hospedagem de dominio...

[18] Comentário enviado por ViCalixto em 03/06/2016 - 13:21h

Pessoal instalaei o ocomon, configurei conforme orientado, no entanto digito http://ipdomeuservidor/ocomon e a pagina me aparece em branco.
Se coloco sobre.php carrega essa informação index.php não.

Podem me ajudar ?


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts