MSN-proxy no OpenSUSE 11.2 como guest em vmware em Windows Server 2008

Após instalar o MSN-proxy v0.7 no OpenSUSE 11.1 de 32 bits, resolvi migrar para MSN-proxy 0.8, mesmo ainda estando em sua versão alpha. O MSN-proxy foi instalado no OpenSUSE 11.2 x64 rodando como guest sobre VmWare 2.0.2 em sistema host Windows Server 2008 x64.

[ Hits: 35.758 ]

Por: Claudir Pereira dos Santos em 01/06/2010


Introdução



Após instalar o msn-proxy v0.7 no openSUSE 11.1 de 32 bits, resolvi migrar para msn-proxy 0.8, mesmo ainda estando em sua versão alpha (alguém tem que testar o sistema :)). O msn-proxy foi instalado no openSUSE 11.2 x64 rodando como guest sobre VmWare 2.0.2 em sistema host Windows Server 2008 x64.

Durante as pesquisas, percebi que usuários tem enfrentado problemas para instalar essa nova versão do msn-proxy. Dessa forma resolvi contribuir para comunidade Linux com esse pequeno artigo. Já existem várias informações na net sobre como instalar o msn-proxy e essa é mais uma para minha distro preferida.

Essa também é uma forma de mostrar aos administradores de rede que é possível manter um servidor Linux para aumentar a segurança sem custos adicionais com hardware. Não irei abordar aqui a instalação do VmWare e sua configuração, mas na net existe uma infinidade de materiais sobre o assunto, inclusive no site oficial do programa, www.vmware.com.

Como ambiente de instalação usei o KDE 4.3.5 release 0, que vem por padrão da distribuição openSUSE 11.2 x64. Você pode optar por usar outro gerenciador de janelas, mas saiba que isso pode mudar a localização de alguns arquivos e pastas.

Instalando o msn-proxy via 1-click install

A princípio iniciei a instalação do msn-proxy pelo site opensuse.org, usando a opção 1-click install. Na data que baixei, o pacote era o 0.8-1.1. O mesmo tem sido empacotado por nosso colega aledr, que faz parte da equipe de desenvolvimento. Isso facilita muito as coisas para os iniciantes, pois dessa forma as dependências são todas instaladas. O pacote melhorou muito desde a versão 0.7 no que tange a instalação automática dos pré-requisitos. Os requisitos são (observar que meu sistema é 64 bits):
  • libc.so.6()(64bit)
  • libc.so.6(GLIBC_2.2.5)(64bit)
  • libc.so.6(GLIBC_2.4)(64bit)
  • libc.so.6(GLIBC_2.3)(64bit)
  • libdl.so.2()(64bit)
  • libdl.so.2(GLIBC_2.2.5)(64bit)
  • libevent-1.4.so.2()(64bit)
  • cron
  • logrotate
  • mysql
  • php5-mysql
  • php5-sockets
  • rpmlib(PayloadFilesHavePrefix) <= 4.0-1
  • rpmlib(CompressedFileNames) <= 3.0.4-1
  • rpmlib(PayloadIsLzma) <= 4.4.6-1

O pacote também disponibilizou para ativação pelo yast os complementos msn-proxy-backend-mysql para suporte ao MySQL e msn-proxy-backend-pgsql para suporte ao PostgreSQL. No meu caso ativei o suporte a MySQL.

Para instalar o msn-proxy, acesse http://software.opensuse.org/search. Selecione openSUSE 11.2 e digite msn-proxy e clique em search. Serão exibidos os pacotes disponíveis para instalação. Para instalar, basta dar um clique em 1-click install. Siga sempre em frente na tela de instalação.

    Próxima página

Páginas do artigo
   1. Introdução
   2. Instalando perfumarias, configurando e criando banco de dados do MySQL
   3. Executando msn-proxy pela primeira vez
   4. Instalando e configurando interface web para administrar o msn-proxy
   5. Instalando e configurando o Squid
   6. Criando as regras iptables
   7. Realizando os primeiros testes com msn-proxy
Outros artigos deste autor

Instalando o MSN-Proxy 0.7 no OpenSuSE 11.1 Linux

Instalando e configurando Magento E-commerce com Apache2 no openSUSE 11.3 64 bits do zero

Leitura recomendada

Instalando e configurando o modem SpeedTouch 330 USB da Alcatel

Novo EyeOS - Sistema Operacional de Computação nas Nuvens

Tor Browser e Rede Tor no Arch Linux - Instalação e Utilização

Configurando um domínio pelo serviço ipturbo empresarial (Brasil Telecom)

Laconica - Twitter? Open source? Sim! Eis nosso microbloging de código aberto

  
Comentários
[1] Comentário enviado por junior em 01/06/2010 - 21:18h

Boa noite Claudir, acompanho as versões do MSN-Proxy a algum tempo, gostaria de saber quais as inovações e novidades que poderão vir com a versão 0.8.

Grato!

[2] Comentário enviado por claupers em 02/06/2010 - 08:46h

Ola junior.rocha.
A grande mudança que percebi foi o suporte a PostgreeSql e mysql como gerenciador de banco de dados. A versão está em um alpha, por isso acredito que ainda existem muitas implementações a serem feitas. A inferface web ainda tem alguns bugs que acredito, serão corrigidas nos próximos pacotes liberados.
Infelizmente no log de alteração não consta explicitamente o que foi feito, apenas que foi atualizado para 0.8.
Para produção recomento manter a versão 0.7 e usar a 0.8 apenas como teste para contribuir com o projeto.


Cordialmente;


Claudir

[3] Comentário enviado por delete em 07/12/2012 - 08:46h

alguem sabe se a versão 0.8 monitora os clientes com MSN 2010 e msn 2011 ? a versão 0.7 esta apresentando problemas com esses clientes. Obrigado!


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts