MP3 Player USB no Slackware

No final do ano ganhei um mp3 player desses meio genéricos que conectam ao computador por USB, estilo pen drive, e para colocá-lo no Linux não se tornou um problema, e ainda digo mais, tive mais problemas para colocá-lo foi para funcionar no Windows.

[ Hits: 60.280 ]

Por: Vitor Ribeiro de Souza em 10/04/2006


Introdução




No final do ano ganhei um MP3 Player desses meio genéricos, que conectam ao computador por USB, estilo pen drive e para colocá-lo no Linux não se tornou um problema e ainda digo mais, tive mais problemas para colocá-lo para funcionar no Windows.

No Windows você precisa instalar o driver, depois o sistema irá reconhecer o dispositivo e com sorte irá aparecer a unidade. No Linux basta apenas conectar o dispositivo, esperar o hotplug reconhecer e montar.

Sem mais conversa, vamos começar!
    Próxima página

Páginas do artigo
   1. Introdução
   2. Hotplug USB
   3. Montando o MP3 Player
   4. Adicionando ao fstab
   5. Incompatibilidade do Hotplug com o Alsa
Outros artigos deste autor

Inprotect + Nessus: Scanner de vulnerabilidades

Webcam Genius no Linux - Slackware

Fluxbox: Unleashead - iDesk + aDesklets + Gkrellm + Eterm

Recursos de placas de vídeo nVidia no X.org

Leitura recomendada

64 Bits - A próxima batalha

Configure seu modem SmartAx MT810 no Ubuntu

Instalando Token da OAB no Linux Mint 17.3 (Rose)

Instalando o ATI Driver (Suse 9.1)

Instalando nVidia no Debian Lenny 5.0.1 - Kernel 2.6.26-2-686

  
Comentários
[1] Comentário enviado por pedru em 10/04/2006 - 20:53h

Legal o artigo o FOSTON 521mb funcionou numa boa.. q eh igual esse da imagem..

Agora tem um aqui que a gente usa dentro do capacete em competições hehehe.. Esse não foi encontrado por nada!

Ao dar lusb ele soh mostra os devices..
E apos adicionar no fstab ele acha o dispositivo mas da erro:

root@PS2:/home/pedru# mount /dev/sda /mnt/Mp3Player -t vfat
mount: wrong fs type, bad option, bad superblock on /dev/sda,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Ae da esse erro.. em qualquer porta USB..
Se souber algo vlw!
Abraço.. e belo artigo!

[2] Comentário enviado por Eagle em 10/04/2006 - 21:04h

Aew pedru.

Tenta montar seu especificar o sistema de arquivos. Assim:
# mount /dev/sda /mnt/Mp3Player
Talvez o próprio programa mount identifique o que seja e monte ele.
No meu pen-drive se eu especificar dá esse mesmo erro. Tenho que deixar que ele tente achar algum.

O artigo ficou bom. Eu fiz um script em shell para facilitar algumas tarefas no meu pen-drive. Depois eu coloco ele aqui no VOL.

Abraço.
Leonardo Fedalto

[3] Comentário enviado por internero em 10/04/2006 - 21:53h

Buenas!

pedru, talvez seu pendrive não esteja em /dev/sda e sim em /dev/sdb, sdc, etc...

digo isso porquê tenho dois discos SATA em meu computador e por esse motivo meu pendrive sempre acaba aparecendo em /dev/sdc.

vale ressaltar também que o hotplug sempre mapeia o /dev/sdX de modo que o primeiro dispositivo que for plugado pega a primeira letra. logo, se você tiver, digamos, uma câmera digital e um mp3 player (ou um pendrive, gaveta usb, etc) a ordem de conexão altera sim o dispositivo criado no /dev

no mais, ótimo artigo!

grande abraço!

[4] Comentário enviado por pedru em 10/04/2006 - 23:08h

Internero!

Poxa cara vc matou a charada! hehehe..
Botei o sdb e já era montou direitinho!
Eu tinha testado isso no debian mas nao tinha dado certo.. a mto tempo
a nem tinha me lembrado q mudei de distro! hehehe..

Abraçaoooooo!

E vlwwwwwww Leonardo pela força ae! =) mas nem era isso ae nao!
Continue assim.. sempre ajudando!

[5] Comentário enviado por vitor.jjb em 11/04/2006 - 09:11h

Fala Galera, desculpem nao ter respondido antes, pois estava no trabalho e tive prova na faculdade e o Velox la de casa me deixou na mao!

Eu acho legal especificar o FS, mas muitas vezes não será necessario. E acho que a dica da galera ae já fez diferença legal!

Vlw galera!

[6] Comentário enviado por JuNiOx em 11/04/2006 - 10:07h

interessante o artigo
=)
pena que eu não tenho um mp3player ainda hehehe

falow

[7] Comentário enviado por removido em 11/04/2006 - 13:36h

TENHO UMA CAMERA DIGITAL COM CARTÃO SD, O HOTPLUG RECONHECE O DISP. , MAS NÃO FUNCIONA COM VFAT, JÁ TENTEI ALGUNS FS, MAS SEMPRE COM A MESMA MSG WRONG FS! AUÉM SABE QUAL O FS DO CARTÃO, NO WIN FUNCIONA TUDO BEM.

[8] Comentário enviado por vitor.jjb em 11/04/2006 - 14:52h

Marasciulo
Entao bota ela no Windows e ve qual sistema de arquivo ela usa ;)
ae no Linux tu monta com o FS que viu no Windows!
qlqer coisa posta ae!
abs!

[9] Comentário enviado por dibetao em 11/04/2006 - 19:27h

Uso o debian-Br-CDD e foi muito fácil configurar o pen drive (mp3 player). No Kurumin então nem se fala. No rindows 98 nao consegui de maneira nenhuma, pois o driver do fabricante veio com problema. Nem fui bater cabeça, pois no linux pegou 100%.

[10] Comentário enviado por pedru em 11/04/2006 - 23:29h

root@PS2:/home/pedru# lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 001 Device 002: ID 1004:6000 LG Electronics, Inc. VX4400/VX6000 Cellphone
root@PS2:/home/pedru# mount /dev/sd
Display all 128 possibilities? (y or n)
sda sda6 sdb2 sdc12 sdd sdd6 sde2 sdf12 sdg sdg6 sdh2
sda1 sda7 sdb3 sdc13 sdd1 sdd7 sde3 sdf13 sdg1 sdg7 sdh3
sda10 sda8 sdb4 sdc14 sdd10 sdd8 sde4 sdf14 sdg10 sdg8 sdh4
sda11 sda9 sdb5 sdc15 sdd11 sdd9 sde5 sdf15 sdg11 sdg9 sdh5
sda12 sdb sdb6 sdc2 sdd12 sde sde6 sdf2 sdg12 sdh sdh6
sda13 sdb1 sdb7 sdc3 sdd13 sde1 sde7 sdf3 sdg13 sdh1 sdh7
sda14 sdb10 sdb8 sdc4 sdd14 sde10 sde8 sdf4 sdg14 sdh10 sdh8
sda15 sdb11 sdb9 sdc5 sdd15 sde11 sde9 sdf5 sdg15 sdh11 sdh9
sda2 sdb12 sdc sdc6 sdd2 sde12 sdf sdf6 sdg2 sdh12
sda3 sdb13 sdc1 sdc7 sdd3 sde13 sdf1 sdf7 sdg3 sdh13
sda4 sdb14 sdc10 sdc8 sdd4 sde14 sdf10 sdf8 sdg4 sdh14
sda5 sdb15 sdc11 sdc9 sdd5 sde15 sdf11 sdf9 sdg5 sdh15
root@PS2:/home/pedru# mount /dev/sd

Olha eu aquiiiii de novo! uahuhauhah
Tentei essas portas ae mas sem o numero! se alguem tive uma dica!

Celular LG MX-510!

Vlw!

[11] Comentário enviado por mlegidio em 12/04/2006 - 02:02h

conseguir fazer funfar meu mp3 no debian tranquilamente. antes de mais nada usei o comando fdisk -l, que me mostrou em qual device eu deveria montar o meu dispositivo. o fs é vfat. criei um diretorio. alterei meu fstab e depois so copiei as mp3. Slack eu nao conhece mas acho q deve ter o comando fdisk ou um similar, nao?!
T+

[12] Comentário enviado por vitor.jjb em 12/04/2006 - 14:26h

Pedru,

Nao posso te dar 100% de certeza... mas qual o cabo que o celular usa? é um cabo USB igual os do MP3? pois dependendo vc teria que usar um programa chamado Gammu para fazer a comunicação do micro com o celular.

abs.

[13] Comentário enviado por pedru em 12/04/2006 - 15:25h

Então é outro dipositivo (ACM)
Carrego o modulo e tudo certinho ae tem que montar como:
#mount /dev/ttyACM /mnt/Celular
O unico problema é que ele não monta! hehehe
Vou ve se com esse programa muda alguma coisa.
Mas ele é como um disco removivel pq utiliza cartao miniSD igual de maquina fotografica,,,
Bom.. Veremos!

Grato,


Pedru

[14] Comentário enviado por fernandoamador em 12/04/2006 - 18:25h

ótimo artigo...

[15] Comentário enviado por rodrigogm_ em 13/04/2006 - 23:15h

Estou tendo problemas pra montar a TransFlash do meu Motorola e398 transformado em Rokr E1 com itunes, já tentei tudo que esta acima, mas ele não consegue montar com vfat, já tentei com outro tipo de fs mas não vai, com vfat ele volta a mensagem:
"mount: wrong fs type, bad option, bad superblock on /dev/sda1,
missing codepage or other error
(aren't you trying to mount an extended partition,
instead of some logical partition inside?)
In some cases useful info is found in syslog - try
dmesg | tail or so"

No windows eu usava o iTunes pra passar as musicas pro celular, vamos dizer que ele alem de reconhecer como disco removivel reconhecia como iPod também...

Se alguem tiver uma sugestão agradeço desde já xD

[16] Comentário enviado por pedru em 14/04/2006 - 12:40h

rodrigogm_:

Quando vc aplica o comando #lsusb o que aparece?!
De uma olhada nisso:
http://www.vivaolinux.com.br/artigos/verArtigo.php?codigo=2339

é um artigo pra acessar celulares da motorola!

E se nao der certo procure uma dica de como se monta o Ipod no linux.. pq esse celular seu deve parecer um disco removiveo naoé?

Tenta ae..

Abraços!

[17] Comentário enviado por rodrigogm_ em 17/04/2006 - 00:34h

Agora consegui... achei o problema, tipo tinha que mudar a configuração do celular pra ele ser reconhecido como disco removivel, eu havia esquecido disso, porem agora foi numa boa, valeu ;)

[18] Comentário enviado por rodrigogm_ em 17/04/2006 - 23:27h

Pronto agora o problema é o seguinte, não to achando um programa pra gerenciar as musicas do celular(funciona como ipod), no windows eu usava o itunes mesmo, porem no linux não estou achando uma alternativa ou até tenho mas não estou conseguindo usar, como no caso o Amarok, me falaram que tem como porem não achei a maneira... se alguem souber posta ai por gentileza... valeu...

Ps.: iPod não é que nem mp3 player comum que tu joga as *.mp3 na memória e sai tocando... iPod é cheio de frescura... cria banco de dados e tudo mais... por isso precisa de algum programa expecifico para gerencia-lo ;)

[19] Comentário enviado por espedito em 11/08/2006 - 16:47h

ta mais... então não é possível usar iPod em GNU/Linux?

[20] Comentário enviado por CerberusBH em 16/01/2007 - 12:08h

Eu gostei! Ainda tem gente que tem dúvidas quanto a acessar pendrives e tocadores MP3 no Linux.
Com o hotplug é moleza acessar pendrives e os tocadores de MP3. Eu uso Slackware 11, já usei Conectiva 10 e nunca tive problemas.
Mas não concordo com a afirmação de que com o Windows há problemas em acessar porque precisa instalar driver e deve ter sorte para que o sistema reconheça a unidade.
Além do Linux, também uso Windows XP, e já tive no meu PC o Windows ME e Windows 2000 Server. Nestas versões de Windows eu NUNCA precisei instalar CD nenhum, e sempre houve detecção automática dos pendrives e MP3, como também do pendrive de meu telefone, que é um Motorola V360.

[21] Comentário enviado por tomcarlos em 25/01/2007 - 11:44h

Meu Debian não consegue reconhecer meu Zen Nano Plus (creative Labs), alguem tem alguma ideia?
Quando faço
# lsusb
simplesmente ele nao mostra nada

[22] Comentário enviado por alexside em 03/05/2007 - 15:47h

Bom tenho o opensuse 10.1 e ltsp 4.2.
O mp3playyer no server ele echa e posso fazer as alterações na boa, porém nas estaçoes ele nãoi detecta, tem que fazer alguma conf específica?
ps: pendrive "puro" detecta nas estações.
1[ ]

[23] Comentário enviado por mactoia em 05/11/2008 - 19:42h

quando eu uso o comando /etc/rc.d/rc.hotplug start
aparece a seguinte mensagem na tela.
** can't synthesize pci hotplug events
Cannot open /proc/bus/usb/001/001
Cannot open /proc/bus/usb/001/001
Cannot open /proc/bus/usb/002/001
Cannot open /proc/bus/usb/002/001
Cannot open /proc/bus/usb/002/002
Cannot open /proc/bus/usb/002/002
Cannot open /proc/bus/usb/003/001
Cannot open /proc/bus/usb/003/001
Cannot open /proc/bus/usb/004/001
Cannot open /proc/bus/usb/004/001
Cannot open /proc/bus/usb/005/001
Cannot open /proc/bus/usb/005/001

alguem por favor poderia me ajudar, estou precisando acessar o conteudo de um trabalho q está no pendrive (mp3) e não estou conseguindo. Obrigado.


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts