Kernel 4.0 no Debian, Linux Mint e Ubuntu - Atualização rápida

Estou realizando uma nova contribuição na comunidade GNU/Linux, descrevendo de forma rápida, a atualização do kernel do Debian e suas variações (Ubuntu, Linux Mint, Lubuntu etc) para a versão 4.0, lançada em 12/04/2015.

[ Hits: 22.250 ]

Por: Fabricio Santana em 15/04/2015


Introdução



Olá, pessoal.

Estou realizando uma nova contribuição na comunidade GNU/Linux, descrevendo de forma rápida, a atualização do kernel do Debian e suas variações (Ubuntu, Linux Mint, Lubuntu etc) para a versão 4.0, lançada em 12/04/2015.

O Kernel Linux 4.0, codinome "Hurr durr eu sou uma ovelha" - não, realmente - traz consigo um conjunto pequeno de novo suporte de hardware, ajustes de performance, correções de bugs e afins.

Recursos

Se você já foi posto para fora por necessidade de reiniciar a sua máquina Linux para concluir a instalação de uma atualização do kernel, não estará sozinho. É um pequeno inconveniente na área de trabalho, e uma das mais importantes para os servidores.

A boa notícia é que o Linux 4.0 não precisa reiniciar para completar a atualização do kernel, uma coisa do passado. Bem, quase.

A base inicial para apoiar patching sem reinicialização chega nesta última versão, pronta para administradores experientes para aproveitar o Kernel Linux 4.0.

Outras mudanças

Embora seja considerado um pequeno lançamento do mais novo kernel Linux, consegue espremer em um conjunto de boas-vindas de melhorias de hardware, novos drivers e ajustes de performance.

Esses incluem:
  • Melhorias na plataforma Intel "Skylake";
  • Suporte Intel Quark SoC;
  • Várias correções para melhorar Linux rodando em um Playstation 3;
  • Töpen-source AMD Radeon driver suporta DisplayPort Áudio;
  • Vários ajustes de driver HID variado, incluindo Lenovo teclados compactos, Wacom Cintiq 27QHD;
  • Toshiba configurações de energia do motorista acrescenta sono USB / função de carga, carga rápida, o sono w / música, etc;
  • Tweaks do sistema de arquivos, incluindo F2FS, BtrfFS, etc.

Saiba mais em:
Mesmo sendo fácil, lembre-se de realizar um backup de TODOS os seus arquivos, pois pode ocorrer algum problema no decorrer da execução e comprometer todo o sistema.

Estou usando um Ubuntu 14.04 LTS para realizar a atualização.

Primeiro, vamos verificar a versão do sistema (32 ou 64 bits), abra o terminal (Ctrl+Alt+t) e digite o comando abaixo:

uname -m
  • Se ele retornar "x86_64", seu sistema é 64 bits.
  • Se a mensagem for "i686", a versão é 32 bits.

Vou criar um diretório para ficar mais organizado os pacotes de atualização, vou continuar a atualização usando o usuário root:

# mkdir -p $HOME/atualiza_kernel
# cd $HOME/atualiza_kernel

Agora, vamos baixar os pacotes da respectiva arquitetura.

Arquitetura 32 bits:

# wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000-generic_4.0.0-040000.201504121935_i386.deb
# wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000_4.0.0-040000.201504121935_all.deb
# wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-image-4.0.0-040000-generic_4.0.0-040000.201504121935_i386.deb

Arquitetura 64 bits:

# wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000_4.0.0-040000.201504121935_all.deb
# wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-image-4.0.0-040000-generic_4.0.0-040000.201504121935_amd64.deb
# wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000-generic_4.0.0-040000.201504121935_amd64.deb

kernel 4.0 lowlatency

Agora, se deseja instalar o "kernel 4.0 lowlatency", use os links abaixo:

Kernel lowlatency 32 bits:

# wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000_4.0.0-040000.201504121935_all.deb
# wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-image-4.0.0-040000-lowlatency_4.0.0-040000.201504121935_i386.deb
# wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000-lowlatency_4.0.0-040000.201504121935_i386.deb

Kernel lowlatency 64 bits:

# wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000_4.0.0-040000.201504121935_all.deb
# wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-image-4.0.0-040000-lowlatency_4.0.0-040000.201504121935_amd64.deb
# wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000-lowlatency_4.0.0-040000.201504121935_amd64.deb

Agora que já foi realizado o download dos pacotes necessários, já podemos atualizar:

# dpkg -i *.deb

Vamos realizar a limpeza removendo os pacotes baixados:

# rm -rf $HOME/atualiza_kernel

Ao término, execute o comando:

# reboot

Pronto! Kernel instalado. Para verificar, basta executar o comando:

uname -r

Removendo

Caso tenha problemas ou queira remover, PRIMEIRO inicie o Kernel antigo.

E basta usar os comandos abaixo:

sudo apt-get purge linux.image-4.0*

Atualizar o GRUB (para garantir que não haja erros na inicialização):

sudo update-grub

E reiniciar.

Considerações finais

Usar a última versão do kernel é sempre uma caixinha de surpresas, então, veja se é necessário a atualização e use os últimos recursos adicionados ao kernel.

Desejo sucesso aos colegas Linux-users e até a próxima!

   

Páginas do artigo
   1. Introdução
Outros artigos deste autor

Instalação do Deepin 14.1 - Uma distribuição fantástica

Servidor NTP - Configuração e ajuste de data e hora

Compilação do kernel v3.x no CentOS e Debian

Antergos - Um caminho para conhecer o Arch Linux

Leitura recomendada

Primeiros comandos para iniciantes

Instalação do Linux em pendrive com VirtualBox

A Origem dos Nomes (parte 2)

Fedora - Instalação Personalizada (NetInstall)

Desknotes e Walkpcs

  
Comentários
[1] Comentário enviado por fabio em 15/04/2015 - 12:30h

A boa notícia é que o Linux 4.0 não precisa reiniciar para completar a atualização do kernel, uma coisa do passado.


Não sabia disso, excelente notícia, principalmente pra quem faz suporte remoto e precisa atualizar o kernel. Chega de ficar rezando pra máquina voltar com um ping em execução! kkk

Um abraço.

[2] Comentário enviado por izaias em 15/04/2015 - 23:09h

"A boa notícia é que o Linux 4.0 não precisa reiniciar para completar a atualização do kernel, uma coisa do passado."

Será mesmo? Quero ver na prática!

Mas a boa notícia, por enquanto, o Ubuntu está voando aqui!
Ótimo artigo!

[3] Comentário enviado por Battistax em 16/04/2015 - 10:09h

Ubuntu cada vez mais rápido e gerenciando melhor o consumo de RAM, com esse Kernel então...voando baixo!

[4] Comentário enviado por eike_bsd em 20/04/2015 - 01:52h

Genial,valeu mesmo!!

[5] Comentário enviado por ansu em 21/04/2015 - 21:18h

Tenho o Debian instalado na minha máquina e segui o tutorial e não deu certo.

[6] Comentário enviado por mangodeupp em 21/04/2015 - 23:58h


instalei e depois voltei pro antigo, tive problemas, alguns programas não funcionavam, exemplo :vmware e etc...

[7] Comentário enviado por MrTropaZ em 25/04/2015 - 15:45h


Muito bom, tem como instalar ele sem dar login? Pelo ctrl+alt+f1? E que aqui atualizei pro ubuntu 15 e agora to restrito ao login, ele não entra, não passa do login, ponho senha e faz que entra mas não entra, li num post que atualizando o kernel pra 4.0 resolve, mas eu uso esses comandos ai e da erro 404 nos links...

[8] Comentário enviado por GustavoValerio em 11/05/2015 - 01:31h


[5] Comentário enviado por ansu em 21/04/2015 - 21:18h

Tenho o Debian instalado na minha máquina e segui o tutorial e não deu certo.


Deve ter faltado algo.
Tenta novamente e depois de executar tudo, executa:
apt -f install

Ou posta o erro que aconteceu.

[9] Comentário enviado por weyderfs em 01/10/2015 - 12:40h

No Debian 8, 32 bits também não consegui retorna o erro:

[email protected]:~/atualiza_kernel# dpkg -i *.deb
A seleccionar pacote anteriormente não seleccionado linux-headers-4.0.0-040000.
(Lendo banco de dados ... 140823 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar linux-headers-4.0.0-040000_4.0.0-040000.201504121935_all.deb ...
A descompactar linux-headers-4.0.0-040000 (4.0.0-040000.201504121935) ...
A seleccionar pacote anteriormente não seleccionado linux-headers-4.0.0-040000-generic.
A preparar para desempacotar linux-headers-4.0.0-040000-generic_4.0.0-040000.201504121935_i386.deb ...
A descompactar linux-headers-4.0.0-040000-generic (4.0.0-040000.201504121935) ...
A seleccionar pacote anteriormente não seleccionado linux-image-4.0.0-040000-generic.
A preparar para desempacotar linux-image-4.0.0-040000-generic_4.0.0-040000.201504121935_i386.deb ...
Done.
A descompactar linux-image-4.0.0-040000-generic (4.0.0-040000.201504121935) ...
Configurando linux-headers-4.0.0-040000 (4.0.0-040000.201504121935) ...
Configurando linux-headers-4.0.0-040000-generic (4.0.0-040000.201504121935) ...
dpkg: problemas com dependências impedem a configuração de linux-image-4.0.0-040000-generic:
linux-image-4.0.0-040000-generic depende de module-init-tools (>= 3.3-pre11-4ubuntu3); porém:
Pacote module-init-tools não está instalado.

dpkg: erro ao processar o pacote linux-image-4.0.0-040000-generic (--install):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
linux-image-4.0.0-040000-generic

[10] Comentário enviado por weyderfs em 01/10/2015 - 12:44h


[9] Comentário enviado por weyderfs em 01/10/2015 - 12:40h

No Debian 8, 32 bits também não consegui retorna o erro:

[email protected]:~/atualiza_kernel# dpkg -i *.deb
A seleccionar pacote anteriormente não seleccionado linux-headers-4.0.0-040000.
(Lendo banco de dados ... 140823 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar linux-headers-4.0.0-040000_4.0.0-040000.201504121935_all.deb ...
A descompactar linux-headers-4.0.0-040000 (4.0.0-040000.201504121935) ...
A seleccionar pacote anteriormente não seleccionado linux-headers-4.0.0-040000-generic.
A preparar para desempacotar linux-headers-4.0.0-040000-generic_4.0.0-040000.201504121935_i386.deb ...
A descompactar linux-headers-4.0.0-040000-generic (4.0.0-040000.201504121935) ...
A seleccionar pacote anteriormente não seleccionado linux-image-4.0.0-040000-generic.
A preparar para desempacotar linux-image-4.0.0-040000-generic_4.0.0-040000.201504121935_i386.deb ...
Done.
A descompactar linux-image-4.0.0-040000-generic (4.0.0-040000.201504121935) ...
Configurando linux-headers-4.0.0-040000 (4.0.0-040000.201504121935) ...
Configurando linux-headers-4.0.0-040000-generic (4.0.0-040000.201504121935) ...
dpkg: problemas com dependências impedem a configuração de linux-image-4.0.0-040000-generic:
linux-image-4.0.0-040000-generic depende de module-init-tools (>= 3.3-pre11-4ubuntu3); porém:
Pacote module-init-tools não está instalado.

dpkg: erro ao processar o pacote linux-image-4.0.0-040000-generic (--install):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
linux-image-4.0.0-040000-generic


Pessoal desculpem minha ignorância encontrei o erro aqui:
linux-image-4.0.0-040000-generic depende de module-init-tools (>= 3.3-pre11-4ubuntu3); porém:
Pacote module-init-tools não está instalado

Executei o apt-get install module-init-tools, em seguida executei o dpkg -i *.deb e agora atualizou. :)

Obrigado pelo tutorial

[11] Comentário enviado por prof em 27/10/2015 - 00:54h


Muito fácil e prático vlw

[12] Comentário enviado por removido em 14/12/2015 - 17:07h

Como uso Mint 17.3 e Ubuntu 15.10 e não entendo nada desse tal de kernel, fiquei com medo de fazer . . .

[13] Comentário enviado por removido em 14/12/2015 - 17:12h

Estou tentando experimentar o Metamorphose e o Kaiana mas nenhum dá boot pela pendrive. No meu micro só tenho Linux, não tenho mais Windows, será que fiz mal ???

[14] Comentário enviado por PhillipeUS em 16/12/2015 - 22:49h

Nossa uso Debian deu muito erro aqui.

Primeiro deu o erro do module-init-tools, mas eu baixei ele.

Depois dentro do diretorio /boot ficou as imagem e arquivos de configuração tanto do meu kernel anterior quanto do novo, eu resetava e so vinha com o kernel velho, ate que eu apaguei as coisas do kernel 3.16 da pasta e o sistema nao teve outro jeito senao usar o kernel 4.

Mas aí veio o pior, eu uso AMD RADEON que eh configurada primeiro baixando os arquivos por esse comando

aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') fglrx-driver

como podem ver, quando eu tinha o kernel 3.16 ele baixou os headers para o kernel especifico (uname -r), dae o driver da AMD nao funfou.

tentei dar este comando de novo, agora pra pegar de acordo com o novo kernel, mas...

No candidate version found for linux-headers-generic
No candidate version found for linux-headers-generic
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

Alguem tem uma ideia como vou fazer pra reconhecer minha AMD RADEON ?

[15] Comentário enviado por renatonog em 27/09/2016 - 21:51h

Aqui foi de boa com Debian 8 acooonteceu comigo o mesmo do amigo weyderfs.


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts