KDE4 junto com KDE3 no Debian Lenny

Todos os tutoriais na internet que mostram como instalar o KDE4 no Debian o fazem substituindo o KDE3. No entanto, é possível fazer eles conviverem, mas para isso é necessário usar os pacotes do KUbuntu, distro na qual isso é possível.

[ Hits: 8.582 ]

Por: Fernando Lucchesi em 29/06/2008 | Blog: http://aoficina.sotao.net/


Introdução



Todos os tutoriais na internet que mostram como instalar o KDE4 no Debian o fazem substituindo o KDE3. No entanto, é possível fazer eles conviverem, mas para isso é necessário usar os pacotes do KUbuntu, distro na qual isso é possível.

Isso é necessário porque os pacotes do KDE4 no Sid (unstable) tem o mesmo nome dos pacotes do KDE3 no Lenny (testing), sendo impossível instalá-los simultaneamente. Já no KUbuntu, todos os pacotes dele terminam em "-kde4", evitando esse problema.

Normalmente não é boa idéia misturar pacotes de distribuições diferentes, mas se você não consegue esperar para testar o KDE4, e não quer por em risco seu KDE3, esse guia é pra você.

Instalando

A instalação é muito simples:

Abra o sources.list e salve uma cópia dele. Se você adicionar o repositório do Ubuntu no seu sources.list mantendo os outros, o Synaptic não vai conseguir juntar com os repositórios do Debian e vai fechar. Você tem que apagar todos os outros repositórios:

# /etc/apt/sources.list
#Ubuntu Hardy Heron
deb http://archive.ubuntu.com/ubuntu/ hardy main restricted universe multiverse

Se você faz questão das pubkeys (o que é bom para garantir que o pacote é de uma fonte confiável), adicione a do repositório do Ubuntu assim:

$ sudo su
# gpg --keyserver hkp://subkeys.pgp.net --recv-keys 40976EAF437D05B5
# gpg --export --armor 40976EAF437D05B5 | sudo apt-key add -


Agora salve, abra o Synaptic e recarregue a lista de pacotes. Você vai poder instalar qualquer pacote do Ubuntu no seu Debian (tomando o devido cuidado com as dependências). Você pode até aproveitar e instalar o Firefox 3.0, por exemplo, enquanto o Iceweasel 3.0 não sai (mas nesse caso eu prefiro esperar).

Se você tentar instalar o pacote kde4 (meta-pacote com todos os pacotes do kde4), ele não vai conseguir, porque ele depende de um pacote que depende de outro pacote que (...) depende do pacote libgs8 em uma versão específica, a do repositório do Ubuntu. Mas a versão do repositório do Lenny (a que está instalada) é mais nova, então ele não faz o downgrade automaticamente. Tudo o que você tem que fazer é abrir o menu Pacote > forçar versão, e escolher a do Ubuntu. Assim, tudo vai instalar corretamente.

Mas isso só é necessário se você fizer questão do Okular, o novo leitor de pdf do KDE4. Além dele, não serão instalados os pacotes kde4 e o kde4-graphics, ambos meta-pacotes (isso indica que não foram instalados todos os pacotes do kde4, só isso). Eu instalei, mas nem cheguei a testá-lo, e é tanto trabalho pra manter ele lá (a cada update com os repos do Lenny eu tinha que brigar pra ele não ser removido), então resolvi tirar de uma vez.

Não se assuste quando ele avisar que vai remover o kdebase-bin-kde3, esse é um pacote que pode ser fornecido pelo KDE3 ou pelo KDE4. Portanto, sua falta não vai influenciar o seu KDE3, já que em seu lugar será instalado o kdebase-bin-kde4.

Aplique as mudanças, ele vai reclamar de um monte de pacotes que não vão ser atualizados (e não devem ser mesmo, para não ter inúmeros problemas com dependências). Aguarde a instalação, ele vai perguntar se você quer substituir o gdm pelo kdm-kde4. Eu escolhi que não, para não ter problemas quando for desinstalar o KDE4. Não esqueça de colocar seus repositórios normais no seu sources.list quando terminar.

Reinicie o X, e lá vai estar a sessão do KDE4 para escolher, e a sessão do KDE3 vai ficar inalterada, pronta para o uso.

   

Páginas do artigo
   1. Introdução
Outros artigos deste autor
Nenhum artigo encontrado.
Leitura recomendada

Arapuca - Expandindo as funcionalidades do FreeRADIUS

Testando o Librix da Itautec

Apresentando e pondo a prova o Mono

Remasterizando o Kurumin

Servidor de Repositório Yum - CentOS / Oracle Linux

  
Comentários
[1] Comentário enviado por engos em 02/07/2008 - 14:59h

Tentei fazer isso e fiquei barrado na parte "menu Pacote > forçar versão".

Infelizmente Debian é uma distro da qual você tem que usar a versão estável e nunca mecher em nada, senão você corre o grande risco dela ficar pior que o Windows ME (como está a minha Debian Lenny), por esse motivo acabo de mudar meu source list para Etch e vou continuar a esperar sair para ele... :(

Fico feliz em saber que você conseguiu isso e está com os dois, mas como Debian só tenho no trabalho, melhor nem mecher para evitar problemas.

Acredito que no momento você já tenha testado bem o KDE4 com Lenny, comente aqui sua opnião para incentivar o pessoal a tentar instalar o KDE4 e servir como complemento do artigo, com os prós e contras.

[]s


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts