Instalando e configurando um sistema RAID 1 no Debian Lenny

Recentemente houve a necessidade de montar em meu setor de trabalho um sistema com redundância contra falhas. Pesquisando sobre o assunto, resolvemos que a alternativa para solucionar nosso problema poderia ser um RAID 1. Depois de feito, testado e documentado, resolvi compartilhar com a comunidade a minha experiência

[ Hits: 119.607 ]

Por: hermes nunes pereira junior em 24/09/2010


Introdução



Este artigo foi baseado nos seguintes sites:

1. Implementando RAID1 em um sistema sem perder dados - Devin
2. Corrigindo falhas e solucionando problemas de RAID no Ubuntu Intrepid (Ubuntu 8.10) « Andre Ferraro

e nas várias tentativas que fiz de fazer, usando vários caminhos que não deram certo.

O que é RAID?

(texto retirado de: Entendendo os Níveis de RAID (Redundant Array of Inexpensive Disks), texto de Danilo Montagna)

RAID é um acróstico de Redundant Array of Independent Drives - Conjunto Redundante de Discos Independente. Num bom português, o RAID é um sistema que utiliza de vários discos rígidos para criar uma redundância nos dados armazenados. Ao invés de ficar em apenas 1 HD, os dados são replicados em outros, ou seja, se um dos HDs falhar, outro HD assume até que o primeiro seja trocado e o sistema novamente sincronizado.

    Próxima página

Páginas do artigo
   1. Introdução
   2. Tipos de RAID
   3. Montando o sistema RAID
   4. Copiando a tabela de particionamento
   5. Criando o primeiro dispositivo md0
   6. Criando o sistema de arquivos das partições RAID
   7. Criando o sistema de arquivos das partições RAID - cont
   8. Adicionando o primeiro HD ao RAID 1
   9. Configurando o novo Grub
Outros artigos deste autor

Uma breve introdução ao Hydrogen

Instalação e configuração do LTSP 5 no Ubuntu 11.04

Criando um mirror do Conectiva para uma rede interna

Usando o NIS/NFS como ferramentas de centralização de controle de rede

Instalando o CMS Joomla

Leitura recomendada

Configurando o DNS - BIND9

Configurando o NRPE (Nagios Remote Plugin Executor) no Ubuntu Desktop 9.10/Server 8.04 com criptografia SSL

Resolvendo o problema de gerenciamento de energia - ACPI

Clonando HD no Linux

Fontes com filtros LCD no Arch Linux

  
Comentários
[1] Comentário enviado por pherde em 24/09/2010 - 14:46h

Po...... muito bom o artigo, muito bem detalhado....

[2] Comentário enviado por removido em 26/09/2010 - 17:36h

Hermes Nunes Pereira Júnior:

you broke the balloon's mouth with your article. It's very well written. Congratulations!
10!

[3] Comentário enviado por obernan em 27/11/2010 - 17:09h

Muito obrigado pela contribuicao, esse seu tutorial e muito importante, ja copiei e gravai na minha pasta de tutos importates !!!!
Mas uma vez muito obrigado pela contribuicao.
Abraço

[4] Comentário enviado por tihbaptista em 28/11/2010 - 23:36h

Sempre quando eu tento executar esse comando mdadm /dev/md2 -a /dev/sda6 diz que o device esta ocuado. É o device responsavel pelo swap, tem alguma ideia do que pode ser?

[5] Comentário enviado por aj.vini em 12/01/2011 - 15:15h

@tihbaptista

Seu swap está ativado? Se sim, desative-o com o swapoff /dev/sda6 antes de executar o comando.

[6] Comentário enviado por moliveira777 em 13/08/2011 - 22:44h

Boa noite,

Parabéns pelo artigo, mas fiquei com uma dúvida, os comandos abaixo são no HD master(sda) ou slave(sdb) ?

# cd /mnt
# mkdir raiz
# mount -t ext3 /dev/md0 raiz
# cd raiz
# mkdir initrd mnt proc sys
# cp -a /boot /bin /cdrom /dev /etc /initrd.img /lib /media ./
# cp -a /opt /root /sbin /selinux /srv /tmp /usr /var /vmlinuz ./


[7] Comentário enviado por alexandre.unix em 21/10/2011 - 12:35h

bom dia, esse tutorial não está funcionando, quando configuro conforme abaixo
As alterações ocorreram nas linhas:

root (hd1,0)
kernel /vmlinuz-2.6.24-1-686 root=/dev/md0 ro

Esta alteração vai fazer com que o sistema dê o boot pelo /dev/md0, a partição raiz, mas no segundo HD, o hd1,0.

o linux não carrega mais ai reinstalei novamente e pulei essa parte e continuo, só que quando chegar para atribuir os discos sda1 e os outros ele não deixa fala que está ocupado, teria como alguém me ajudar ?

[8] Comentário enviado por alexandre.unix em 21/10/2011 - 15:05h

Seguam esse tutorial que funciona.
Raid1 instalando o sistema do zero...
Testei todos os passos ,funciona perfeitamente.
Testei também o desastre com os 2 discos, uma de casa vez, dei o restore e funcionou perfeitamente.


http://translate.google.com.br/translate?hl=pt-BR&sl=en&u=http://mikeoverip.wordpress.com/2009/12/07...


Abraços...

[9] Comentário enviado por minduim em 29/01/2012 - 21:11h

Por favor alguem poderia me ajudar? Não consigo com que o Ubuntu 11.10 de boot com RAD1 no segundo HD.
Aproposito parabéns pelo artigo.

http://www.vivaolinux.com.br/topico/GRUB/Ubuntu-1110-Raid1-via-software-nao-funciona


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts