Instalação e configuração do gdesklets no Slackware 10

Gdesklets é uma arquitetura de "applets" destinado a implementar uma ampla gama de funcionalidades em seu desktop. Nesse artigo aprenderemos a instalar detalhadamente esse software e de quebra ainda veremos como instalar e configurar um display (plugin).

[ Hits: 59.125 ]

Por: Perfil removido em 18/12/2004


Um pouco sobre o gdesklets



Gdesklets é uma arquitetura de "applets" para desktop destinado a implementar na área de trabalho Linux (Gnome e gerenciadores de janela compatíveis), displays com uma ampla gama de funcionalidades como:
  • monitores de sistema;
  • monitores de condição atmosférica;
  • calendários;
  • relógios;
  • barras de ícones;
  • etc.

O gdesklets é o equivalente para Gnome ao Super Karamba do KDE e tem a vantagem justamente de funcionar em outros gerenciadores de janelas diferentes do Gnome, enquanto o Super Karamba funciona só no KDE. Em meus testes o gdesklets rodou perfeito no fluxbox-devel, tendo apresentado 100% de funcionalidade, como se estivesse rodando no Gnome. No blackbox ele funcionou apenas em uma área de trabalho, ficando as demais sem mostrar nenhum dos displays. No Enlightenment dr16 rodou, mas não testei fora da área de trabalho onde o gdesklets foi executado. No WindowMaker ficou meio "estranho", apresentando um reticulado ao redor dos displays (onde deveria ser transparente). No XFCE rodou perfeito. No Gnome, obviamente, rodou perfeito e no KDE também rodou :0).

Apesar do gdesklets ser pequeno, para instalar dá um "trabalhão", sendo necessário instalar muita coisa antes de se poder compilar ele com sucesso. Os passos que apresento a seguir são baseados num texto de um fórum de Linux internacional. Esse texto foi passado a mim pelo meu amigo do canal #gnulinux, o Goldblade, que tem usado com sucesso o gdesklets em seu FreeBSD :0).

OBS: minhas instruções vão diferir do texto do fórum internacional (LinuxQuestions.org) em alguns aspectos, sendo que além de tudo o que o texto original especifica, eu ainda tive que instalar mais uma dependência, além disso, o gdesklets especificado no texto do fórum, na prática, não funcionou comigo.

    Próxima página

Páginas do artigo
   1. Um pouco sobre o gdesklets
   2. Instalação das dependências
   3. Instalação do gdesklets
   4. Usando o gdesklets
   5. Instalando um display
   6. Usando um display
Outros artigos deste autor

Estratégias de backup e ferramentas livres

Instalando o antivírus BitDefender no Linux

Internacionalização de Caracteres em Computadores

Instalando EpiInfo 6.0.4d no Slackware 10.2

Instalando o OpenOffice

Leitura recomendada

Debian NetInstall: instalação personalizada

Convertendo o HP Pavilion dv2000 ao Ubuntu

Instalando o bbpager do Blackbox

Dhcp3-server e Bind9 no Debian 5 Lenny Linux

Integrando o BIND com DHCPd

  
Comentários
[1] Comentário enviado por simon em 18/12/2004 - 15:33h

Cara, muito bom o artigo e tal... Mas aqui da erro sempre, quando dou o $gdesklets , ele aparece uma janela informando o erro... Uso o fluxbox, e tal, mas ainda assim, nada:< Vou tentar pelo gnome, é só o tempo do emerge, hehe...

[2] Comentário enviado por cybercop em 19/12/2004 - 13:06h

Comigo tbm esta dando erro, formatei meu micro 2 vezes, e sempre da o mesmo erro, qdo digito gdesklets parece erro (na versao 0.32):

from line 3: HOME, USERHOME

e qdo baixo o pacote .tgz do linuxpackages.net da versao 0.30, aparece:

Connecting Daemon: Timeout

Estranho :/

[3] Comentário enviado por removido em 19/12/2004 - 14:25h

antes de fazer esse texto eu testei várias versões de gdesklets , incluindo pacotes do linuxpackages , mas nenhum funcionou ...
só fui ter "exito parcial" quando segui o texto do fõrum que o goldblade do canal #gnulinux tinha me passado ... mas mesmo assim o gdesklets não rodava direito ....
só consegui fazer o gdesklets rodar pra valer mesmo quando peguei a versão 0.32 e instalei o swig ....
agora os problemas que a maioria tem ao instalar o gdesklets parecem ser as
ínumeras dependencias que esses trecos de gnome exigem ... tanto é que eu
informo no texto que meu slack foi instalado em modo full (tudo que tem direito) , justamente pra não ter esse problema ... e mesmo assim ainda são necessários 5 "coisas" pro gdesklets rodar na minha máquina ...
portanto , quem seguir meu texto e mesmo assim o gdesklets não rodar , ou nem compilar , pode ter certeza : falta alguma lib do gnome no sistema ...

[4] Comentário enviado por Wesley F em 21/12/2004 - 13:16h

Eu instalei o gDesklets via ports aki no meu FreeBSD 5.3 ae eu inicio ele aparece assim

$ gdesklets
/usr/X11R6/bin/gdesklets:65: DeprecationWarning: the 'argc' parameter is optional and deprecated
client.set_restart_command(1, [sys.argv[0]])
gDesklets 0.26.2
Copyright (C) 2003, 2004 The gDesklets Team

This software is licensed under the terms of the GNU GPL.

e fica o cursor piscando e nao consigo fazer nada, pois nao aparece nada, so fica o cursor piscando, além do gdesklets tem que instalar outra coisa?

Se alguem puder me ajudar eu agradeço


Abraços



[5] Comentário enviado por removido em 21/12/2004 - 20:27h

eu só uso slackware ...
quem poderia ajudar vc seria o goldblade do canal #gnulinux da brasnet ....
ele instalou gdesklets em seu freebsd e obteve sucesso total (bem antes de eu
escrever o texto sobre o gdesklets) .

:0)

[6] Comentário enviado por Xterminator em 22/12/2004 - 05:58h

bom se ajudar ,eu uso gdesklets a algum tempo , e nas versões recentes algumas coistas mais são necessários para alguns famigerados displays .
um bom local pra começar ...
http://gnomesupport.org/forums/viewforum.php?f=23

[7] Comentário enviado por cybercop em 04/01/2005 - 15:44h

Pow coloquei um OUTRO tutorial de instalaçao do gdesklets no slack ja faz uma semana e nada buaaaaaaaaa!

Em 5 minutos da pra instalar a parada.

[8] Comentário enviado por cybercop em 04/01/2005 - 15:45h

OBS.: Soh falta o site publicar o tutorial!

[9] Comentário enviado por fabio em 04/01/2005 - 16:45h

O site está com um delay de 10 dias para publicação de artigos, porém... final de ano ninguém tem nada pra fazer, choveu artigos na fila de espera, lascou :)

Mas aguenta aí que a gente tarda mas não falha.

[]'s

[10] Comentário enviado por Gordon_Freeman em 08/01/2005 - 00:04h

O artigo ficou muito bom. Há muito tempo que tenho tentado instalar o gdesklet aqui em casa e com esse artigo eu consegui.
Valeu Megatron.
[]'s

[11] Comentário enviado por dark_slack em 12/01/2005 - 18:04h

eu instalei o gdesklets e quando dou o $gdesklets aparece isso aqui:

leo@darkstar:~$ gdesklets
Usage: gdesklets [option] <command> [arguments...]

<command>: open <files> (Opens the given display files)
start (Runs the gDesklets daemon)
stop (Stops the gDesklets daemon)
list (Lists open displays)
restart (Restarts the gDesklets daemon)
profile <profile> (Switches to the given profile)
profile (Shows the current and the available profiles)
shell (Opens the graphical shell)
slay (Kills the daemon -- use in emergency)
about (Prints information about gDesklets)
version (Prints gDesklets version)
help (Displays this text)

[option]: --translucent (Enables translucency on the freedesktop.org
XServer)


e depois quando uso o $gdesklets start aparece:

leo@darkstar:~$ gdesklets start
Traceback (most recent call last):
File "/usr/share/gdesklets/gdesklets-daemon", line 13, in ?
import gnome.ui
ImportError: No module named gnome.ui
Cannot establish connection to daemon : timout

[12] Comentário enviado por dark_slack em 12/01/2005 - 18:05h

Alguem sabe o que esta faltando instalar?

[13] Comentário enviado por strungle em 27/01/2005 - 01:03h

Parabéns Megatron, um belo artigo, tudo funcionou tranquilamente!
Valeu cara!
Abraço!

[14] Comentário enviado por dark_slack em 24/02/2005 - 12:48h

alguem consseguiu instalar o pyorbit sem problemas?

checking for ORBit-2.0 >= 2.4.4... Package ORBit-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `ORBit-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'ORBit-2.0' found

configure: error: Library requirements (ORBit-2.0 >= 2.4.4) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

[15] Comentário enviado por mophox em 07/03/2005 - 15:49h

Galera... o segredo é o seguinte:

ter instalado além dos pacotes listados no artigo (IMPORTANTE: compilados com "./configure --prefix=/usr) os seguintes pacotes:

- python 2.3.4 que vem com o próprio slack 10
- gnome-python 2.5.90 que pode ser baixado em www.linuxpackages.net

Depois de fuçar MUUUUUUUITO consegui instalar o gDesklets v0.32 :)

BOA SORTE a todos!

[16] Comentário enviado por rafaslack em 03/06/2005 - 19:10h

Pessoal gostaria de uma ajuda, eu fiz tudo o que o tutorial diz, instalei as dependencia so que na hora de configurar o gdesklets ele acontece o seguinte erro:

checking for pygtk-2.0 >= 2.4.0 pyorbit-2 >= 2.0.1 gnome-python-2.0 >=
2.6.0...
Requested 'pygtk-2.0 >= 2.4.0' but version of PyGTK is 2.2.0

configure: error: Library requirements (pygtk-2.0 >= 2.4.0 pyorbit-2 >=
2.0.1 gn
ome-python-2.0 >= 2.6.0) not met; consider adjusting the PKG_CONFIG_PATH
environ
ment variable if your libraries are in a nonstandard prefix so pkg-config
can find them.

O que devo fazer, alguem poderia ajudar?
Obrigado desde já

[17] Comentário enviado por medeiros64 em 30/01/2006 - 20:02h

fala aew magatron ha ha ha mais uma vez to aki perguntando p/ ti rsrsrs.
cara é o seguinte o gdesklets roda perfeitamente parabens pelo tuto só q to sofrendo aki rsrsr olha no gnome kde e bla bla bla funciona perfeitamente aparece o icone do gdesklets na barrinha do ambiente. ha ha ha mas eu uso o blackbox e no blackbox nao aparece icone nenhum na barrinha nao testei no flux mas sei q vc gosta muito do flux entao já deve ter testado.

bom me fala ai como faço o gdesklets funcionar no blacbox ???
vc já fez ?

cara valew e mais uma vez te agradecendo otmo tuto mesmo. e valew pelo material q vc disponiliza na net nao só aki mas como muitos sabem já ha muito material seu na net.

cara velew

[18] Comentário enviado por removido em 30/01/2006 - 20:56h

blackbox não tem um systemtray como o fluxbox , gnome , kde ...
é por isso que gdesklets não roda direito com o blackbox ....
recomendo passar pro fluxbox ...

[19] Comentário enviado por medeiros64 em 30/01/2006 - 21:42h

blz valew megatron intao to usando o flux ta show valew + uma vez t+ continue com seus tutos falow

[20] Comentário enviado por rafaslack em 14/06/2006 - 01:00h

Porque que o meu fica iniciando gdesklets-daemon......
Conectando ao servidor ...... e nao faz nada ate que manda a mensagem Cannot establish connection to daemon: timeout!
Porque isso, ele conecta em algum servidor pra poder abrir?
Vlw

[21] Comentário enviado por removido em 14/06/2006 - 09:01h

isso é coisa do gdesklets e do gnome ...

[22] Comentário enviado por rafaslack em 14/06/2006 - 16:33h

Hm mas eu não uso gnome então não vai funcionar?
Vlw

[23] Comentário enviado por removido em 14/06/2006 - 16:37h

gdesklets é coisa de gnome ....
assim como o superkaramba é do kde ...

[24] Comentário enviado por rafaslack em 14/06/2006 - 16:42h

Hm mas no superkaramba da pra fazer funcionar em outros gerenciadores e o gdesklets não tem como também?

[25] Comentário enviado por removido em 14/06/2006 - 16:45h

tanto o gdesklets como o superkaramba funcionam em outros gerenciadores de janelas , mas vc tem que ter o gnome e o kde instalados
no caso do superkaramba ainda tem que fazer uns "truques" pra ele funcionar "fora" do kde ....

[26] Comentário enviado por rafaslack em 14/06/2006 - 16:48h

Hm então teria que instalar o gnome para poder usar o gdesklets mas so instalando já funciona ou precisa fazer alguma coisa depois? Oks.
No caso do superkaramba os "truques" eu sei quais sãos rsrs
Vlw

[27] Comentário enviado por AlexMS em 15/07/2006 - 23:36h

eu não gostei muito do gdesklets... achei ele muito pobre em interface... tè

[28] Comentário enviado por st.pelgrim em 25/08/2007 - 11:35h

para quem precisar do ORBit2, como o dark_slack:
http://www.gnome.org/projects/ORBit2

[29] Comentário enviado por feliperossi em 22/03/2008 - 01:16h

cara ele abre e tudo mas nao to conseguindo colocar os plugins clico neles e nao aparece nda
tipo abre e tals system hdd clock calendario e tals mas nao consigo aplicar

[30] Comentário enviado por removido em 22/03/2008 - 15:24h

recomendo instalar pacotes já feitos pra versão da distro que vc usa
e é sempre bom lembrar : gdesklets precisa do gnome pra funcionar
e o slack atual não tem mais um gnome "oficial"


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts