Deixando o Debian redondo após instalação

Neste artigo vamos instalar e remover alguns programas no Debian, entre outras coisas, no intuito de melhorar o funcionamento deste sistema operacional de acordo com suas necessidades.

[ Hits: 43.941 ]

Por: André em 05/02/2010 | Blog: http://127.0.0.1


Instalando os interpretadores Perl, Python e Ruby



Se você quer programar em Perl, Python ou Ruby ou até mesmo usar um programa escrito nestas linguagens, vai precisar interpretar, e para interpretar precisaremos de um interpretador.

Vamos começar com o interpretador Perl.

P.S.: Se você seguiu a página anterior sobre adição de repositórios tudo vai correr bem! :)

Vire root mais uma vez no terminal e digite "apt-get install perl":

su root
# apt-get install perl


Ele vai lhe questionar o seguinte:

"É preciso baixar 8196kB de arquivos. Depois desta operação, 1118kB adicionais de espaço em disco serão usados."

Apenas tecle "s" e espere ele baixar e instalar o interpretador.

Depois de instalado, vamos verificar a versão do interpretador, para isso podemos usar o parâmetro -v:

# perl -v

Vamos a instalação do interpretador Python, que será praticamente a mesma coisa...

# apt-get install python

Ele vai lhe questionar:

"É preciso baixar 4277kB de arquivos. Depois desta operação, 65,5kB de espaço em disco serão liberados."

Tecle "s" como anteriormente e espere enquanto ele baixa e instala.

Depois de instalá-lo vamos testá-lo...

Digite:

# python

Vai aparecer algo como:

Python 2.5.4 (r254:67916, Jan 24 2010, 12:18:00)
[GCC 4.4.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>

Ali nós podemos "brincar" um pouco, digamos assim. Ex.:

>>> nome = 'Andre '
>>> sobrenome = 'Junior'
>>> nomecompleto = nome + sobrenome
>>> print nomecompleto
Andre Junior

Mas isso não vem ao caso...

Vamos a instalação do interpretador Ruby.

# apt-get install ruby irb rdoc

Ele vai lhe questionar:

"É preciso baixar 2997kB de arquivos. Depois desta operação, 8757kB adicionais de espaço em disco serão usados."

Como anteriormente, apenas tecle "s".

Vamos ver a versão instalada:

# ruby -v

A versão atual é a 1.8.7.

Página anterior     Próxima página

Páginas do artigo
   1. Introdução
   2. Adicionando os repositórios
   3. Instalando os interpretadores Perl, Python e Ruby
   4. Instalando o Pidgin e o Xchat
Outros artigos deste autor

Introdução a LUA, uma poderosa linguagem de programação

Gerenciamento de programas no Ubuntu através do Synaptic

A profissão: Programador

Introdução ao Anonimato na Web - Web Anonimity

Trabalhando com a interface gráfica em Java (parte 2)

Leitura recomendada

Cacti + Plugins (Settings, Monitor, Thold e Weathermap) - Instalação e configuração

VirtualBox com PHPvirtualbox em Servidor Ubuntu 14.04

Instalação do Redmine no CentOS 6

Criando pacotes no Slackware

PlayOnLinux - Compatibilidade de um jeito fácil

  
Comentários
[1] Comentário enviado por eldeablo em 05/02/2010 - 17:11h

Caro colega junior linux , você já deu um dist-upgrade com uma source assim? imagino se eu fizer, o debian se transformará em um verdadeiro frankenstein, no seu artigo não foi especificado se é lenny, squeeze ou sid, pois sua source mostra variantes dessas versões do debian, misturar sources é sempre perigoso, uso o squeeze aqui e tenho algumas dessas sources citadas no artigo, pois nunca se sabe os problemas que possam acarretar tal aventura!

Ai vai uma source redonda para o lenny;

#Repositorios Oficiais
deb http://ftp.br.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.br.debian.org/debian/ lenny main contrib non-free
deb http://ftp.br.debian.org/debian-security/ lenny/updates main
deb-src http://ftp.br.debian.org/debian-security/ lenny/updates main


#Repositorios Volateis
deb http://volatile.debian.org/debian-volatile/ lenny/volatile main
deb-src http://volatile.debian.org/debian-volatile/ lenny/volatile main


#Multimedia
deb http://www.debian-multimedia.org/">http://www.debian-multimedia.org/ lenny main
deb-src http://www.debian-multimedia.org lenny main

*para ativar o repositório multimedia
* wget http://debian-multimedia.org/gpgkey.pub -O - | apt-key add - && apt-get install debian-multimedia-keyring

Valeu! Abraço!

[2] Comentário enviado por andrezc em 05/02/2010 - 17:30h

Sim, está uma bagunça esse meu sources.list, tanto que já não estou usando o mesmo.

Agora estou usando apenas

#mirros de segurança

deb http://security.debian.org/ lenny/updates main contrib
deb-src http://security.debian.org/ lenny/updates main contrib

#mirros oficiais
deb ftp://ftp.br.debian.org/debian/ lenny main contrib non-free
deb http://linorg.usp.br/debian/ lenny main contrib non-free

#para usar os servidores abaixo basta remover o "#" e atualizar a lista de pacotes


#mirros multimidia

#deb http://debian-multimedia.org/ lenny main
#deb http://ftp.debian-unofficial.org/debian lenny main contrib non-free

#compiz-fusion
#deb http://apt-get.if.uff.br lenny-ifuff compiz

#opera
#deb http://deb.opera.com/opera/ lenny non-free


Pois no artigo eu não especifiquei o Debian, por isso aí tem repositórios até do etch.

E obrigado pela colaboração ;)

[3] Comentário enviado por andrezc em 05/02/2010 - 17:53h

Opa, acabei postando o mesmo que você, então... é esse mesmo que estou usando atualmente : )

[4] Comentário enviado por draggom em 05/02/2010 - 23:49h

Gostei muito do navegador: iceweasel, ele é leve e compacto e resolve o meu problema de pouca memoria no meu pentiun 4 com 256 mb de ram. É sempre bom ler e reler estas dicas de companheiros, mesmo que elas são repetitivas, ajuda bastante, principalmente aos novos usuários do debian.

[5] Comentário enviado por adsuporte em 11/02/2010 - 00:40h

boa noite, eu segui esse tuto para fazer a instalação do mozilla firefox, só que quando estou na parte final, onde eu do o ultimo comando aparece esta msgm:

(firefox-bin:16891): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

o que pode ser isso, sera que falta alguma dependencia, meu linux é o debian 5.0 lenny, e a instalação é nova!!

sera que alguem pode me ajudar?

valew


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts