Configurar rádio online com Icecast2 + Darkice

Fiz este tutorial porque não consegui achar algo completo para ajudar a criar uma rádio online. Este tutorial te explicará o básico para você colocar uma rádio pra funcionar no Linux, bem como explicando os problemas que tive e como resolvê-los.

[ Hits: 92.029 ]

Por: Jorge Andrade em 06/09/2007 | Blog: https://www.linkedin.com/in/jorgeflh/


Conclusão



Pronto!!! Depois de configurado o Darkice vamos executar o seguinte comando para que ele comece a trabalhar:

$ /usr/local/bin/darkice -v 0 -c /usr/local/etc/darkice.cfg &

Se você digitar novamente http://localhost:8000 e clicar no menu Administration, ele pedirá a senha de administrador do site (que foi configurada no arquivo icecast.xml) e você verá que existe um ponto de montagem funcionando chamado "radio". Todo o som do seu computador será capturado e mandado para o arquivo radio.mp3 da radio.

Para acessar a rádio de outro computador na mesma rede, supondo que o ip do servidor é 192.168.1.1, digite http://192.168.1.1:8000/radio.

Obs: Se você tentar acessar pelo Internet Explorer e o Media Player não tiver setado como padrão para tocar mp3, ele começará baixar o arquivo e nunca acabará, porque a rádio não pára. Neste caso abra o Media Player, vá em arquivo > abrir URL e digite o endereço.

Uma coisa que pode acontecer é você fazer tudo certo e o som não ser capturado. Isto pode ocorrer caso:
  • O dispositivo que você colocou na seção input não seja o correto na sua máquina;
  • Dentro do KDE, no Centro de controle > Som e Multimedia > Sistema de Som, na aba Hardware, não esteja setado a opção Full Duplex;
  • No Kmix, a configuração vai depender da placa de som, no meu caso, tenho que deixar setado, na aba Switches, a opção MIX, e para sair o som do microfone, deixar setado na aba Input, a opção de microfone (a verde).

Bom pessoal, com isso vocês conseguem colocar uma rádio no ar. Existem muitas configurações avançadas que vocês poderão ir aprendendo, pode ser feito um script no /etc/rc.d/ para iniciar os serviços, mais isso foge do escopo deste tutorial.

Página anterior    

Páginas do artigo
   1. Introdução
   2. Instalar Darkice
   3. Configurar Icecast2
   4. Configurar Darkice
   5. Conclusão
Outros artigos deste autor
Nenhum artigo encontrado.
Leitura recomendada

Servidor de rede (PDC - Proxy Transparente - DNS)

Cópia completa do HD - cluster por cluster

Usando OpenBSD como desktop

Instalando fontes TTF de forma fácil com rpm-buid

O desafio continua...

  
Comentários
[1] Comentário enviado por jorgeandrade em 06/09/2007 - 10:18h

Pessoal, só uma correção no artigo. Na página 3 "Configurando Icecast2" o caminho correto para o arquivo icecast.xml é /opt/icecast/etc/icecast.xml e não /usr/local/etc/icecast.xml

Abraços

[2] Comentário enviado por marcrock em 07/09/2007 - 17:49h

Ótimo artigo !!!!

Muito bem explicado.


Até +!!!!!!

[3] Comentário enviado por maickelpc em 22/11/2007 - 17:08h

qual a distribuicao mais adequada para configurar, estou tendo serios problemas com debian etch 4

[4] Comentário enviado por jorgeandrade em 25/11/2007 - 14:44h

Não tem nenhuma distribuição mais adequada, os passos utilizados devem funcionar em qualquer distribuição. É genérico

[5] Comentário enviado por quasedois em 13/11/2008 - 16:41h

ola, estou tentando configurar uma radio ao vivo, estou tentando na distribuição kubuntu, fiz tudo que esta descrito no artigo e mais algumas coisas, porem cheguei em um ponto que nao consigo passar

quando dou o comando para iniciar o darkice

/usr/local/bin/darkice -v 0 -c /usr/local/etc/darkice.cfg &

aparece:

/usr/local/bin/darkice: error while loading shared libraries: libmp3lame.so.0: cannot open shared object file: No such file or directory

ja instalei a biblioteca lame e quando fui instalar o darkice, foi atravez do comando

/home/labredes/Desktop/darkice-0.19# ./configure --with-lame-prefix=/usr/local/lib --with-twolame-prefix=/usr/local/lib

se alguem puder me ajudar fico grato

abrs

[6] Comentário enviado por quasedois em 17/11/2008 - 16:25h

Alguem ?

[7] Comentário enviado por quasedois em 21/11/2008 - 13:32h

Ja ta resolvido!

[8] Comentário enviado por don_murilo em 29/01/2009 - 10:02h

Estou tendo problema na instalação da 1ª pagina, estou fazendo a instalação no suse linux

[9] Comentário enviado por carlotres em 23/02/2009 - 09:27h

[email protected]:/etc/icecast# icecast
[23/Feb/2009:09:24:52] No configfile found, using defaults.
Icecast Version 1.3.12 Initializing...
Icecast comes with NO WARRANTY, to the extent permitted by law.
You may redistribute copies of Icecast under the terms of the
GNU General Public License.
For more information about these matters, see the file named COPYING.
Starting thread engine...
[23/Feb/2009:09:24:52] Icecast Version 1.3.12 Starting..
[23/Feb/2009:09:24:52] Starting Admin Console Thread...
-> [23/Feb/2009:09:24:52] Starting main connection handler...
-> [23/Feb/2009:09:24:52] Bind to socket on port 8000 failed. Shutting down now.
-> [23/Feb/2009:09:24:52] Cleanly shutting down...
-> [23/Feb/2009:09:24:52] Closing all listening sockets...
-> [23/Feb/2009:09:24:52] Telling threads to die...
-> [23/Feb/2009:09:24:52] Closing sockets for admins that keep hanging around...
-> [23/Feb/2009:09:24:52] Closing sockets for sources that keep hanging around...
-> [23/Feb/2009:09:24:52] Closing all remaining sockets...
-> [23/Feb/2009:09:24:52] Waiting a wee while to let the other threads die..
-> -> [23/Feb/2009:09:24:53] Ok, that's enough, let's kill the remaining 1 bugger
-> [23/Feb/2009:09:24:53] Closing and removing directory servers...
-> [23/Feb/2009:09:24:53] Removing remaining sources...
-> [23/Feb/2009:09:24:53] Exiting..
-> [email protected]:/etc/icecast#
isso acontece quando eu tento ligar o icecast.. e aliás .. meu ./configure , nem omake e nem o make install tão funfando

[10] Comentário enviado por halfling em 09/06/2009 - 19:12h

Olá, você saberia me dizer qual é o calculo de banda usada?

[11] Comentário enviado por ruben5wat em 08/09/2009 - 11:31h

./configure --prefix=/opt/icecast/ alguem pode explicar melhor este passo?

Obrigado (:

[12] Comentário enviado por ruben5wat em 13/09/2009 - 15:26h

resolvido

[13] Comentário enviado por vinigeremia em 10/08/2010 - 10:34h

Existe a possibilidade de receber a entrada do line-in? preciso mto
halp. obrigado

[14] Comentário enviado por mdajesus em 17/09/2010 - 11:26h

OLA VINIGEREMIA, LEIA AQUI NESSE LINK DO SITE PCWORLD: http://pcworld.uol.com.br/dicas/2008/04/28/como-montar-um-podcast-sua-radio-virtual-usando-ubuntu-li...

[15] Comentário enviado por marcelovegano em 28/04/2011 - 23:08h

Eu montei a rádio, porém apenas eu consigo escutar, como eu jogo ela para que todos que tenham internet escutam?

[16] Comentário enviado por LeticiaCastro em 16/06/2011 - 16:07h

Seu tutorial está muito bom, Jorge. Mas, que pena, aqui tem muitas informações boas para quem se interessa em criar uma rádio online:

http://www.masternewmedia.com.br/publicacoes_de_audio_e_musica/radio/web-radio-on-line-como-criar-a-...

[17] Comentário enviado por Ruwindows em 27/12/2011 - 14:59h

Quando entro com o comando:
/opt/icecast/bin/icecast -c /opt/icecast/etc/icecast.xml &

aparece isto!!!!!


[email protected]:~# /opt/icecast/bin/icecast -c /opt/icecast/etc/icecast.xml &
[1] 20953
[email protected]:~# ERROR: You should not run icecast2 as root
Use the changeowner directive in the config file

[1]+ Exit 1 /opt/icecast/bin/icecast -c /opt/icecast/etc/icecast.xml

[email protected]:~#

[18] Comentário enviado por mateus_stalin em 18/10/2016 - 18:07h

O meu está retornando com a seguinte mensagem:

root# darkice -c /etc/icecast2/darkice.cfg
DarkIce 0.20.1 live audio streamer, http://darkice.tyrell.hu/
Copyright (c) 2000-2007, Tyrell Hungary, http://tyrell.hu/

Using config file: /etc/icecast2/darkice.cfg
Using OSS DSP input device: /dev/dsp
Using POSIX real-time scheduling, priority 98
DarkIce: OssDspSource.cpp:291: read error [0]
------------------------------------------------------------------------------

Ele não mostra o ponto de montagem /radio quando eu acesso via browser, e não há nenhum processo do Darkice rodando no linux.

Ja analisei todas as configurações, reiniciei o servidor e nada.

Alguma sugestão? Detalhe, estava funcionando e simplesmente PAROU.


Contribuir com comentário