Compilando Apache 2 com PHP, MySQL, mod_perl e mod_ssl

cvs

Este artigo nos mostra como fazer para turbinar seu Apache 2 com alguns de seus módulos mais populares, tudo isso a partir do zero, com 100% dos pacotes compilados na mão.

[ Hits: 81.915 ]

Por: Thiago Alves em 10/08/2004 | Blog: http://www.seeufosseopresidente.com.br


Downloads



Vamos pegar os pacotes.

MySQL:
http://dev.mysql.com/get/Downloads/.../mysql-4.0.18.tar.gz
Recomendo baixar essa versão e compilar.

Apache:
http://ftp.pucpr.br/apache/httpd/
Baixe a ultima versão da série 2.

PHP:
http://www.php.net/downloads.php
Quando esse artigo foi escrito a ultima versão era a 4.3.6

mod_perl:
http://ftp.pucpr.br/apache/perl/

Agora vamos para a compilação dos pacotes.

Página anterior     Próxima página

Páginas do artigo
   1. Introdução
   2. Downloads
   3. Compilando MySQL, Apache e PHP
   4. Compilando mod_perl
   5. Considerações finais
Outros artigos deste autor

Gaim + Gaim Encryption - Bate-papo com segurança

Tornando o OpenBSD stable

Montando um PDC com OpenBSD

Virtualização com CentOS e VMware Server

Servidor Web com NetBSD (Apache + PHP + MySQL + *)

Leitura recomendada

Guia introdutório do Linux IV

Trabalhando com arquivos e diretórios

Fundamentos do sistema Linux - Gerenciadores de inicialização

Enviando email das atividades do proFTPD

Completando o Ubuntu (para principiantes)

  
Comentários
[1] Comentário enviado por wronieri em 10/08/2004 - 10:00h

Muito bom artigo mas uma dúvida, eu tenho instalado o Apache 2 no Red Hat 9 e nunca consegui levantar o serviço não ser se é porque uso bale modem mas ele sempre da uma mensagem de erro e o ip 127.0.0.1 já tentei de tudo e não vai o q pode ser?

[2] Comentário enviado por cvs em 10/08/2004 - 10:03h

qual é a mensagem exata do tal erro?

[3] Comentário enviado por wronieri em 10/08/2004 - 10:14h

Esta mensagem: "Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName".

[4] Comentário enviado por cvs em 10/08/2004 - 10:21h

isso não é um erro, ele manda esse aviso mas mesmo assim inicia o apache, normalmente é o que acontece.

[5] Comentário enviado por wronieri em 10/08/2004 - 10:23h

Ele inicia de boa? porque no meu ele dá o [FALHOU] ao invés do [OK] mas mesmo assim vou dar uma olhada mais detalhada para ver se o serviço está ou não rodando... mesmo assim valeu!

[6] Comentário enviado por y2h4ck em 10/08/2004 - 12:43h

wronieri, para resolver e simples,
edite o /etc/hosts
e adicione o seu hostname com o ip 127.0.0.1

Isso acontece pq ele nao ve nenhum Ip associado ao
ServerName do seu httpd.conf.


[7] Comentário enviado por wronieri em 10/08/2004 - 13:57h

Valeu Y2h4ck era isto mesmo :-)

[8] Comentário enviado por agk em 11/08/2004 - 08:55h

Parabéns pelo artigo, e wronieri você pode usar na opção ServerName do seu httpd.conf o ip da sua máquina que também resolve o problema.
[ ]'s

[9] Comentário enviado por katito em 27/01/2005 - 19:22h

estou salvando as minhas paginas no /var/www e quando escrevo no navegador localhost/*.php aparece uma janela pra eu baixar o arquivo php nao visualiza oq eh isso?

[10] Comentário enviado por cvs em 28/01/2005 - 00:12h

cara, não se faz isso não... coloca http://localhost/nome.php... Tá configurado de forma correta, fez tudo certinho, sem nenhum erro?

[11] Comentário enviado por albert em 09/11/2005 - 11:26h

Uso o Slackware 10.2 e atualizei para o Apache2 e o php5 usando arquivos tgz. O apache roda beleza, mas quando executo o arquivo com <?php phpinfo();?> apenas aparece uma tela em branco. APENAS UMA TELA EM BRANCO. Chequei o httpd.conf e está tudo instalado corretamente. Alguém faz idéia o que pode ser?

[12] Comentário enviado por Rafael1986 em 20/01/2006 - 16:51h

kras, eu tinha o apache 1.3, e resolvi instalar o 2.0, seguindo este tutorial.. porém, qndo dou o lynx http:// -dump -head ele me retorna o server antigo, 1.3 com suporte a php somente. Ja restartei o server, mas nau madiaontou nda
pq isso?

[13] Comentário enviado por fablinuxer em 30/11/2006 - 17:00h

cvs, é uma satisfação muito grande estar falando com vc pela primeira vez, estou ultizando seu tuto e estou tendo algums problemas bem quando executo os procedimentos depois de compliar e instalar o mysql da esse erro:
/usr/local/mysql/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)'
Check that mysqld is running and that the socket: '/tmp/mysql.sock' exists!
e mesmo tentano copiar de /var/run/mysql/mysql.sock não é permitido e com esse erro atrapalha a compilação de php, será uq tem com resolver isso?
abraço amigo

[14] Comentário enviado por fablinuxer em 30/11/2006 - 17:09h

Ha... e outro erro é que quando tento o comando /usr/local/mysql/bin/mysql -u root -p o erro é o segiumte ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (111) mais uma vez valeu ..

[15] Comentário enviado por duduzinhu em 22/06/2007 - 16:58h

Comecei a tentar criar um WebServer a pouco tempo 1º configurei o apache2 corretamente depois o desinstalei para tentar colocar o meu servidor a roda o apache2+php5 e vi q era nescessário instalar o mysql para q fosse possivel o php rodar no servidor depois de ter lido uns 20 tutoriais de criação de WebServer em linux, a propósito o meu é um FedoraCore 6. Tentei centenas de vezes configurar um servidor com apache2+mysql+php5, li diversos de tutoriais mas sempre na hora de compilar o mysql da um erro diferente sendo q sigo o tutorial certinho mas mesmo assim da erro. Nem terminei de ler esse tutorial pq qdo tento compilar o mysql que é o q se deve faser 1º nesse tuto da o seguinte erro:
checking for termcap functions library... configure: error: No curses/termcap library found
... uso o gcc pra compilar os source-codes, ja formatei o meu pc e tentei seguir um tutorial desde o começo mas sempre da esse erro na hora de instalar o mysql,se puder me ajudar me manda um e-mail ([email protected]), desde já obrigado.

[16] Comentário enviado por dorivansousa em 25/08/2007 - 20:33h

eu tentei instalar o mysql no ubuntu e mostrou esse erro tambem (error: No curses/termcap library found)
apos muita procura na internet achei uma dica que manda rodar esse comando:
apt-get install libncurses5-dev

no meu caso resolveu

[17] Comentário enviado por helioalb em 23/12/2007 - 15:14h

Olá Thiago, poderia dizer que você é meu herói, estava a tempos tentando instalar Apache+PHP+MySql via repositório no meu Debian, e nada dava certo, agora ta tudo rodando bunitinho. Valeu mesmo.

Falowww

[18] Comentário enviado por removido em 13/03/2008 - 03:02h

artigo show de bola


Contribuir com comentário