OpenVPN Debian 7

1. OpenVPN Debian 7

Tiago Shimizu
tiagoshimizu

(usa Debian)

Enviado em 23/11/2014 - 21:12h

Olá a todos.

Configurei um servidor openvpn em um ambiente de teste com debian 7 x64.
Mando rodar o servidor e tudo dá certo.
Configuro a estação cliente, com windows 7 x32 e mando conectar e recebo a mensagem que está conectado. Recebo um endereço de ip e tudo porem, não tenho acesso a nenhuma informação! Tanto ping do servidor para o cliente, quanto cliente servidor não retorna nada.

Onde posso estar errando?
Alguém poderia me ajudar?
Seguem meus arquivos de configuração:

[Servidor]
local 192.168.1.250
port 1194
proto udp
dev tun
ca keys/ca.crt
cert keys/server.crt
key keys/server.key # This file should be kept secret
dh keys/dh1024.pem
server 10.8.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
client-to-client
keepalive 10 120
tls-auth keys/ta.key 0 # This file is secret
cipher AES-256-CBC
comp-lzo
max-clients 3
persist-key
persist-tun
status openvpn-status.log
log /var/log/openvpn.log
verb 3

[Cliente]
client
dev tun
proto udp
remote 192.168.1.250 1194 # use IP or hostname
resolv-retry infinite
nobind
persist-key
persist-tun
ca keys/ca.crt
cert keys/client1.crt
key keys/client1.key
tls-auth keys/ta.key 1
ns-cert-type server
cipher AES-256-CBC
comp-lzo
verb 3
pull dhcp-options
status openvpn-status.log
auth-user-pass

Obrigado.



  


2. Re: OpenVPN Debian 7

Geowany Galdino
geowany

(usa Debian)

Enviado em 24/11/2014 - 04:05h

Como estão as configurações do firewall (iptables)?


3. Re: OpenVPN Debian 7

Tiago Shimizu
tiagoshimizu

(usa Debian)

Enviado em 24/11/2014 - 07:32h

Primeiramente, obrigado pela ajuda.
Visto se tratar de um ambiente de teste, liberei um monte de portas e nada. Fiz o redirecionamento dos pacotes de dados da eth0 para a tun0 e também não resolveu.
Quais seriam as principais portas que teria que abrir para começar a funcionar?
Obrigado.


4. Re: OpenVPN Debian 7

Tiago Shimizu
tiagoshimizu

(usa Debian)

Enviado em 26/11/2014 - 20:01h

Pessoal, mesmo dando um iptables -F ele não acessa as informações no servidor!

O que percebi é que quando mando dar um ping da estação cliente para o servidor, ele mostra na tela de acompanhamento de tráfego na rede que foram enviados e recebidos alguns bits mas não responde ao ping.
Alguma ajuda?
Obrigado.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts