Problema estação sem internet [RESOLVIDO]

1. Problema estação sem internet [RESOLVIDO]

Adriano
DR1CO

(usa Outra)

Enviado em 23/12/2020 - 18:01h

Olá, estou com a distro DB10 buster.
A estação está funcionando, pega o dhcp, porém não funciona internet nela.

Alguém poderia me ajudar?
============================
dhcpd.conf

ddns-update-style none;
log-facility local7;
subnet 192.168.10.0 netmask 255.255.255.0 {
range 192.168.10.151 192.168.10.199;
option domain-name-servers 8.8.8.8, 8.8.4.4;
option domain-name "drico.com.br";
option routers 192.168.10.1;
option broadcast-address 255.255.255.255;
default-lease-time 600;
max-lease-time 7200;
}
========================================
interfaces
allow-hotplug enp4s0
iface enp4s0 inet static
address 192.168.10.1
netmask 255.255.255.0
network 192.168.10.0
broadcast 192.168.10.255

allow-hotplug enp1s0
iface enp1s0 inet dhcp
========================

enp1s0 - interface que recebe internet
enp4s0 - interface que deveria distribuir internet para o ambiente.



  


2. Re: Problema estação sem internet [RESOLVIDO]

Marcelo Oliver
msoliver

(usa Debian)

Enviado em 23/12/2020 - 18:49h


DR1CO escreveu:

Olá, estou com a distro DB10 buster.
A estação está funcionando, pega o dhcp, porém não funciona internet nela.

Alguém poderia me ajudar?
============================
dhcpd.conf

ddns-update-style none;
log-facility local7;
subnet 192.168.10.0 netmask 255.255.255.0 {
range 192.168.10.151 192.168.10.199;
option domain-name-servers 8.8.8.8, 8.8.4.4;
option domain-name "drico.com.br";
option routers 192.168.10.1;
option broadcast-address 255.255.255.255;
default-lease-time 600;
max-lease-time 7200;
}
========================================
interfaces
allow-hotplug enp4s0
iface enp4s0 inet static
address 192.168.10.1
netmask 255.255.255.0
network 192.168.10.0
broadcast 192.168.10.255

allow-hotplug enp1s0
iface enp1s0 inet dhcp
========================

enp1s0 - interface que recebe internet
enp4s0 - interface que deveria distribuir internet para o ambiente.

Boa noite.
Configurou o servidor para compartilhar a "internet"?


______________________________________________________________________
Importante: lynx --dump goo.gl/a9KeFc|sed -nr '/^[ ]+Se/,/dou.$/p'
Att.: Marcelo Oliver
______________________________________________________________________
Nota de esclarecimento:
O comando: lynx --dump goo.gl/a9KeFc|sed -nr '/^[ ]+Se/,/dou.$/p',
faz parte da minha assinatura.
O qual, "filtra" a página: "https://www.vivaolinux.com.br/termos-de-uso/",
Mostrando o seguinte:

Se você sanou sua dúvida ou resolveu um problema a partir de um
tópico criado, é extremamente recomendável que acesse o tópico e
marque-o como "RESOLVIDO". E mais recomendável ainda que você eleja
como melhor resposta a que mais lhe ajudou.


______________________________________________________________________



3. Re: Problema estação sem internet [RESOLVIDO]

Stanislaus K
StanislausK

(usa FreeBSD)

Enviado em 23/12/2020 - 21:31h

Ola,

"Alguém poderia me ajudar?"

você fez o roteamento:

/etc/sysctl.conf
net.ipv4.ip_forward=1

e como está o firewall?



4. Re: Problema estação sem internet [RESOLVIDO]

Adriano
DR1CO

(usa Outra)

Enviado em 25/12/2020 - 13:27h

msoliver escreveu:


DR1CO escreveu:

Olá, estou com a distro DB10 buster.
A estação está funcionando, pega o dhcp, porém não funciona internet nela.

Alguém poderia me ajudar?
============================
dhcpd.conf

ddns-update-style none;
log-facility local7;
subnet 192.168.10.0 netmask 255.255.255.0 {
range 192.168.10.151 192.168.10.199;
option domain-name-servers 8.8.8.8, 8.8.4.4;
option domain-name "drico.com.br";
option routers 192.168.10.1;
option broadcast-address 255.255.255.255;
default-lease-time 600;
max-lease-time 7200;
}
========================================
interfaces
allow-hotplug enp4s0
iface enp4s0 inet static
address 192.168.10.1
netmask 255.255.255.0
network 192.168.10.0
broadcast 192.168.10.255

allow-hotplug enp1s0
iface enp1s0 inet dhcp
========================

enp1s0 - interface que recebe internet
enp4s0 - interface que deveria distribuir internet para o ambiente.

Boa noite.
Configurou o servidor para compartilhar a "internet"?


______________________________________________________________________
Importante: lynx --dump goo.gl/a9KeFc|sed -nr '/^[ ]+Se/,/dou.$/p'
Att.: Marcelo Oliver
______________________________________________________________________
Nota de esclarecimento:
O comando: lynx --dump goo.gl/a9KeFc|sed -nr '/^[ ]+Se/,/dou.$/p',
faz parte da minha assinatura.
O qual, "filtra" a página: "https://www.vivaolinux.com.br/termos-de-uso/",
Mostrando o seguinte:

Se você sanou sua dúvida ou resolveu um problema a partir de um
tópico criado, é extremamente recomendável que acesse o tópico e
marque-o como "RESOLVIDO". E mais recomendável ainda que você eleja
como melhor resposta a que mais lhe ajudou.


______________________________________________________________________

Eu realmente não sei, apanhei bastante pra fazer o dhcp funcionar, preciso fazer mais alguma coisa pelo jeito, pois a internet não passa pra estação. Se tiver alguma dica, o que precisar só pedir rsrs



5. Re: Problema estação sem internet [RESOLVIDO]

Adriano
DR1CO

(usa Outra)

Enviado em 25/12/2020 - 13:30h

StanislausK escreveu:

Ola,

"Alguém poderia me ajudar?"

você fez o roteamento:

/etc/sysctl.conf
net.ipv4.ip_forward=1

e como está o firewall?


Eu vou conseguir verificar na segunda a linha, lembro que no init.d não tinha o arquivo firewall, e criei um e coloquei as regras, depois com pesquisas descobri que no db10 se chama ufw, baixei e instalei(criou o seu prórpio arquivo na init.d), mas não alterei nenhum parâmetro nele.


6. Re: Problema estação sem internet [RESOLVIDO]

Adriano
DR1CO

(usa Outra)

Enviado em 28/12/2020 - 08:59h

StanislausK escreveu:

Ola,

"Alguém poderia me ajudar?"

você fez o roteamento:

/etc/sysctl.conf
net.ipv4.ip_forward=1

e como está o firewall?


Verifiquei a linha, e esta conforme você disse =1, porém não passa internet


7. Re: Problema estação sem internet [RESOLVIDO]

Adriano
DR1CO

(usa Outra)

Enviado em 28/12/2020 - 09:04h

StanislausK escreveu:

Ola,

"Alguém poderia me ajudar?"

você fez o roteamento:

/etc/sysctl.conf
net.ipv4.ip_forward=1

e como está o firewall?

O firewall esta padrão (ufw) não cheguei a alterar ele

#!/bin/sh

### BEGIN INIT INFO
# Provides: ufw
# Required-Start: $local_fs
# Required-Stop: $local_fs
# Default-Start: S
# Default-Stop: 1
# Short-Description: start firewall
# Description: Start ufw firewall
### END INIT INFO

set -e

PATH="/sbin:/bin"

[ -d /lib/ufw ] || exit 0

. /lib/lsb/init-functions

for s in "/lib/ufw/ufw-init-functions" "/etc/ufw/ufw.conf" "/etc/default/ufw" ; do
if [ -s "$s" ]; then
. "$s"
else
log_failure_msg "Could not find $s (aborting)"
exit 1
fi
done

error=0
case "$1" in
start)
if [ "$ENABLED" = "yes" ] || [ "$ENABLED" = "YES" ]; then
log_action_begin_msg "Starting firewall:" "ufw"
output=`ufw_start` || error="$?"
if [ "$error" = "0" ]; then
log_action_cont_msg "Setting kernel variables ($IPT_SYSCTL)"
fi
if [ ! -z "$output" ]; then
echo "$output" | while read line ; do
log_action_cont_msg "$line"
done
fi
else
log_action_begin_msg "Skip starting firewall:" "ufw (not enabled)"
fi
log_action_end_msg $error
exit $error
;;
stop)
if [ "$ENABLED" = "yes" ] || [ "$ENABLED" = "YES" ]; then
log_action_begin_msg "Stopping firewall:" "ufw"
output=`ufw_stop` || error="$?"
if [ ! -z "$output" ]; then
log_action_cont_msg "$output"
fi
else
log_action_begin_msg "Skip stopping firewall:" "ufw (not enabled)"
fi
log_action_end_msg $error
exit $error
;;
restart|force-reload)
log_action_begin_msg "Reloading firewall:" "ufw"
output=`ufw_reload` || error="$?"
if [ ! -z "$output" ]; then
log_action_cont_msg "$output"
fi
log_action_end_msg $error
exit $error
;;
status)
output=`ufw_status` || error="$?"
if [ ! -z "$output" ]; then
log_action_cont_msg "$output"
fi
log_action_end_msg $error
exit $error
;;
*)
echo "Usage: /etc/init.d/ufw {start|stop|restart|force-reload|status}"
exit 1
;;
esac

exit 0
===================================
Copiei e colei exatamente como está.

Me ajuda pois só falta isso pra finalizar rsrs (passar internet)



8. Re: Problema estação sem internet [RESOLVIDO]

Adriano
DR1CO

(usa Outra)

Enviado em 28/12/2020 - 09:15h

msoliver escreveu:

Boa noite.
Configurou o servidor para compartilhar a "internet"?


______________________________________________________________________
Importante: lynx --dump goo.gl/a9KeFc|sed -nr '/^[ ]+Se/,/dou.$/p'
Att.: Marcelo Oliver
______________________________________________________________________
Nota de esclarecimento:
O comando: lynx --dump goo.gl/a9KeFc|sed -nr '/^[ ]+Se/,/dou.$/p',
faz parte da minha assinatura.
O qual, "filtra" a página: "https://www.vivaolinux.com.br/termos-de-uso/",
Mostrando o seguinte:

Se você sanou sua dúvida ou resolveu um problema a partir de um
tópico criado, é extremamente recomendável que acesse o tópico e
marque-o como "RESOLVIDO". E mais recomendável ainda que você eleja
como melhor resposta a que mais lhe ajudou.


______________________________________________________________________


Eu achei que fosse só no sysctl.conf, mas tem coisa no firewall pelo que parece, porém não sei como prosseguir


9. Re: Problema estação sem internet [RESOLVIDO]

Adriano
DR1CO

(usa Outra)

Enviado em 28/12/2020 - 10:43h

DR1CO escreveu:

Eu achei que fosse só no sysctl.conf, mas tem coisa no firewall pelo que parece, porém não sei como prosseguir


Pessoal, apliquei esses 2 comandos e funcionou.

echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -j MASQUERADE

Antes eu tinha aplicado o 2º comando, só que com a interface de rede mencionada, ACHO que por isso não tinha funcionado.