como remover o pacote [RESOLVIDO]

1. como remover o pacote [RESOLVIDO]

eduardo henrique martins
eduardohelite

(usa Outra)

Enviado em 13/10/2019 - 21:35h

Ola estou instalando o agente em um servidor de email porem esta dando conflito como remover o outro pacote?


Transaction check error:
file /etc/zabbix/zabbix_agentd.conf from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-2.0.21-1.el7.x86_64
file /etc/logrotate.d/zabbix-agent from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /etc/zabbix/zabbix_agentd.conf from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /usr/lib/systemd/system/zabbix-agent.service from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /usr/sbin/zabbix_agentd from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /usr/share/man/man8/zabbix_agentd.8.gz from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /var/run/zabbix from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /var/log/zabbix from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64


  


2. Re: como remover o pacote [RESOLVIDO]

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 13/10/2019 - 22:33h

Você precisa dar mais alguns detalhes, como distro e versão dela que você utiliza.



3. Re: como remover o pacote [RESOLVIDO]

Gabriel
rabbit

(usa Debian)

Enviado em 13/10/2019 - 23:00h

Posta aí o comando que você executou.


x.x
run rabbit run


4. Re: como remover o pacote [RESOLVIDO]

eduardo henrique martins
eduardohelite

(usa Outra)

Enviado em 14/10/2019 - 11:06h

estou utilizando o comando .

yum install zabbix-agent

onde o mesmo nao instala e apresenta que ha um conflito.

[root@teste~]$yum install zabbix-agent
Plugins carregados: fastestmirror, langpacks
base | 3.6 kB 00:00:00
base-debuginfo | 2.5 kB 00:00:00
base-source | 2.9 kB 00:00:00
centosplus-source | 2.9 kB 00:00:00
extras | 2.9 kB 00:00:00
extras-source | 2.9 kB 00:00:00
fasttrack | 2.9 kB 00:00:00
remi | 3.0 kB 00:00:00
remi-debuginfo | 3.0 kB 00:00:00
remi-php55 | 3.0 kB 00:00:00
remi-php55-debuginfo | 3.0 kB 00:00:00
remi-php56 | 3.0 kB 00:00:00
remi-php56-debuginfo | 3.0 kB 00:00:00
remi-safe | 3.0 kB 00:00:00
remi-test | 3.0 kB 00:00:00
remi-test-debuginfo | 3.0 kB 00:00:00
rpmfind | 5.3 kB 00:00:00
updates | 2.9 kB 00:00:00
updates-source | 2.9 kB 00:00:00
zabbix | 2.9 kB 00:00:00
zabbix-non-supported | 951 B 00:00:00
Loading mirror speeds from cached hostfile
* base: linorg.usp.br
* extras: mirror.fileplanet.com
* fasttrack: linorg.usp.br
* remi: remi.xpg.com.br
* remi-php55: remi.xpg.com.br
* remi-php56: remi.xpg.com.br
* remi-safe: remi.xpg.com.br
* remi-test: remi.xpg.com.br
* updates: linorg.usp.br
Resolvendo dependências
--> Executando verificação da transação
---> O pacote zabbix-agent.x86_64 0:3.0.28-1.el7 será instalado
--> Resolução de dependências finalizada

Dependências resolvidas

======================================================================================================================================================================================
Package Arq. Versão Repo Tam.
======================================================================================================================================================================================
Instalando:
zabbix-agent x86_64 3.0.28-1.el7 zabbix 347 k

Resumo da transação
======================================================================================================================================================================================
Instalar 1 Package

Tamanho total: 347 k
Tamanho depois de instalado: 1.3 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
file /etc/zabbix/zabbix_agentd.conf from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-2.0.21-1.el7.x86_64
file /etc/logrotate.d/zabbix-agent from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /etc/zabbix/zabbix_agentd.conf from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /usr/lib/systemd/system/zabbix-agent.service from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /usr/sbin/zabbix_agentd from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /usr/share/man/man8/zabbix_agentd.8.gz from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /var/run/zabbix from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /var/log/zabbix from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64

Sumário de erros


5. Re: como remover o pacote [RESOLVIDO]

felipe jareta
fjareta

(usa Outra)

Enviado em 14/10/2019 - 12:47h

eduardohelite escreveu:

estou utilizando o comando .

yum install zabbix-agent

onde o mesmo nao instala e apresenta que ha um conflito.

[root@teste~]$yum install zabbix-agent
Plugins carregados: fastestmirror, langpacks
base | 3.6 kB 00:00:00
base-debuginfo | 2.5 kB 00:00:00
base-source | 2.9 kB 00:00:00
centosplus-source | 2.9 kB 00:00:00
extras | 2.9 kB 00:00:00
extras-source | 2.9 kB 00:00:00
fasttrack | 2.9 kB 00:00:00
remi | 3.0 kB 00:00:00
remi-debuginfo | 3.0 kB 00:00:00
remi-php55 | 3.0 kB 00:00:00
remi-php55-debuginfo | 3.0 kB 00:00:00
remi-php56 | 3.0 kB 00:00:00
remi-php56-debuginfo | 3.0 kB 00:00:00
remi-safe | 3.0 kB 00:00:00
remi-test | 3.0 kB 00:00:00
remi-test-debuginfo | 3.0 kB 00:00:00
rpmfind | 5.3 kB 00:00:00
updates | 2.9 kB 00:00:00
updates-source | 2.9 kB 00:00:00
zabbix | 2.9 kB 00:00:00
zabbix-non-supported | 951 B 00:00:00
Loading mirror speeds from cached hostfile
* base: linorg.usp.br
* extras: mirror.fileplanet.com
* fasttrack: linorg.usp.br
* remi: remi.xpg.com.br
* remi-php55: remi.xpg.com.br
* remi-php56: remi.xpg.com.br
* remi-safe: remi.xpg.com.br
* remi-test: remi.xpg.com.br
* updates: linorg.usp.br
Resolvendo dependências
--> Executando verificação da transação
---> O pacote zabbix-agent.x86_64 0:3.0.28-1.el7 será instalado
--> Resolução de dependências finalizada

Dependências resolvidas

======================================================================================================================================================================================
Package Arq. Versão Repo Tam.
======================================================================================================================================================================================
Instalando:
zabbix-agent x86_64 3.0.28-1.el7 zabbix 347 k

Resumo da transação
======================================================================================================================================================================================
Instalar 1 Package

Tamanho total: 347 k
Tamanho depois de instalado: 1.3 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
file /etc/zabbix/zabbix_agentd.conf from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-2.0.21-1.el7.x86_64
file /etc/logrotate.d/zabbix-agent from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /etc/zabbix/zabbix_agentd.conf from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /usr/lib/systemd/system/zabbix-agent.service from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /usr/sbin/zabbix_agentd from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /usr/share/man/man8/zabbix_agentd.8.gz from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /var/run/zabbix from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64
file /var/log/zabbix from install of zabbix-agent-3.0.28-1.el7.x86_64 conflicts with file from package zabbix20-agent-2.0.21-1.el7.x86_64

Sumário de erros


Olá amigo.
Já tentou remover pelo próprio yum?

yum remove -y zabbix20-2.0.21-1.el7.x86_64

Isso deve resolver seu problema, se não der certo tente verificar qual o nome correto do pacote antigo e usar o mesmo comando.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts